aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-12-07 19:00:07 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-12-07 19:00:07 +0000
commit5f2d5cf80a2054e86c38cdd487d8d344c1c40cbe (patch)
treeb7fa5bf621f30a950808719f76ffb66050ee125b
parent30ec49f1f3f22e24a6e9785b7782d25afe59c98e (diff)
downloadports-5f2d5cf80a2054e86c38cdd487d8d344c1c40cbe.tar.gz
ports-5f2d5cf80a2054e86c38cdd487d8d344c1c40cbe.zip
devel/py-yunomi: Metrics library with rate, distribution and timing information
yunomi provides insights to the internal behavior of an application, providing useful statistics and metrics on selected portions of your code. It's a Python port of the core portion of a Java Metrics library by Coda Hale. WWW: https://github.com/dreid/yunomi PR: ports/184581 Submitted by: Johannes Jost Meixner <xmj chaot.net>
Notes
Notes: svn path=/head/; revision=335841
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-yunomi/Makefile30
-rw-r--r--devel/py-yunomi/distinfo2
-rw-r--r--devel/py-yunomi/pkg-descr5
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 60c61771505b..973990e3a3ff 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3840,6 +3840,7 @@
SUBDIR += py-yapps2
SUBDIR += py-ydbf
SUBDIR += py-yum-metadata-parser
+ SUBDIR += py-yunomi
SUBDIR += py-z3c.autoinclude
SUBDIR += py-z3c.batching
SUBDIR += py-z3c.caching
diff --git a/devel/py-yunomi/Makefile b/devel/py-yunomi/Makefile
new file mode 100644
index 000000000000..f1611aa58b5e
--- /dev/null
+++ b/devel/py-yunomi/Makefile
@@ -0,0 +1,30 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= yunomi
+PORTVERSION= 0.3.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= Metrics library with rate, distribution and timing information
+
+LICENSE= MIT
+
+PORTDOCS= README.rst \
+ HISTORY.rst
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_AUTOPLIST= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/py-yunomi/distinfo b/devel/py-yunomi/distinfo
new file mode 100644
index 000000000000..822384ff3612
--- /dev/null
+++ b/devel/py-yunomi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (yunomi-0.3.0.tar.gz) = 91fceddbb4716cba81219a1f70dd3814e128a4352698520e1ed355ab9cb7db87
+SIZE (yunomi-0.3.0.tar.gz) = 14218
diff --git a/devel/py-yunomi/pkg-descr b/devel/py-yunomi/pkg-descr
new file mode 100644
index 000000000000..5419a3e43bdc
--- /dev/null
+++ b/devel/py-yunomi/pkg-descr
@@ -0,0 +1,5 @@
+yunomi provides insights to the internal behavior of an application, providing
+useful statistics and metrics on selected portions of your code. It's a Python
+port of the core portion of a Java Metrics library by Coda Hale.
+
+WWW: https://github.com/dreid/yunomi