aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-18 17:59:34 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-18 18:05:14 +0000
commit5f369cb4b991964caee14c0474a99e9b9a091752 (patch)
treeac6f9c7a8ba60ea7e11f65512d9e84da9f7aa17f
parenta5a037dcb1ee764ccaa3202f96edd45a824b8cea (diff)
downloadports-5f369cb4b991964caee14c0474a99e9b9a091752.tar.gz
ports-5f369cb4b991964caee14c0474a99e9b9a091752.zip
x11-fonts/py-cffsubr: Use tx from x11-fonts/afdko as embedded tx (built from external/afdko)
- Update RUN_DEPENDS: afdko is already RUN_DEPENDS of py-afdko - Bump PORTREVISION for package change PR: 270135 Reported by: Ting-Wei Lan <lantw44@gmail.com>
-rw-r--r--x11-fonts/py-cffsubr/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-fonts/py-cffsubr/Makefile b/x11-fonts/py-cffsubr/Makefile
index ea17300fe146..060e09c772ee 100644
--- a/x11-fonts/py-cffsubr/Makefile
+++ b/x11-fonts/py-cffsubr/Makefile
@@ -1,5 +1,6 @@
PORTNAME= cffsubr
PORTVERSION= 0.2.9.post1
+PORTREVISION= 1
CATEGORIES= x11-fonts python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,16 +13,21 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}afdko>=0:x11-fonts/py-afdko@${PY_FLAVOR} \
+RUN_DEPENDS= tx:x11-fonts/afdko \
+ ${PYTHON_PKGNAMEPREFIX}afdko>=0:x11-fonts/py-afdko@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}fonttools>=4.10.2:print/py-fonttools@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+PLIST_FILES= ${PYTHON_SITELIBDIR}/cffsubr/tx
post-patch:
# Clean up bundled libraries
@${RM} -r ${WRKSRC}/external/
+post-install:
+ ${LN} -s ${LOCALBASE}/bin/tx ${STAGEDIR}${PYTHON_SITELIBDIR}/cffsubr/tx
+
.include <bsd.port.mk>