aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-01-02 17:07:10 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-01-03 14:09:41 +0000
commit5f48a463f2c8ed784dcbce02c9f8089c4c899ca9 (patch)
tree8e187d9581ab5a106d7daecfd67dfdbe5edd2a81
parente7f90c256436b9165c3eaa4c1ef723ac2b46cf10 (diff)
downloadports-5f48a463f2c8ed784dcbce02c9f8089c4c899ca9.tar.gz
ports-5f48a463f2c8ed784dcbce02c9f8089c4c899ca9.zip
devel/llvm15: remove ELFv1 support
-rw-r--r--devel/llvm15/Makefile4
-rw-r--r--devel/llvm15/files/patch-clang_lib_Driver_ToolChains_Clang.cpp (renamed from devel/llvm15/files/extra-patch-clang_lib_Driver_ToolChains_Clang.cpp)0
2 files changed, 0 insertions, 4 deletions
diff --git a/devel/llvm15/Makefile b/devel/llvm15/Makefile
index 3489ca09a29a..3651f6dda433 100644
--- a/devel/llvm15/Makefile
+++ b/devel/llvm15/Makefile
@@ -256,10 +256,6 @@ MLIR_PATTERN= ${MLIR_COMMANDS:S/^/bin./:tW:C/ */|/g}|mlir|libMLIR|obj.MLIRCAP
.include <bsd.port.options.mk>
-.if defined(PPC_ABI) && ${PPC_ABI} == ELFv2
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-clang_lib_Driver_ToolChains_Clang.cpp
-.endif
-
# keep in sync with /usr/src/lib/clang/clang.build.mk
# ----------- start of sync block ------------------
# Armv6 and armv7 uses hard float abi, unless the CPUTYPE has soft in it.
diff --git a/devel/llvm15/files/extra-patch-clang_lib_Driver_ToolChains_Clang.cpp b/devel/llvm15/files/patch-clang_lib_Driver_ToolChains_Clang.cpp
index 37304e59f444..37304e59f444 100644
--- a/devel/llvm15/files/extra-patch-clang_lib_Driver_ToolChains_Clang.cpp
+++ b/devel/llvm15/files/patch-clang_lib_Driver_ToolChains_Clang.cpp