aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2024-10-05 22:59:13 +0000
committerDimitry Andric <dim@FreeBSD.org>2024-10-20 09:58:05 +0000
commit5f8037e8c926def9d6e9d13f4038502f6ea82c30 (patch)
tree98ecf307fed2d90464519aa6b5794a3eb0c7934c
parent558b064f290da383bfb1dfc57eedaa4f0fb2e045 (diff)
downloadports-5f8037e8c926def9d6e9d13f4038502f6ea82c30.tar.gz
ports-5f8037e8c926def9d6e9d13f4038502f6ea82c30.zip
math/cgal: fix headers for use with clang 19
Clang 19 has become more strict about errors in member functions, which results in errors building ports that use headers from math/cgal, such as cad/csxcad: In file included from /wrkdirs/usr/ports/cad/csxcad/work/CSXCAD-0.6.3/src/CSPrimPolyhedron.cpp:25: In file included from /wrkdirs/usr/ports/cad/csxcad/work/CSXCAD-0.6.3/src/CSPrimPolyhedron_p.h:6: In file included from /usr/local/include/CGAL/Polyhedron_3.h:25: In file included from /usr/local/include/CGAL/HalfedgeDS_default.h:23: In file included from /usr/local/include/CGAL/boost/graph/graph_traits_HalfedgeDS_default.h:15: In file included from /usr/local/include/CGAL/boost/graph/graph_traits_HalfedgeDS.h:29: /usr/local/include/CGAL/boost/graph/iterator.h:224:22: error: no member named 'base' in 'Halfedge_around_source_iterator<Graph>' 224 | return (! (this->base() == nullptr)) ? | ~~~~ ^ /usr/local/include/CGAL/boost/graph/iterator.h:324:22: error: no member named 'base' in 'Halfedge_around_target_iterator<Graph>' 324 | return (! (this->base() == nullptr)) ? | ~~~~ ^ /usr/local/include/CGAL/boost/graph/iterator.h:423:22: error: no member named 'base' in 'Halfedge_around_face_iterator<Graph>' 423 | return (! (this->base() == nullptr)) ? | ~~~~ ^ The problem is that the `base()` member function is only available when an iterator is derived from `boost::iterator_adaptor`, but the three iterators mentioned above, `Halfedge_around_source_iterator`, `Halfedge_around_target_iterator` and `Halfedge_around_face_iterator` are not. Upstream CGAL has done a bit more refactoring in this particular area, but is enough to cherry-pick the changes that remove the `operator bool_type() const` member functions, which reference the non-existing `base()` member function. Bump PORTREVISION to ensure dependent ports build against the fixed headers. PR: 281880 Approved by: maintainer timeout (2 weeks) MFH: 2024Q4 (cherry picked from commit 54b05f1c1eb7a7d7d8ffa823c19babe8dae9fc66)
-rw-r--r--math/cgal/Makefile2
-rw-r--r--math/cgal/files/patch-include_CGAL_boost_graph_iterator.h59
2 files changed, 60 insertions, 1 deletions
diff --git a/math/cgal/Makefile b/math/cgal/Makefile
index a06e69bc8721..c25dd21e17a8 100644
--- a/math/cgal/Makefile
+++ b/math/cgal/Makefile
@@ -1,6 +1,6 @@
PORTNAME= cgal
PORTVERSION= 5.5.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= https://github.com/${PORTNAME:tu}/${PORTNAME}/releases/download/v${PORTVERSION}/
DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
diff --git a/math/cgal/files/patch-include_CGAL_boost_graph_iterator.h b/math/cgal/files/patch-include_CGAL_boost_graph_iterator.h
new file mode 100644
index 000000000000..20f360c1f045
--- /dev/null
+++ b/math/cgal/files/patch-include_CGAL_boost_graph_iterator.h
@@ -0,0 +1,59 @@
+--- include/CGAL/boost/graph/iterator.h.orig 2022-10-07 19:04:41 UTC
++++ include/CGAL/boost/graph/iterator.h
+@@ -213,18 +213,7 @@ class Halfedge_around_source_iterator { (public)
+ {}
+
+ #ifndef DOXYGEN_RUNNING
+- // design patter: "safe bool"
+- // will be replaced by explicit operator bool with C++11
+- typedef void (Halfedge_around_source_iterator::*bool_type)() const;
+
+- void this_type_does_not_support_comparisons() const {}
+-
+- operator bool_type() const
+- {
+- return (! (this->base() == nullptr)) ?
+- &Halfedge_around_source_iterator::this_type_does_not_support_comparisons : 0;
+- }
+-
+ bool operator==( const Self& i) const {
+ CGAL_assertion( anchor == anchor);
+ return ( g == i.g) && ( pos == i.pos) && ( winding == i.winding);
+@@ -313,18 +302,7 @@ class Halfedge_around_target_iterator { (public)
+ {}
+
+ #ifndef DOXYGEN_RUNNING
+- // design patter: "safe bool"
+- // will be replaced by explicit operator bool with C++11
+- typedef void (Halfedge_around_target_iterator::*bool_type)() const;
+
+- void this_type_does_not_support_comparisons() const {}
+-
+- operator bool_type() const
+- {
+- return (! (this->base() == nullptr)) ?
+- &Halfedge_around_target_iterator::this_type_does_not_support_comparisons : 0;
+- }
+-
+ bool operator==( const Self& i) const {
+ CGAL_assertion( anchor == anchor);
+ return ( g == i.g) && ( pos == i.pos) && ( winding == i.winding);
+@@ -411,18 +389,6 @@ class Halfedge_around_face_iterator { (public)
+ const value_type& operator * ( ) const { return pos; }
+ pointer operator -> ( ) { return &pos; }
+ const value_type* operator -> ( ) const { return &pos; }
+-
+- // design patter: "safe bool"
+- // will be replaced by explicit operator bool with C++11
+- typedef void (Halfedge_around_face_iterator::*bool_type)() const;
+-
+- void this_type_does_not_support_comparisons() const {}
+-
+- operator bool_type() const
+- {
+- return (! (this->base() == nullptr)) ?
+- &Halfedge_around_face_iterator::this_type_does_not_support_comparisons : 0;
+- }
+
+ bool operator==( const Self& i) const {
+ CGAL_assertion( anchor == anchor);