aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2024-02-25 11:41:17 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2024-02-26 17:54:38 +0000
commit5ffc7be915856fa656b06fd773d8012f9b4572e5 (patch)
tree5774dafdec31af4485f1055a8a01375a9e90f597
parente615d22b478578e71cb904c09ac3ae0fab20db05 (diff)
downloadports-5ffc7be915856fa656b06fd773d8012f9b4572e5.tar.gz
ports-5ffc7be915856fa656b06fd773d8012f9b4572e5.zip
devel/libtai: moved manpages to share/man
Fix do-install target and plist to install manpages in share/man Reorder and format Makefile to make linter happy
-rw-r--r--devel/libtai/Makefile24
-rw-r--r--devel/libtai/files/patch-Makefile4
-rw-r--r--devel/libtai/files/patch-conf-ccso4
-rw-r--r--devel/libtai/files/patch-leadsecs_read.c4
-rw-r--r--devel/libtai/files/patch-leapsecs.34
-rw-r--r--devel/libtai/files/patch-make-compile.sh4
-rw-r--r--devel/libtai/files/patch-make-makelibso.sh4
-rw-r--r--devel/libtai/files/patch-yearcal.c4
-rw-r--r--devel/libtai/pkg-plist22
9 files changed, 37 insertions, 37 deletions
diff --git a/devel/libtai/Makefile b/devel/libtai/Makefile
index 9a74731dea5f..3015827a548d 100644
--- a/devel/libtai/Makefile
+++ b/devel/libtai/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libtai
PORTVERSION= 0.60
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel
MASTER_SITES= http://cr.yp.to/libtai/ \
ftp://ftp.task.gda.pl/mirror/mirror.qmail.org/koobera/pub/software/
@@ -11,16 +11,16 @@ WWW= https://cr.yp.to/libtai.html
LICENSE= UNLICENSE
-CONFLICTS_INSTALL= mess822
-
-ALL_TARGET= it
USES= groff
USE_LDCONFIG= yes
MAKE_ENV= LIBVERSION="${LIBVERSION}"
MAKE_JOBS_UNSAFE= yes
+ALL_TARGET= it
-PLIST_SUB= LIBVERSION=${LIBVERSION} \
- LIBFILE=${LIBFILE}
+CONFLICTS_INSTALL= mess822
+
+PLIST_SUB= LIBFILE=${LIBFILE} \
+ LIBVERSION=${LIBVERSION}
MAN_FILES= caldate.3 caldate_mjd.3 caltime.3 caltime_tai.3 leapsecs.3 \
tai.3 tai_now.3 tai_pack.3 taia.3 taia_now.3 taia_pack.3
@@ -40,6 +40,11 @@ do-configure:
# update leap seconds table
@${CAT} ${FILESDIR}/leapsecs-update.txt >> ${WRKSRC}/leapsecs.txt
+post-build:
+ @${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ${WRKSRC}/leapsecs < ${WRKSRC}/leapsecs.txt > \
+ ${WRKSRC}/leapsecs.dat
+
pre-install:
# correct header locations inside files
.for file in ${HEADER_FILES}
@@ -47,15 +52,10 @@ pre-install:
${WRKSRC}/${file}
.endfor
-post-build:
- @${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
- ${WRKSRC}/leapsecs < ${WRKSRC}/leapsecs.txt > \
- ${WRKSRC}/leapsecs.dat
-
do-install:
${INSTALL_DATA} ${WRKSRC}/leapsecs.dat ${STAGEDIR}${PREFIX}/etc
.for i in ${MAN_FILES}
- ${INSTALL_MAN} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/man/man3
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/share/man/man3
.endfor
.for i in ${PROGRAM_FILES}
${INSTALL_PROGRAM} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
diff --git a/devel/libtai/files/patch-Makefile b/devel/libtai/files/patch-Makefile
index 01e4ba96bd13..776ec2d96c0b 100644
--- a/devel/libtai/files/patch-Makefile
+++ b/devel/libtai/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Oct 13 14:52:20 1998
-+++ Makefile Fri Jun 16 20:30:27 2000
+--- Makefile.orig Tue Oct 13 14:52:20 1998 UTC
++++ Makefile
@@ -5,10 +5,11 @@
default: it
diff --git a/devel/libtai/files/patch-conf-ccso b/devel/libtai/files/patch-conf-ccso
index 235040125e43..8b2229b4e728 100644
--- a/devel/libtai/files/patch-conf-ccso
+++ b/devel/libtai/files/patch-conf-ccso
@@ -1,4 +1,4 @@
---- conf-ccso.orig Wed Dec 31 21:00:00 1969
-+++ conf-ccso Fri Jun 16 19:17:52 2000
+--- conf-ccso.orig Wed Dec 31 21:00:00 1969 UTC
++++ conf-ccso
@@ -0,0 +1 @@
+-fPIC -DPIC
diff --git a/devel/libtai/files/patch-leadsecs_read.c b/devel/libtai/files/patch-leadsecs_read.c
index 4705cda0fe54..f9cf1a43b559 100644
--- a/devel/libtai/files/patch-leadsecs_read.c
+++ b/devel/libtai/files/patch-leadsecs_read.c
@@ -1,5 +1,5 @@
---- leapsecs_read.c.orig Fri Jun 16 22:44:31 2000
-+++ leapsecs_read.c Fri Jun 16 22:45:17 2000
+--- leapsecs_read.c.orig Fri Jun 16 22:44:31 2000 UTC
++++ leapsecs_read.c
@@ -18,7 +18,7 @@
int i;
struct tai u;
diff --git a/devel/libtai/files/patch-leapsecs.3 b/devel/libtai/files/patch-leapsecs.3
index 02d1a1a19eb0..b36f9eafb517 100644
--- a/devel/libtai/files/patch-leapsecs.3
+++ b/devel/libtai/files/patch-leapsecs.3
@@ -1,5 +1,5 @@
---- leapsecs.3.orig Fri Jun 16 22:44:24 2000
-+++ leapsecs.3 Fri Jun 16 22:44:47 2000
+--- leapsecs.3.orig Fri Jun 16 22:44:24 2000 UTC
++++ leapsecs.3
@@ -52,10 +52,10 @@
.B leapsecs_read
diff --git a/devel/libtai/files/patch-make-compile.sh b/devel/libtai/files/patch-make-compile.sh
index 611bb2f8fbed..e5a01ec1670f 100644
--- a/devel/libtai/files/patch-make-compile.sh
+++ b/devel/libtai/files/patch-make-compile.sh
@@ -1,5 +1,5 @@
---- make-compile.sh.orig Tue Oct 13 14:52:20 1998
-+++ make-compile.sh Fri Jun 16 19:18:35 2000
+--- make-compile.sh.orig Tue Oct 13 14:52:20 1998 UTC
++++ make-compile.sh
@@ -1 +1,2 @@
-echo exec "$CC" -c '${1+"$@"}'
+echo "$CC" -c '${1+"$@"}'
diff --git a/devel/libtai/files/patch-make-makelibso.sh b/devel/libtai/files/patch-make-makelibso.sh
index 1a7426e975ab..c2660f9cd14e 100644
--- a/devel/libtai/files/patch-make-makelibso.sh
+++ b/devel/libtai/files/patch-make-makelibso.sh
@@ -1,5 +1,5 @@
---- make-makelibso.sh.orig Wed Dec 31 21:00:00 1969
-+++ make-makelibso.sh Fri Jun 16 19:32:24 2000
+--- make-makelibso.sh.orig Wed Dec 31 21:00:00 1969 UTC
++++ make-makelibso.sh
@@ -0,0 +1,3 @@
+echo 'main="$1"; shift'
+echo 'rm -f "$main"'
diff --git a/devel/libtai/files/patch-yearcal.c b/devel/libtai/files/patch-yearcal.c
index c12bc4f68956..08aac57665fc 100644
--- a/devel/libtai/files/patch-yearcal.c
+++ b/devel/libtai/files/patch-yearcal.c
@@ -1,5 +1,5 @@
---- yearcal.c.orig 1998-10-13 18:52:20.000000000 +0200
-+++ yearcal.c 2011-07-01 09:45:48.000000000 +0200
+--- yearcal.c.orig 1998-10-13 18:52:20 UTC
++++ yearcal.c
@@ -16,7 +16,7 @@
, "December"
} ;
diff --git a/devel/libtai/pkg-plist b/devel/libtai/pkg-plist
index 2557c9945b59..640ab6e1a2f5 100644
--- a/devel/libtai/pkg-plist
+++ b/devel/libtai/pkg-plist
@@ -11,15 +11,15 @@ include/libtai/uint64.h
lib/%%LIBFILE%%.a
lib/%%LIBFILE%%.so
lib/%%LIBFILE%%.so.%%LIBVERSION%%
-man/man3/caldate.3.gz
-man/man3/caldate_mjd.3.gz
-man/man3/caltime.3.gz
-man/man3/caltime_tai.3.gz
-man/man3/leapsecs.3.gz
-man/man3/tai.3.gz
-man/man3/tai_now.3.gz
-man/man3/tai_pack.3.gz
-man/man3/taia.3.gz
-man/man3/taia_now.3.gz
-man/man3/taia_pack.3.gz
+share/man/man3/caldate.3.gz
+share/man/man3/caldate_mjd.3.gz
+share/man/man3/caltime.3.gz
+share/man/man3/caltime_tai.3.gz
+share/man/man3/leapsecs.3.gz
+share/man/man3/tai.3.gz
+share/man/man3/tai_now.3.gz
+share/man/man3/tai_pack.3.gz
+share/man/man3/taia.3.gz
+share/man/man3/taia_now.3.gz
+share/man/man3/taia_pack.3.gz
@(,,0644) etc/leapsecs.dat