aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-12 12:07:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-12 12:07:34 +0000
commit601956149b27af07bc8df4fdaa92b2a476d1b147 (patch)
tree1c336c087670f3e1078d9638955b2da8f35d97cc
parentc41e1105201a126f09b5536708c14e39ca591b5e (diff)
downloadports-601956149b27af07bc8df4fdaa92b2a476d1b147.tar.gz
ports-601956149b27af07bc8df4fdaa92b2a476d1b147.zip
Add rubygem-protocol-websocket 0.7.5
Protocol::WebSocket provides a low-level implementation of the WebSocket protocol according to RFC6455. It only implements the latest stable version (13). WWW: https://github.com/socketry/protocol-websocket
Notes
Notes: svn path=/head/; revision=548316
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-protocol-websocket/Makefile22
-rw-r--r--www/rubygem-protocol-websocket/distinfo3
-rw-r--r--www/rubygem-protocol-websocket/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e6dab6f0a0db..bfe4f3e256a6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1974,6 +1974,7 @@
SUBDIR += rubygem-protocol-http
SUBDIR += rubygem-protocol-http1
SUBDIR += rubygem-protocol-http2
+ SUBDIR += rubygem-protocol-websocket
SUBDIR += rubygem-puma
SUBDIR += rubygem-puma_worker_killer
SUBDIR += rubygem-pusher-client
diff --git a/www/rubygem-protocol-websocket/Makefile b/www/rubygem-protocol-websocket/Makefile
new file mode 100644
index 000000000000..43a2fffb1748
--- /dev/null
+++ b/www/rubygem-protocol-websocket/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= protocol-websocket
+PORTVERSION= 0.7.5
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Low level implementation of the WebSocket protocol
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-protocol-http>=0.2<1:www/rubygem-protocol-http \
+ rubygem-protocol-http1>=0.2<1:www/rubygem-protocol-http1
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-protocol-websocket/distinfo b/www/rubygem-protocol-websocket/distinfo
new file mode 100644
index 000000000000..c6d3899278ed
--- /dev/null
+++ b/www/rubygem-protocol-websocket/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1599729127
+SHA256 (rubygem/protocol-websocket-0.7.5.gem) = 9e2625291cf19fa947fd864b72c70f48ed404be8be1a1b578218c65c356765c7
+SIZE (rubygem/protocol-websocket-0.7.5.gem) = 9216
diff --git a/www/rubygem-protocol-websocket/pkg-descr b/www/rubygem-protocol-websocket/pkg-descr
new file mode 100644
index 000000000000..37199d629673
--- /dev/null
+++ b/www/rubygem-protocol-websocket/pkg-descr
@@ -0,0 +1,5 @@
+Protocol::WebSocket provides a low-level implementation of the WebSocket
+protocol according to RFC6455. It only implements the latest stable version
+(13).
+
+WWW: https://github.com/socketry/protocol-websocket