aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-05 14:15:14 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-05 14:23:45 +0000
commit601e20d746af455809adab05ed06802de0332a60 (patch)
treedfbcbbf3b8cda79581fcb650888f3e80c89c87d6
parent148f9e0f2cd9090ac22b2a426ee382c312ece6a6 (diff)
downloadports-601e20d746af455809adab05ed06802de0332a60.tar.gz
ports-601e20d746af455809adab05ed06802de0332a60.zip
security/snort3: Update version 3.1.62.0=>3.1.63.0
- Refresh patches - Control linking against libunwind [1] Changelog: https://github.com/snort3/snort3/releases/tag/3.1.63.0 Co-authored-by: Chad Jacob Milios <milios@ccsys.com> PR: 266485 Reported by: milios@ccsys.com
-rw-r--r--security/snort3/Makefile7
-rw-r--r--security/snort3/distinfo6
-rw-r--r--security/snort3/files/patch-cmake_include__libraries.cmake10
-rw-r--r--security/snort3/files/patch-config.cmake.h.in4
-rw-r--r--security/snort3/files/patch-src_control_control.h5
5 files changed, 22 insertions, 10 deletions
diff --git a/security/snort3/Makefile b/security/snort3/Makefile
index 0ff859f9ed97..71aa6baeaaa8 100644
--- a/security/snort3/Makefile
+++ b/security/snort3/Makefile
@@ -1,5 +1,5 @@
PORTNAME= snort
-DISTVERSION= 3.1.62.0
+DISTVERSION= 3.1.63.0
PORTEPOCH= 1
CATEGORIES= security
PKGNAMESUFFIX= 3
@@ -32,7 +32,7 @@ CMAKE_ARGS+= -DFLEX_INCLUDE_DIR_HINT:PATH=${PREFIX}/include/flex
CONFLICTS= snort-2*
OPTIONS_DEFINE= ADDRESSSANITIZER DEBUG DOCS FLATBUFFERS HYPERSCAN \
- LARGEPCAP PIE STATICDAQ THREADSANITIZER TSC
+ LARGEPCAP LIBUNWIND PIE STATICDAQ THREADSANITIZER TSC
OPTIONS_DEFAULT= STATICDAQ
OPTIONS_DEFAULT_amd64= HYPERSCAN
OPTIONS_SUB= yes
@@ -41,6 +41,7 @@ ADDRESSSANITIZER_DESC= Enable address sanitizer
FLATBUFFERS_DESC= Enable flatbuffers support
HYPERSCAN_DESC= Enable high-performance regular expression lib
LARGEPCAP_DESC= Enable support for pcaps larger than 2 GB
+LIBUNWIND_DESC= Print stack trace in case of crash
PIE_DESC= Enable PIE (Broken)
STATICDAQ_DESC= Link static DAQ modules
THREADSANITIZER_DESC= Enable thread sanitizer
@@ -54,6 +55,8 @@ HYPERSCAN_LIB_DEPENDS= libhs.so:devel/hyperscan
HYPERSCAN_PLIST_SUB= HYPERSCAN=""
HYPERSCAN_PLIST_SUB_OFF= HYPERSCAN="@comment "
LARGEPCAP_CMAKE_BOOL= ENABLE_LARGE_PCAP
+LIBUNWIND_LIB_DEPENDS= libunwind.so:devel/libunwind
+LIBUNWIND_CMAKE_BOOL= ENABLE_LIBUNWIND
PIE_CMAKE_BOOL= ENABLE_PIE
STATICDAQ_CMAKE_BOOL= ENABLE_STATIC_DAQ
THREADSANITIZER_CMAKE_BOOL= ENABLE_THREAD_SANITIZER
diff --git a/security/snort3/distinfo b/security/snort3/distinfo
index b2a59b2a94d7..946233af3512 100644
--- a/security/snort3/distinfo
+++ b/security/snort3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1685101117
-SHA256 (snort3-snort3-3.1.62.0_GH0.tar.gz) = 1f18936da65d52702f75e5b9ffe2cfbc9c9373201801ad275f6e636451f7e06f
-SIZE (snort3-snort3-3.1.62.0_GH0.tar.gz) = 3245025
+TIMESTAMP = 1685968779
+SHA256 (snort3-snort3-3.1.63.0_GH0.tar.gz) = 7ca415ac8098cd5ee001dc751966d4a6028961ca9cfc788447b7ea7048f53f85
+SIZE (snort3-snort3-3.1.63.0_GH0.tar.gz) = 3246802
diff --git a/security/snort3/files/patch-cmake_include__libraries.cmake b/security/snort3/files/patch-cmake_include__libraries.cmake
new file mode 100644
index 000000000000..e6956ad1c847
--- /dev/null
+++ b/security/snort3/files/patch-cmake_include__libraries.cmake
@@ -0,0 +1,10 @@
+--- cmake/include_libraries.cmake.orig 2023-06-05 12:40:26 UTC
++++ cmake/include_libraries.cmake
+@@ -26,4 +26,6 @@ if (ENABLE_SAFEC)
+ endif (ENABLE_SAFEC)
+ find_package(ICONV QUIET)
+ find_package(UUID QUIET)
+-find_package(Libunwind)
++if (ENABLE_LIBUNWIND)
++ find_package(Libunwind)
++endif (ENABLE_LIBUNWIND)
diff --git a/security/snort3/files/patch-config.cmake.h.in b/security/snort3/files/patch-config.cmake.h.in
index 31b9973dfe56..46b4fec88ac8 100644
--- a/security/snort3/files/patch-config.cmake.h.in
+++ b/security/snort3/files/patch-config.cmake.h.in
@@ -1,6 +1,6 @@
---- config.cmake.h.in.orig 2021-03-27 18:13:03 UTC
+--- config.cmake.h.in.orig 2023-06-02 19:53:06 UTC
+++ config.cmake.h.in
-@@ -167,5 +167,8 @@
+@@ -173,5 +173,8 @@
/* Define if `thread_local` keyword should be used */
#cmakedefine USE_THREAD_LOCAL 1
diff --git a/security/snort3/files/patch-src_control_control.h b/security/snort3/files/patch-src_control_control.h
index 96725a313534..d99f74fa5418 100644
--- a/security/snort3/files/patch-src_control_control.h
+++ b/security/snort3/files/patch-src_control_control.h
@@ -1,7 +1,6 @@
---- src/control/control.h.orig 2021-09-08 19:39:41 UTC
+--- src/control/control.h.orig 2023-06-02 19:53:06 UTC
+++ src/control/control.h
-@@ -26,6 +26,7 @@
- #include <cstdarg>
+@@ -28,6 +28,7 @@
#include <queue>
#include <string>
#include <vector>