aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2023-02-13 13:23:10 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2023-02-13 13:23:10 +0000
commit602b040678a73adec7d1d298b41676a38559fe49 (patch)
tree9e97acebd36d251c405553fa37fbb51a1977f58c
parent05305e7571b27f3513a00105e281c3e64992d2a6 (diff)
downloadports-602b040678a73adec7d1d298b41676a38559fe49.tar.gz
ports-602b040678a73adec7d1d298b41676a38559fe49.zip
net-mgmt/openbmp: Fix build
librdkafka added libcurl dependency openbmp's cmake is not smart to get it alone
-rw-r--r--net-mgmt/openbmp/Makefile2
-rw-r--r--net-mgmt/openbmp/files/patch-Server_CMakeLists.txt30
2 files changed, 24 insertions, 8 deletions
diff --git a/net-mgmt/openbmp/Makefile b/net-mgmt/openbmp/Makefile
index b3579ca0f40a..2c21496e9357 100644
--- a/net-mgmt/openbmp/Makefile
+++ b/net-mgmt/openbmp/Makefile
@@ -1,7 +1,7 @@
PORTNAME= openbmp
DISTVERSIONPREFIX= v
DISTVERSION= 0.14.0
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= net-mgmt
MAINTAINER= pizzamig@FreeBSD.org
diff --git a/net-mgmt/openbmp/files/patch-Server_CMakeLists.txt b/net-mgmt/openbmp/files/patch-Server_CMakeLists.txt
index 42fe05df7869..28ecb7738702 100644
--- a/net-mgmt/openbmp/files/patch-Server_CMakeLists.txt
+++ b/net-mgmt/openbmp/files/patch-Server_CMakeLists.txt
@@ -1,6 +1,6 @@
---- Server/CMakeLists.txt.orig 2018-03-06 18:31:59 UTC
-+++ Server/CMakeLists.txt
-@@ -24,6 +24,23 @@ find_path(LIBYAML_CPP_INCLUDE_DIR
+--- Server/CMakeLists.txt.orig 2018-03-06 19:31:59.000000000 +0100
++++ Server/CMakeLists.txt 2023-02-13 13:54:14.656995000 +0100
+@@ -24,6 +24,31 @@
PATH_SUFFIXES
include)
@@ -20,24 +20,40 @@
+ PATH_SUFFIXES
+ lib)
+
++find_library(LIBCURL_LIBRARY_DIR
++ NAMES
++ libcurl.so
++ HINTS
++ ${HINT_ROOT_DIR}
++ PATH_SUFFIXES
++ lib64
++ lib)
+
find_library(LIBYAML_CPP_LIBRARY
NAMES
libyaml-cpp.a yaml-cpp
-@@ -84,6 +101,7 @@ endif()
+@@ -33,6 +58,7 @@
+ lib64
+ lib)
+
++
+ find_path(LIBRDKAFKA_INCLUDE_DIR
+ librdkafka/rdkafkacpp.h
+ HINTS
+@@ -84,6 +110,7 @@
# Update the include dir
include_directories(${LIBRDKAFKA_INCLUDE_DIR} ${LIBYAML_CPP_INCLUDE_DIR} src/ src/bmp src/bgp src/bgp/linkstate src/kafka)
#link_directories(${LIBRDKAFKA_LIBRARY})
-+link_directories(${LIBLZ4_CPP_LIBRARY_DIR} ${LIBZSTD_CPP_LIBRARY_DIR})
++link_directories(${LIBLZ4_CPP_LIBRARY_DIR} ${LIBZSTD_CPP_LIBRARY_DIR} ${LIBCURL_LIBRARY_DIR})
# Define the source files to compile
-@@ -134,7 +152,7 @@ if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang" OR CMA
+@@ -134,7 +161,7 @@
endif()
# Set the libs to link
-set (LIBS pthread ${LIBYAML_CPP_LIBRARY} ${LIBRDKAFKA_CPP_LIBRARY} ${LIBRDKAFKA_LIBRARY} z ${SSL_LIBS} dl)
-+set (LIBS pthread ${LIBYAML_CPP_LIBRARY} ${LIBRDKAFKA_CPP_LIBRARY} ${LIBRDKAFKA_LIBRARY} z lz4 zstd ${SSL_LIBS})
++set (LIBS pthread ${LIBYAML_CPP_LIBRARY} ${LIBRDKAFKA_CPP_LIBRARY} ${LIBRDKAFKA_LIBRARY} z lz4 zstd curl ${SSL_LIBS})
# Set the binary
add_executable (openbmpd ${SRC_FILES})