aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 16:53:32 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 17:03:10 +0000
commit60ae83008eab6a481b44ba1947b4c0f3232c166b (patch)
tree1ad8860d4e96dd59a04dff8c43d1523eb6cf9fd5
parent69e2e87fa56b54e267429b326f7f6188a7baaa71 (diff)
downloadports-60ae83008eab6a481b44ba1947b4c0f3232c166b.tar.gz
ports-60ae83008eab6a481b44ba1947b4c0f3232c166b.zip
devel/grpc: Update to 1.60.0
- Bump PORTREVISION of dependent ports for shlib change Changes: https://github.com/grpc/grpc/releases
-rw-r--r--biology/ncbi-blast+/Makefile1
-rw-r--r--databases/arrow/Makefile2
-rw-r--r--devel/bear/Makefile2
-rw-r--r--devel/google-cloud-cpp/Makefile2
-rw-r--r--devel/grpc/Makefile20
-rw-r--r--devel/grpc/distinfo10
-rw-r--r--devel/grpc/files/extra-patch-openssl21
-rw-r--r--devel/grpc/pkg-plist38
-rw-r--r--net/rubygem-grpc/Makefile1
-rw-r--r--www/nginx-devel/Makefile2
10 files changed, 69 insertions, 30 deletions
diff --git a/biology/ncbi-blast+/Makefile b/biology/ncbi-blast+/Makefile
index 35bcdbfb1fe2..b7d6bea5965f 100644
--- a/biology/ncbi-blast+/Makefile
+++ b/biology/ncbi-blast+/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ncbi-blast+
DISTVERSION= 2.14.1
+PORTREVISION= 1
CATEGORIES= biology perl5 python
MASTER_SITES= https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/LATEST/ \
https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/${PORTVERSION}/
diff --git a/databases/arrow/Makefile b/databases/arrow/Makefile
index 515536f4221c..21ebaece01a5 100644
--- a/databases/arrow/Makefile
+++ b/databases/arrow/Makefile
@@ -1,6 +1,6 @@
PORTNAME= arrow
DISTVERSION= 13.0.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= databases
MASTER_SITES= APACHE/${PORTNAME}/${PORTNAME}-${DISTVERSION} \
https://github.com/apache/orc/archive/rel/:orc
diff --git a/devel/bear/Makefile b/devel/bear/Makefile
index 818783393330..4a4f8bf04b43 100644
--- a/devel/bear/Makefile
+++ b/devel/bear/Makefile
@@ -1,6 +1,6 @@
PORTNAME= bear
DISTVERSION= 3.1.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MAINTAINER= jrm@FreeBSD.org
diff --git a/devel/google-cloud-cpp/Makefile b/devel/google-cloud-cpp/Makefile
index 8b82b46cf95d..bd6e6d1d9c73 100644
--- a/devel/google-cloud-cpp/Makefile
+++ b/devel/google-cloud-cpp/Makefile
@@ -1,7 +1,7 @@
PORTNAME= google-cloud-cpp
DISTVERSIONPREFIX= v
DISTVERSION= 2.13.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/devel/grpc/Makefile b/devel/grpc/Makefile
index 939f4b9c415d..f12b633cf6e4 100644
--- a/devel/grpc/Makefile
+++ b/devel/grpc/Makefile
@@ -1,7 +1,6 @@
PORTNAME= grpc
-PORTVERSION= 1.54.2
+PORTVERSION= 1.60.0
DISTVERSIONPREFIX= v
-PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= devel
@@ -24,7 +23,7 @@ USES= cmake compiler:c++17-lang cpe localbase:ldflags pkgconfig ssl
USE_GITHUB= yes
GH_TUPLE= census-instrumentation:opencensus-proto:v0.4.1:census_instrumentation_opencensus_proto/third_party/opencensus-proto/src \
- cncf:xds:32f1caf:cncf_xds/third_party/xds
+ cncf:xds:0fa0005:cncf_xds/third_party/xds
CMAKE_ARGS= -DCMAKE_CXX_STANDARD=17 \
-DgRPC_ABSL_PROVIDER=package \
@@ -34,8 +33,17 @@ CMAKE_ARGS= -DCMAKE_CXX_STANDARD=17 \
-DgRPC_RE2_PROVIDER=package \
-DgRPC_SSL_PROVIDER=package \
-DgRPC_ZLIB_PROVIDER=package
-CMAKE_OFF= gRPC_BACKWARDS_COMPATIBILITY_MODE gRPC_BUILD_TESTS
-CMAKE_ON= BUILD_SHARED_LIBS gRPC_BUILD_CODEGEN gRPC_BUILD_CSHARP_EXT gRPC_BUILD_GRPC_CPP_PLUGIN gRPC_BUILD_GRPC_CSHARP_PLUGIN gRPC_BUILD_GRPC_NODE_PLUGIN gRPC_BUILD_GRPC_OBJECTIVE_C_PLUGIN gRPC_BUILD_GRPC_PHP_PLUGIN gRPC_BUILD_GRPC_PYTHON_PLUGIN gRPC_BUILD_GRPC_RUBY_PLUGIN
+CMAKE_OFF= gRPC_BACKWARDS_COMPATIBILITY_MODE \
+ gRPC_BUILD_TESTS
+CMAKE_ON= BUILD_SHARED_LIBS \
+ gRPC_BUILD_CODEGEN \
+ gRPC_BUILD_GRPC_CPP_PLUGIN \
+ gRPC_BUILD_GRPC_CSHARP_PLUGIN \
+ gRPC_BUILD_GRPC_NODE_PLUGIN \
+ gRPC_BUILD_GRPC_OBJECTIVE_C_PLUGIN \
+ gRPC_BUILD_GRPC_PHP_PLUGIN \
+ gRPC_BUILD_GRPC_PYTHON_PLUGIN \
+ gRPC_BUILD_GRPC_RUBY_PLUGIN
USE_CSTD= c11
USE_CXXSTD= c++17
USE_LDCONFIG= yes
@@ -60,6 +68,8 @@ post-patch:
@${RM} -r ${WRKSRC}/third_party/cares/
@${RM} -r ${WRKSRC}/third_party/protobuf/
@${RM} -r ${WRKSRC}/third_party/re2/
+ #@${RM} -r ${WRKSRC}/third_party/upb/
+ #@${RM} -r ${WRKSRC}/third_party/utf8_range/
@${RM} -r ${WRKSRC}/third_party/xxhash/
@${RM} -r ${WRKSRC}/third_party/zlib/
diff --git a/devel/grpc/distinfo b/devel/grpc/distinfo
index b2b9a78915b0..89bec69facfd 100644
--- a/devel/grpc/distinfo
+++ b/devel/grpc/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1684104314
-SHA256 (grpc-grpc-v1.54.2_GH0.tar.gz) = 3c305f0ca5f98919bc104448f59177e7b936acd5c69c144bf4a548cad723e1e4
-SIZE (grpc-grpc-v1.54.2_GH0.tar.gz) = 8912552
+TIMESTAMP = 1701409461
+SHA256 (grpc-grpc-v1.60.0_GH0.tar.gz) = 437068b8b777d3b339da94d3498f1dc20642ac9bfa76db43abdd522186b1542b
+SIZE (grpc-grpc-v1.60.0_GH0.tar.gz) = 17442762
SHA256 (census-instrumentation-opencensus-proto-v0.4.1_GH0.tar.gz) = e3d89f7f9ed84c9b6eee818c2e9306950519402bf803698b15c310b77ca2f0f3
SIZE (census-instrumentation-opencensus-proto-v0.4.1_GH0.tar.gz) = 164379
-SHA256 (cncf-xds-32f1caf_GH0.tar.gz) = 1a4deadcda02a08ccc0a220dbd0cb6dbbb9a051a25d2d8544565703553532ca2
-SIZE (cncf-xds-32f1caf_GH0.tar.gz) = 104130
+SHA256 (cncf-xds-0fa0005_GH0.tar.gz) = bb9e05e048ef35335b70f8c4038e47c0a5586122108738e2bd82f18b57d59885
+SIZE (cncf-xds-0fa0005_GH0.tar.gz) = 105778
diff --git a/devel/grpc/files/extra-patch-openssl b/devel/grpc/files/extra-patch-openssl
index 1c3ef81580e1..2f950a6d85f0 100644
--- a/devel/grpc/files/extra-patch-openssl
+++ b/devel/grpc/files/extra-patch-openssl
@@ -1,11 +1,20 @@
---- CMakeLists.txt.orig 2023-04-13 00:26:28 UTC
+--- CMakeLists.txt.orig 2023-11-28 00:12:30 UTC
+++ CMakeLists.txt
-@@ -26032,7 +26032,7 @@ generate_pkgconfig(
+@@ -30395,7 +30395,7 @@ generate_pkgconfig(
"high performance general RPC framework"
"${gRPC_CORE_VERSION}"
- "gpr absl_any_invocable absl_base absl_bind_front absl_cleanup absl_cord absl_core_headers absl_flags absl_flags_marshalling absl_flat_hash_map absl_flat_hash_set absl_function_ref absl_hash absl_inlined_vector absl_memory absl_optional absl_random_random absl_span absl_status absl_statusor absl_str_format absl_strings absl_synchronization absl_time absl_type_traits absl_utility absl_variant"
-- "openssl re2 libcares zlib"
-+ "re2 libcares zlib"
+ "absl_algorithm_container absl_any_invocable absl_base absl_bind_front absl_cleanup absl_cord absl_core_headers absl_flags absl_flags_marshalling absl_flat_hash_map absl_flat_hash_set absl_function_ref absl_hash absl_inlined_vector absl_memory absl_optional absl_random_bit_gen_ref absl_random_distributions absl_random_random absl_span absl_status absl_statusor absl_str_format absl_strings absl_synchronization absl_time absl_type_traits absl_utility absl_variant gpr"
+- "libcares openssl re2 zlib"
++ "libcares re2 zlib"
"-lgrpc"
- "-laddress_sorting -lupb"
+ "-laddress_sorting -lupb -lupb_textformat_lib -lupb_json_lib -lutf8_range_lib -lupb_collections_lib"
"grpc.pc")
+@@ -30417,7 +30417,7 @@ generate_pkgconfig(
+ "C++ wrapper for gRPC"
+ "${gRPC_CPP_VERSION}"
+ "absl_algorithm_container absl_any_invocable absl_base absl_bind_front absl_cleanup absl_cord absl_core_headers absl_flags absl_flags_marshalling absl_flat_hash_map absl_flat_hash_set absl_function_ref absl_hash absl_inlined_vector absl_memory absl_optional absl_random_bit_gen_ref absl_random_distributions absl_random_random absl_span absl_status absl_statusor absl_str_format absl_strings absl_synchronization absl_time absl_type_traits absl_utility absl_variant gpr grpc"
+- "libcares openssl re2 zlib"
++ "libcares re2 zlib"
+ "-lgrpc++"
+ "-laddress_sorting -lupb -lupb_textformat_lib -lupb_json_lib -lutf8_range_lib -lupb_collections_lib"
+ "grpc++.pc")
diff --git a/devel/grpc/pkg-plist b/devel/grpc/pkg-plist
index b1dcc5f6d024..2404d82c86f8 100644
--- a/devel/grpc/pkg-plist
+++ b/devel/grpc/pkg-plist
@@ -96,9 +96,12 @@ include/grpc/event_engine/slice.h
include/grpc/event_engine/slice_buffer.h
include/grpc/fork.h
include/grpc/grpc.h
+include/grpc/grpc_audit_logging.h
+include/grpc/grpc_crl_provider.h
include/grpc/grpc_posix.h
include/grpc/grpc_security.h
include/grpc/grpc_security_constants.h
+include/grpc/impl/channel_arg_names.h
include/grpc/impl/codegen/atm.h
include/grpc/impl/codegen/atm_gcc_atomic.h
include/grpc/impl/codegen/atm_gcc_sync.h
@@ -136,6 +139,7 @@ include/grpc/support/atm_gcc_atomic.h
include/grpc/support/atm_gcc_sync.h
include/grpc/support/atm_windows.h
include/grpc/support/cpu.h
+include/grpc/support/json.h
include/grpc/support/log.h
include/grpc/support/log_windows.h
include/grpc/support/port_platform.h
@@ -242,6 +246,7 @@ include/grpcpp/impl/sync.h
include/grpcpp/resource_quota.h
include/grpcpp/security/alts_context.h
include/grpcpp/security/alts_util.h
+include/grpcpp/security/audit_logging.h
include/grpcpp/security/auth_context.h
include/grpcpp/security/auth_metadata_processor.h
include/grpcpp/security/authorization_policy_provider.h
@@ -252,6 +257,7 @@ include/grpcpp/security/server_credentials.h
include/grpcpp/security/tls_certificate_provider.h
include/grpcpp/security/tls_certificate_verifier.h
include/grpcpp/security/tls_credentials_options.h
+include/grpcpp/security/tls_crl_provider.h
include/grpcpp/server.h
include/grpcpp/server_builder.h
include/grpcpp/server_context.h
@@ -293,11 +299,11 @@ lib/cmake/grpc/modules/Findc-ares.cmake
lib/cmake/grpc/modules/Findre2.cmake
lib/cmake/grpc/modules/Findsystemd.cmake
lib/libaddress_sorting.so
-lib/libaddress_sorting.so.31
-lib/libaddress_sorting.so.31.0.0
+lib/libaddress_sorting.so.37
+lib/libaddress_sorting.so.37.0.0
lib/libgpr.so
-lib/libgpr.so.31
-lib/libgpr.so.31.0.0
+lib/libgpr.so.37
+lib/libgpr.so.37.0.0
lib/libgrpc++.so
lib/libgrpc++.so.%%SHLIB_MAJOR%%
lib/libgrpc++.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
@@ -314,8 +320,8 @@ lib/libgrpc++_unsecure.so
lib/libgrpc++_unsecure.so.%%SHLIB_MAJOR%%
lib/libgrpc++_unsecure.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
lib/libgrpc.so
-lib/libgrpc.so.31
-lib/libgrpc.so.31.0.0
+lib/libgrpc.so.37
+lib/libgrpc.so.37.0.0
lib/libgrpc_authorization_provider.so
lib/libgrpc_authorization_provider.so.%%SHLIB_MAJOR%%
lib/libgrpc_authorization_provider.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
@@ -323,14 +329,26 @@ lib/libgrpc_plugin_support.so
lib/libgrpc_plugin_support.so.%%SHLIB_MAJOR%%
lib/libgrpc_plugin_support.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
lib/libgrpc_unsecure.so
-lib/libgrpc_unsecure.so.31
-lib/libgrpc_unsecure.so.31.0.0
+lib/libgrpc_unsecure.so.37
+lib/libgrpc_unsecure.so.37.0.0
lib/libgrpcpp_channelz.so
lib/libgrpcpp_channelz.so.%%SHLIB_MAJOR%%
lib/libgrpcpp_channelz.so.%%SHLIB_MAJOR%%.%%SHLIB_MINOR%%
lib/libupb.so
-lib/libupb.so.31
-lib/libupb.so.31.0.0
+lib/libupb.so.37
+lib/libupb.so.37.0.0
+lib/libupb_collections_lib.so
+lib/libupb_collections_lib.so.37
+lib/libupb_collections_lib.so.37.0.0
+lib/libupb_json_lib.so
+lib/libupb_json_lib.so.37
+lib/libupb_json_lib.so.37.0.0
+lib/libupb_textformat_lib.so
+lib/libupb_textformat_lib.so.37
+lib/libupb_textformat_lib.so.37.0.0
+lib/libutf8_range_lib.so
+lib/libutf8_range_lib.so.37
+lib/libutf8_range_lib.so.37.0.0
libdata/pkgconfig/gpr.pc
libdata/pkgconfig/grpc++.pc
libdata/pkgconfig/grpc++_unsecure.pc
diff --git a/net/rubygem-grpc/Makefile b/net/rubygem-grpc/Makefile
index 91c9fa0a8317..2f01ade4e2a0 100644
--- a/net/rubygem-grpc/Makefile
+++ b/net/rubygem-grpc/Makefile
@@ -1,5 +1,6 @@
PORTNAME= grpc
PORTVERSION= 1.60.0
+PORTREVISION= 1
CATEGORIES= net rubygems
MASTER_SITES= RG
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index c2c4d3fd398a..16ec90764ff8 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME?= nginx
PORTVERSION= 1.25.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
LOCAL/osa