aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-06 16:34:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-06 17:25:34 +0000
commit60ef4afb204004a27552672f77250847ea75e8ff (patch)
treed53feddd860709d3853157825d57d5b3ac32c807
parente97e684cb0ee1bcb4f6148210440aac4913a32a7 (diff)
downloadports-60ef4afb204004a27552672f77250847ea75e8ff.tar.gz
ports-60ef4afb204004a27552672f77250847ea75e8ff.zip
devel/py-session-info: New port: Print version information for loaded modules, Python, and the OS
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-session-info/Makefile20
-rw-r--r--devel/py-session-info/distinfo3
-rw-r--r--devel/py-session-info/pkg-descr6
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d194e6318b18..4153007f11c7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5248,6 +5248,7 @@
SUBDIR += py-sentry-sdk
SUBDIR += py-serializable
SUBDIR += py-serpent
+ SUBDIR += py-session-info
SUBDIR += py-setproctitle
SUBDIR += py-setuptools
SUBDIR += py-setuptools-git
diff --git a/devel/py-session-info/Makefile b/devel/py-session-info/Makefile
new file mode 100644
index 000000000000..06565a7b4ac3
--- /dev/null
+++ b/devel/py-session-info/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= session-info
+DISTVERSION= 1.0.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Print version information for loaded modules, Python, and the OS
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stdlib-list>0:devel/py-stdlib-list@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-session-info/distinfo b/devel/py-session-info/distinfo
new file mode 100644
index 000000000000..d68b2c0cadd7
--- /dev/null
+++ b/devel/py-session-info/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1659803353
+SHA256 (session_info-1.0.0.tar.gz) = 3cda5e03cca703f32ae2eadbd6bd80b6c21442cfb60e412c21cb8ad6d5cbb6b7
+SIZE (session_info-1.0.0.tar.gz) = 24345
diff --git a/devel/py-session-info/pkg-descr b/devel/py-session-info/pkg-descr
new file mode 100644
index 000000000000..0383c5051d7b
--- /dev/null
+++ b/devel/py-session-info/pkg-descr
@@ -0,0 +1,6 @@
+session_info outputs version information for modules loaded in the current
+session, Python, the OS, and the CPU. It is designed as a minimum measure to
+increase reproducibility and provides similar information as sessionInfo and
+devtools::session_info in R.
+
+WWW: https://gitlab.com/joelostblom/session_info