aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-24 00:41:02 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-24 04:37:51 +0000
commit611b86aeb776d312137a82d24bb98ca58c384a18 (patch)
tree7970b519d03d8b2bc906731d3591548b45b132e0
parentabdfb41c181ba23a31c71860076c8815c98a93d3 (diff)
downloadports-611b86aeb776d312137a82d24bb98ca58c384a18.tar.gz
ports-611b86aeb776d312137a82d24bb98ca58c384a18.zip
x11-toolkits/plib: Fix build with llvm16
- Utilize USES=localbase - Pet portclippy - Adopt port Sponsored by: The FreeBSD Foundation
-rw-r--r--x11-toolkits/plib/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/x11-toolkits/plib/Makefile b/x11-toolkits/plib/Makefile
index f053200e5bf6..d19072835cde 100644
--- a/x11-toolkits/plib/Makefile
+++ b/x11-toolkits/plib/Makefile
@@ -4,25 +4,31 @@ PORTREVISION= 8
CATEGORIES= x11-toolkits
MASTER_SITES= http://plib.sourceforge.net/dist/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Portable library for joystick/sound/OpenGL GUI/3D math
WWW= http://plib.sourceforge.net/
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cpe gl gmake xorg
+USES= cpe gl gmake localbase:ldflags xorg
CPE_VENDOR= ${PORTNAME}_project
-USE_XORG= xt xi xmu xext x11
USE_GL= glu
+USE_XORG= xt xi xmu xext x11
+
GNU_CONFIGURE= yes
CXXFLAGS+= -fPIC
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+LDFLAGS+= -lpthread
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-js-jsBSD.cxx
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CPPFLAGS+= -Dregister=
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread||g ; \
s|-ldl||g ; \