aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2022-07-08 21:47:56 +0000
committerDan Langille <dvl@FreeBSD.org>2022-07-08 21:57:13 +0000
commit61343510f6b23e0b91678aef0f593d22b7d12f35 (patch)
tree5747378b994eb6b65953bb00c4182aac295db439
parentc9befd7a40c568474b1ff4d6b5b2a3da89a81435 (diff)
downloadports-61343510f6b23e0b91678aef0f593d22b7d12f35.tar.gz
ports-61343510f6b23e0b91678aef0f593d22b7d12f35.zip
security/iddawc: New port: OAuth2/OIDC Client
OAuth2/OIDC Client and Relying Party library
-rw-r--r--security/Makefile1
-rw-r--r--security/iddawc/Makefile31
-rw-r--r--security/iddawc/distinfo3
-rw-r--r--security/iddawc/pkg-descr14
-rw-r--r--security/iddawc/pkg-plist35
5 files changed, 84 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3250fdf9b357..c7d7d99f3e59 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -217,6 +217,7 @@
SUBDIR += i2p
SUBDIR += i2pd
SUBDIR += iaikpkcs11wrapper
+ SUBDIR += iddawc
SUBDIR += idea
SUBDIR += identify
SUBDIR += imds-filterd
diff --git a/security/iddawc/Makefile b/security/iddawc/Makefile
new file mode 100644
index 000000000000..99ad673b7ba2
--- /dev/null
+++ b/security/iddawc/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= iddawc
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.4
+CATEGORIES= security
+
+MAINTAINER= dvl@FreeBSD.org
+COMMENT= OAuth2/OIDC Client and Relying Party library
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= yder>1.4.14:devel/yder \
+ orcania>2.2.1:devel/orcania \
+ gnutls>0:security/gnutls
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libjansson.so:devel/jansson \
+ libgnutls.so:security/gnutls \
+ liborcania.so:devel/orcania \
+ libyder.so:devel/yder \
+ libmicrohttpd.so:www/libmicrohttpd \
+ librhonabwy.so:security/rhonabwy \
+ libulfius.so:www/ulfius
+
+USES= cmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= babelouest
+
+CMAKE_ARGS= -DWITH_JOURNALD=off
+
+.include <bsd.port.mk>
diff --git a/security/iddawc/distinfo b/security/iddawc/distinfo
new file mode 100644
index 000000000000..fee1ba3333b9
--- /dev/null
+++ b/security/iddawc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1657307910
+SHA256 (babelouest-iddawc-v1.1.4_GH0.tar.gz) = f9a54cd0cebff4ef4d6cb96d178ed7b87d865c24e236bdd85b3e3a5f159ba463
+SIZE (babelouest-iddawc-v1.1.4_GH0.tar.gz) = 1481659
diff --git a/security/iddawc/pkg-descr b/security/iddawc/pkg-descr
new file mode 100644
index 000000000000..9d94d3ac9e95
--- /dev/null
+++ b/security/iddawc/pkg-descr
@@ -0,0 +1,14 @@
+Handles the OAuth2 and OpenID Connect authentication process flow from the
+client side.
+
+* Generates requests based on input parameters
+* Parses response
+* Validates response values
+
+Supported response_types: code, token, id_token, password, client_credentials,
+refresh_token, device_code
+
+Supported client authentication methods: client_secret_basic,
+client_secret_post, client_secret_jwt, private_key_jwt
+
+WWW: https://github.com/babelouest/iddawc
diff --git a/security/iddawc/pkg-plist b/security/iddawc/pkg-plist
new file mode 100644
index 000000000000..71491f144fe6
--- /dev/null
+++ b/security/iddawc/pkg-plist
@@ -0,0 +1,35 @@
+bin/idwcc
+include/iddawc-cfg.h
+include/iddawc.h
+lib/libiddawc.so
+lib/libiddawc.so.1.1
+lib/libiddawc.so.1.1.4
+libdata/pkgconfig/libiddawc.pc
+share/idwcc/webapp/callback.html
+share/idwcc/webapp/css/bootstrap.css
+share/idwcc/webapp/css/bootstrap.css.map
+share/idwcc/webapp/css/bootstrap.min.css
+share/idwcc/webapp/css/bootstrap.min.css.map
+share/idwcc/webapp/css/fork-awesome.css
+share/idwcc/webapp/css/fork-awesome.min.css
+share/idwcc/webapp/css/fork-awesome.min.css.map
+share/idwcc/webapp/css/idwcc.css
+share/idwcc/webapp/css/v5-compat.css
+share/idwcc/webapp/css/v5-compat.min.css
+share/idwcc/webapp/css/v5-compat.min.css.map
+share/idwcc/webapp/fonts/forkawesome-webfont.eot
+share/idwcc/webapp/fonts/forkawesome-webfont.svg
+share/idwcc/webapp/fonts/forkawesome-webfont.ttf
+share/idwcc/webapp/fonts/forkawesome-webfont.woff
+share/idwcc/webapp/fonts/forkawesome-webfont.woff2
+share/idwcc/webapp/index.html
+share/idwcc/webapp/js/bootstrap.js
+share/idwcc/webapp/js/bootstrap.js.map
+share/idwcc/webapp/js/bootstrap.min.js
+share/idwcc/webapp/js/bootstrap.min.js.map
+share/idwcc/webapp/js/iddwc.js
+share/idwcc/webapp/js/jquery.js
+share/idwcc/webapp/js/jquery.min.js
+share/idwcc/webapp/js/popper.js
+share/idwcc/webapp/js/popper.min.js
+share/idwcc/webapp/js/qrcode.js