aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2020-07-14 02:26:34 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2020-07-14 02:26:34 +0000
commit61391e907b450f5fa681c2e623fc71e74d8f6350 (patch)
tree6e94206494c3820a2872550b19e5805b43125331
parent320bb54947e2c2332dcf42ec95ce2d5bbc9bf8a6 (diff)
downloadports-61391e907b450f5fa681c2e623fc71e74d8f6350.tar.gz
ports-61391e907b450f5fa681c2e623fc71e74d8f6350.zip
sysutils/py-jailconf: Parse and edit your FreeBSD jail.conf file
Parse and edit your FreeBSD jail.conf file with Python. WWW: https://github.com/leforestier/jailconf
Notes
Notes: svn path=/head/; revision=542188
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-jailconf/Makefile30
-rw-r--r--sysutils/py-jailconf/distinfo3
-rw-r--r--sysutils/py-jailconf/pkg-descr3
4 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ed53da329cf8..234e420a4811 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -977,6 +977,7 @@
SUBDIR += py-honcho
SUBDIR += py-hpilo
SUBDIR += py-iowait
+ SUBDIR += py-jailconf
SUBDIR += py-leviathan
SUBDIR += py-liquidctl
SUBDIR += py-mitogen
diff --git a/sysutils/py-jailconf/Makefile b/sysutils/py-jailconf/Makefile
new file mode 100644
index 000000000000..89f3f4cd506e
--- /dev/null
+++ b/sysutils/py-jailconf/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= jailconf
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.1
+CATEGORIES= sysutils python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Parse and edit your FreeBSD jail.conf file
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ply>=3.9:devel/py-ply@${PY_FLAVOR}
+
+USES= python:3.0+
+USE_GITHUB= yes # tests nnot packaged in PyPI sdist
+USE_PYTHON= autoplist distutils
+
+#LICENSE= "BSD". Unclear. See Upstream #1
+#LICENSE_FILE= Does not exist
+
+GH_ACCOUNT= leforestier
+
+NO_ARCH= yes
+
+do-test:
+ ${TOUCH} ${WRKSRC}/test/__init__.py
+ ${MV} ${WRKSRC}/test/jailconf_test.py ${WRKSRC}/test/test_jailconf.py
+ cd ${WRKSRC} && ${PYTHON_CMD} -m unittest -v
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-jailconf/distinfo b/sysutils/py-jailconf/distinfo
new file mode 100644
index 000000000000..e5f5c36b15e3
--- /dev/null
+++ b/sysutils/py-jailconf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1594691968
+SHA256 (leforestier-jailconf-v0.2.1_GH0.tar.gz) = b2eef97da86da5b761cdb9fa09d17abfe199b9918451494264aaddc5cfba522e
+SIZE (leforestier-jailconf-v0.2.1_GH0.tar.gz) = 5191
diff --git a/sysutils/py-jailconf/pkg-descr b/sysutils/py-jailconf/pkg-descr
new file mode 100644
index 000000000000..08ccbe2d644e
--- /dev/null
+++ b/sysutils/py-jailconf/pkg-descr
@@ -0,0 +1,3 @@
+Parse and edit your FreeBSD jail.conf file with Python.
+
+WWW: https://github.com/leforestier/jailconf