aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2019-05-11 18:52:00 +0000
committerKoop Mast <kwm@FreeBSD.org>2019-05-11 18:52:00 +0000
commit6139dfbfd7a40c269396221f7caa0e61a599e1b7 (patch)
treef083ec760989cebd766e401aed17a44153a8653a
parenteedd27b63e150bfa49c1298adc1f3343de439c70 (diff)
downloadports-6139dfbfd7a40c269396221f7caa0e61a599e1b7.tar.gz
ports-6139dfbfd7a40c269396221f7caa0e61a599e1b7.zip
Update gegl to 0.4.14.
Notes
Notes: svn path=/head/; revision=501286
-rw-r--r--graphics/gegl/Makefile15
-rw-r--r--graphics/gegl/distinfo6
-rw-r--r--graphics/gegl/files/patch-gegl_gegl-config.c70
-rw-r--r--graphics/gegl/pkg-plist7
4 files changed, 88 insertions, 10 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index d259d6f41797..464a8cbe239e 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gegl
-PORTVERSION= 0.4.12
-PORTREVISION= 3
+PORTVERSION= 0.4.14
CATEGORIES= graphics
MASTER_SITES= GIMP
@@ -20,7 +19,7 @@ LIB_DEPENDS= libbabl-0.1.so:x11/babl \
libfribidi.so:converters/fribidi \
libpng.so:graphics/png
-USES= compiler:c11 cpe gettext gmake gnome jpeg libtool localbase \
+USES= compiler:c++14-lang cpe gettext gmake gnome jpeg libtool localbase \
pathfix pkgconfig shebangfix uniquefiles tar:bzip2
USE_GNOME= glib20 intltool introspection:build
USE_LDCONFIG= yes
@@ -30,7 +29,7 @@ CONFIGURE_ARGS= --without-vala --disable-docs
CONFIGURE_ARGS+=--without-mrg --without-lensfun
INSTALL_TARGET= install-strip
-GEGL_MINOR= 412
+GEGL_MINOR= 414
GEGL_VER= 0.4
PLIST_SUB+= GEGL_MINOR="${GEGL_MINOR}" GEGL_VER=${GEGL_VER}
@@ -46,10 +45,10 @@ UNIQUE_SUFFIX_FILES= bin/gcut
OPTIONS_SUB= yes
OPTIONS_DEFINE= CAIRO ENSCRIPT EXIV2 FFMPEG PIXBUF GRAPHVIZ JASPER \
- LUA OPENEXR RAW PANGO LIBRSVG2 SDL SPIRO V4L \
+ LUA OPENEXR RAW PANGO POPPLER LIBRSVG2 SDL SPIRO V4L \
EXAMPLES LCMS2 WEBP TIFF GEXIV2
OPTIONS_DEFAULT=CAIRO ENSCRIPT EXIV2 PIXBUF GRAPHVIZ JASPER LCMS2 LUA \
- OPENEXR RAW PANGO LIBRSVG2 SDL SPIRO V4L WEBP TIFF
+ OPENEXR RAW PANGO POPPLER LIBRSVG2 SDL SPIRO V4L WEBP TIFF
ENSCRIPT_DESC= Enscript support
SPIRO_DESC= Spiro support
@@ -65,6 +64,9 @@ CAIRO_CONFIGURE_WITH= cairo
PANGO_USE= GNOME=pango
PANGO_CONFIGURE_WITH= pango
+POPPLER_LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
+POPPLER_CONFIGURE_WITH= popplerglib
+
ENSCRIPT_BUILD_DEPENDS= enscript:print/enscript-a4
FFMPEG_LIB_DEPENDS= libavformat.so:multimedia/ffmpeg
@@ -93,6 +95,7 @@ LIBRSVG2_USE= GNOME=librsvg2
LIBRSVG2_CONFIGURE_OFF= --without-librsvg
SDL_USE= SDL=sdl
+SDL_USES= sdl
SDL_CONFIGURE_WITH= sdl
SPIRO_LIB_DEPENDS= libspiro.so:graphics/libspiro
diff --git a/graphics/gegl/distinfo b/graphics/gegl/distinfo
index 425f0d2519b1..de2375732cfa 100644
--- a/graphics/gegl/distinfo
+++ b/graphics/gegl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1543060134
-SHA256 (gegl-0.4.12.tar.bz2) = e967293eabe89257e1d511bf68435fbfd44e6e0f9ef51b86cc50781f09eb5852
-SIZE (gegl-0.4.12.tar.bz2) = 7065555
+TIMESTAMP = 1555532285
+SHA256 (gegl-0.4.14.tar.bz2) = 4c01d58599d8ddb3714effd2675ea1863272cf2d7d9ed3d32aee80c89f859901
+SIZE (gegl-0.4.14.tar.bz2) = 7209142
diff --git a/graphics/gegl/files/patch-gegl_gegl-config.c b/graphics/gegl/files/patch-gegl_gegl-config.c
new file mode 100644
index 000000000000..3f53ba03e2ef
--- /dev/null
+++ b/graphics/gegl/files/patch-gegl_gegl-config.c
@@ -0,0 +1,70 @@
+--- gegl/gegl-config.c.orig 2019-04-17 20:23:56 UTC
++++ gegl/gegl-config.c
+@@ -34,6 +34,9 @@
+ #include <unistd.h>
+ #endif
+
++#include <sys/types.h>
++#include <sys/sysctl.h>
++
+ G_DEFINE_TYPE (GeglConfig, gegl_config, G_TYPE_OBJECT)
+
+ static GObjectClass * parent_class = NULL;
+@@ -219,8 +222,8 @@ gegl_config_class_init (GeglConfigClass *klass)
+ long mem_total = default_tile_cache_size;
+ long mem_min = 512 << 20; // 512mb
+ long mem_available = mem_min;
++
+ #ifdef G_OS_WIN32
+-#ifdef G_OS_WIN32
+ # if defined(_MSC_VER) && (_MSC_VER <= 1200)
+ MEMORYSTATUS memory_status;
+ memory_status.dwLength = sizeof (memory_status);
+@@ -240,7 +243,46 @@ gegl_config_class_init (GeglConfigClass *klass)
+ mem_available = memory_status.ullAvailPhys;
+ }
+ # endif
+-#endif
++#elif defined(__APPLE__)
++ /* get total memory from the HW_MEMSIZE */
++ int64_t usermem;
++ size_t len = sizeof usermem;
++ static int mib[2] = { CTL_HW, HW_MEMSIZE };
++
++ if (sysctl (mib, 2, &usermem, &len, NULL, 0) == 0) {
++ mem_total = usermem;
++ }
++ /* and available mem from host_statistics64 */
++ vm_size_t page_size = sysconf (_SC_PAGESIZE);
++ mach_port_t host = mach_host_self ();
++ vm_statistics64_data_t vm_stat;
++ kern_return_t kret;
++ unsigned int count = HOST_VM_INFO64_COUNT;
++
++ kret = host_statistics64 (host, HOST_VM_INFO64, (host_info64_t)&vm_stat, &count);
++
++ if (kret == KERN_SUCCESS)
++ {
++ mem_available = (long) (vm_stat.free_count + vm_stat.active_count
++ + vm_stat.inactive_count
++# ifdef MAC_OS_X_VERSION_10_9
++ + vm_stat.compressor_page_count
++# endif
++ ) * page_size;
++ mach_port_deallocate (mach_task_self (), host);
++ }
++#elif defined(__FreeBSD__)
++
++ size_t len = sizeof(unsigned int);
++ unsigned int realmem, physmem;
++
++ if(sysctlbyname("hw.realmem", &realmem, &len, NULL, 0)) {
++ mem_total = (int64_t) realmem;
++ };
++
++ if (sysctlbyname("hw.physmem", &physmem, &len, NULL, 0)) {
++ mem_available = physmem;
++ }
+
+ #else
+ mem_total = sysconf (_SC_PHYS_PAGES) * sysconf (_SC_PAGESIZE);
diff --git a/graphics/gegl/pkg-plist b/graphics/gegl/pkg-plist
index ed46fd931208..6a0ef8aa6dce 100644
--- a/graphics/gegl/pkg-plist
+++ b/graphics/gegl/pkg-plist
@@ -7,8 +7,8 @@ include/gegl-%%GEGL_VER%%/gegl-buffer-backend.h
include/gegl-%%GEGL_VER%%/gegl-buffer-cl-iterator.h
include/gegl-%%GEGL_VER%%/gegl-buffer-enums.h
include/gegl-%%GEGL_VER%%/gegl-buffer-iterator.h
-include/gegl-%%GEGL_VER%%/gegl-buffer-iterator2.h
include/gegl-%%GEGL_VER%%/gegl-buffer-matrix2.h
+include/gegl-%%GEGL_VER%%/gegl-buffer-swap.h
include/gegl-%%GEGL_VER%%/gegl-buffer.h
include/gegl-%%GEGL_VER%%/gegl-color.h
include/gegl-%%GEGL_VER%%/gegl-cpuaccel.h
@@ -19,15 +19,18 @@ include/gegl-%%GEGL_VER%%/gegl-graph-debug.h
include/gegl-%%GEGL_VER%%/gegl-init.h
include/gegl-%%GEGL_VER%%/gegl-lookup.h
include/gegl-%%GEGL_VER%%/gegl-matrix.h
+include/gegl-%%GEGL_VER%%/gegl-memory.h
include/gegl-%%GEGL_VER%%/gegl-node.h
include/gegl-%%GEGL_VER%%/gegl-op.h
include/gegl-%%GEGL_VER%%/gegl-operations-util.h
+include/gegl-%%GEGL_VER%%/gegl-parallel.h
include/gegl-%%GEGL_VER%%/gegl-paramspecs.h
include/gegl-%%GEGL_VER%%/gegl-path.h
include/gegl-%%GEGL_VER%%/gegl-plugin.h
include/gegl-%%GEGL_VER%%/gegl-processor.h
include/gegl-%%GEGL_VER%%/gegl-random.h
include/gegl-%%GEGL_VER%%/gegl-rectangle.h
+include/gegl-%%GEGL_VER%%/gegl-scratch.h
include/gegl-%%GEGL_VER%%/gegl-tile-backend.h
include/gegl-%%GEGL_VER%%/gegl-tile-handler.h
include/gegl-%%GEGL_VER%%/gegl-tile-source.h
@@ -82,6 +85,7 @@ include/gegl-%%GEGL_VER%%/sc/sc-sample.h
%%OPENEXR%%lib/gegl-%%GEGL_VER%%/exr-save.so
%%FFMPEG%%lib/gegl-%%GEGL_VER%%/ff-load.so
%%FFMPEG%%lib/gegl-%%GEGL_VER%%/ff-save.so
+lib/gegl-%%GEGL_VER%%/gegl-common-cxx.so
lib/gegl-%%GEGL_VER%%/gegl-common-gpl3.so
lib/gegl-%%GEGL_VER%%/gegl-common.so
lib/gegl-%%GEGL_VER%%/gegl-core.so
@@ -95,6 +99,7 @@ lib/gegl-%%GEGL_VER%%/jpg-save.so
%%CAIRO%%lib/gegl-%%GEGL_VER%%/npd.so
lib/gegl-%%GEGL_VER%%/npy-save.so
%%CAIRO%%lib/gegl-%%GEGL_VER%%/path.so
+%%POPPLER%%lib/gegl-%%GEGL_VER%%/pdf-load.so
%%PIXBUF%%lib/gegl-%%GEGL_VER%%/pixbuf.so
lib/gegl-%%GEGL_VER%%/png-load.so
lib/gegl-%%GEGL_VER%%/png-save.so