aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-05 00:37:01 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-05 00:37:01 +0000
commit6151ae9c9d512a3e545e9f79058e1661678817db (patch)
tree9638de0ff0604eacac3a5a2b744818a61ddc14f8
parent06c9e2951924e6ff2357d8f507dc977c957c8988 (diff)
downloadports-6151ae9c9d512a3e545e9f79058e1661678817db.tar.gz
ports-6151ae9c9d512a3e545e9f79058e1661678817db.zip
devel/py-pytest-remotedata: Add py-pytest-remotedata 0.4.1
pytest-remotedata provides a plugin for the pytest framework that allows developers to control unit tests that require access to data from the internet. It was originally part of the astropy core package, but has been moved to a separate package in order to be of more general use.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-remotedata/Makefile25
-rw-r--r--devel/py-pytest-remotedata/distinfo3
-rw-r--r--devel/py-pytest-remotedata/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ec31a3add8b0..d93b683797e3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5468,6 +5468,7 @@
SUBDIR += py-pytest-regressions
SUBDIR += py-pytest-regtest
SUBDIR += py-pytest-relaxed
+ SUBDIR += py-pytest-remotedata
SUBDIR += py-pytest-rerunfailures
SUBDIR += py-pytest-runner
SUBDIR += py-pytest-services
diff --git a/devel/py-pytest-remotedata/Makefile b/devel/py-pytest-remotedata/Makefile
new file mode 100644
index 000000000000..d54689737731
--- /dev/null
+++ b/devel/py-pytest-remotedata/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= pytest-remotedata
+PORTVERSION= 0.4.1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Pytest plugin for controlling remote data access
+WWW= https://github.com/astropy/pytest-remotedata
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=30.3.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=0:devel/py-setuptools-scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=17.0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=4.6,1:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-remotedata/distinfo b/devel/py-pytest-remotedata/distinfo
new file mode 100644
index 000000000000..02af84763f82
--- /dev/null
+++ b/devel/py-pytest-remotedata/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1712084452
+SHA256 (pytest-remotedata-0.4.1.tar.gz) = 05c08bf638cdd1ed66eb01738a1647c3c714737c3ec3abe009d2c1f793b4bb59
+SIZE (pytest-remotedata-0.4.1.tar.gz) = 13279
diff --git a/devel/py-pytest-remotedata/pkg-descr b/devel/py-pytest-remotedata/pkg-descr
new file mode 100644
index 000000000000..b6466a4d2517
--- /dev/null
+++ b/devel/py-pytest-remotedata/pkg-descr
@@ -0,0 +1,4 @@
+pytest-remotedata provides a plugin for the pytest framework that allows
+developers to control unit tests that require access to data from the internet.
+It was originally part of the astropy core package, but has been moved to a
+separate package in order to be of more general use.