aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaap Akkerhuis <jaap@NLnetLabs.nl>2022-08-15 18:05:53 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-08-16 15:56:04 +0000
commit616885da342a3dc4396407df3e2a6c5b3e175a6c (patch)
tree3043ead3b64beaf871a19969fa8f53982b12c654
parent79f9679c7e795de9a15451910526cea3ea50c21f (diff)
downloadports-616885da342a3dc4396407df3e2a6c5b3e175a6c.tar.gz
ports-616885da342a3dc4396407df3e2a6c5b3e175a6c.zip
dns/{py-}ldns: update to 1.8.3
ChangeLog: https://www.nlnetlabs.nl/news/2022/Aug/15/ldns-1.8.3-released/ 1.8.3 2022-08-15 * bugfix #183: Assertion failure with OPT record without rdata. * Fix for syntax error in pyldns 1.8.2 2022-08-12 * bugfix #147: Allow for tabs in whitespace before quoted rdata fields. * bugfix #149: Add some missing [out] annotations to doxygen parameters. * Fix build error on Solaris 10 with inet_ntop redeclaration error. * Fix -U flag with ldns-signzone. * Enable compile of SVCB and HTTPS support by default. * bugfix #179: Free line memory even if zone file parsing fails * bugfix #166: Grow buffer when writing chars and fixed size strings when converting to presentation format, preventing potential assersion errors. * bugfix #46: Print network errors when secure tracing. * EDNS0 Option handling and conversion into presentation format. * bugfix #145: ldns-verify-zone should not call occluded records glue. PR: 265859 Reported by: jaap@NLnetLabs.nl (maintainer)
-rw-r--r--dns/ldns/Makefile12
-rw-r--r--dns/ldns/distinfo6
-rw-r--r--dns/ldns/files/patch-LibreSSL-3.592
-rw-r--r--dns/ldns/pkg-plist3
-rw-r--r--dns/py-ldns/pkg-plist2
5 files changed, 14 insertions, 101 deletions
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index 2b90905a93c7..32afafe781fe 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -1,5 +1,5 @@
PORTNAME= ldns
-DISTVERSION= 1.8.1
+DISTVERSION= 1.8.3
CATEGORIES= dns
MASTER_SITES= https://www.nlnetlabs.nl/downloads/ldns/ \
LOCAL/ehaupt
@@ -32,7 +32,7 @@ DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
HTMLDOCS= doc/html/*
OPTIONS_DEFINE+= DANETAUSAGE GOST RRTYPEAMTRELAY RRTYPEAVC RRTYPENINFO \
- RRTYPERKEY RRTYPETA RRTYPESVCBHTTPS
+ RRTYPERKEY RRTYPETA
DANETAUSAGE_DESC= Enable ta usage, requires openssl >= 1.1.0
GOST_DESC= GOST signatures enabled, requires openssl >= 1.0.0
@@ -41,7 +41,6 @@ RRTYPERKEY_DESC= Enable draft RR type rkey.
RRTYPETA_DESC= Enable draft RR type ta.
RRTYPEAVC_DESC= Enable draft RR type avc.
RRTYPEAMTRELAY_DESC= Enable draft RR type amtrelay.
-RRTYPESVCBHTTPS_DESC= Enable SVCB and HTTPS draft RR types.
OPTIONS_SUB= yes
@@ -53,7 +52,6 @@ RRTYPERKEY_CONFIGURE_ENABLE= rrtype-rkey
RRTYPETA_CONFIGURE_ENABLE= rrtype-ta
RRTYPEAVC_CONFIGURE_ENABLE= rrtype-avc
RRTYPEAMTRELAY_CONFIGURE_ENABLE= rrtype-amtrelay
-RRTYPESVCBHTTPS_CONFIGURE_ENABLE= rrtype-svcb-https
EXAMPLES_CONFIGURE_WITH= examples
DRILL_CONFIGURE_WITH= drill
DRILL_INSTALL_TARGET= install-drill
@@ -139,4 +137,10 @@ post-install:
.endif # BUILD_PYLDNS || BUILD_P5PERL
+.if (defined(BUILD_PYLDNS))
+post-install:
+# file /usr/local/lib/python3.9/site-packages/_ldns.so.3.5.0
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PYTHON_VERSION}/site-packages/_ldns.so.3.5.0
+.endif # BUILD_PYLDNS
+
.include <bsd.port.post.mk>
diff --git a/dns/ldns/distinfo b/dns/ldns/distinfo
index de9c486ad6ce..bfaa881cccf4 100644
--- a/dns/ldns/distinfo
+++ b/dns/ldns/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1638532111
-SHA256 (ldns-1.8.1.tar.gz) = 958229abce4d3aaa19a75c0d127666564b17216902186e952ca4aef47c6d7fa3
-SIZE (ldns-1.8.1.tar.gz) = 1284971
+TIMESTAMP = 1660561209
+SHA256 (ldns-1.8.3.tar.gz) = c3f72dd1036b2907e3a56e6acf9dfb2e551256b3c1bbd9787942deeeb70e7860
+SIZE (ldns-1.8.3.tar.gz) = 1299856
diff --git a/dns/ldns/files/patch-LibreSSL-3.5 b/dns/ldns/files/patch-LibreSSL-3.5
deleted file mode 100644
index 42af36a139eb..000000000000
--- a/dns/ldns/files/patch-LibreSSL-3.5
+++ /dev/null
@@ -1,92 +0,0 @@
-From 887d618239312cc8c11e41c45492eee02a8f28a2 Mon Sep 17 00:00:00 2001
-From: Theo Buehler <tb@openbsd.org>
-Date: Tue, 11 Jan 2022 21:14:24 +0100
-Subject: [PATCH] Use accessors for DSA and RSA objects
-
-In the upcoming LibreSSL version 3.5, the DSA and RSA structs will
-become opaque, so we should use the OpenSSL 1.1 setters and getters
-to fix the build. The relevant API has been available since
-LibreSSL 2.7. The last LibreSSL version (2.6) not having these
-accessors was EOL late 2018, so no users should be affected by this
-change.
----
- dnssec.c | 4 ++--
- host2str.c | 4 ++--
- keys.c | 6 +++---
- 3 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/dnssec.c b/dnssec.c
-index 63fece52..fbaa518a 100644
---- dnssec.c.orig
-+++ dnssec.c
-@@ -381,7 +381,7 @@ ldns_key_buf2dsa_raw(const unsigned char* key, size_t len)
- BN_free(Y);
- return NULL;
- }
--#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(HAVE_LIBRESSL)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000 || (defined(HAVE_LIBRESSL) && LIBRESSL_VERSION_NUMBER < 0x20700000)
- #ifndef S_SPLINT_S
- dsa->p = P;
- dsa->q = Q;
-@@ -468,7 +468,7 @@ ldns_key_buf2rsa_raw(const unsigned char* key, size_t len)
- BN_free(modulus);
- return NULL;
- }
--#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(HAVE_LIBRESSL)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000 || (defined(HAVE_LIBRESSL) && LIBRESSL_VERSION_NUMBER < 0x20700000)
- #ifndef S_SPLINT_S
- rsa->n = modulus;
- rsa->e = exponent;
-diff --git a/host2str.c b/host2str.c
-index a207a913..634c5676 100644
---- host2str.c.orig
-+++ host2str.c
-@@ -2451,7 +2451,7 @@ ldns_key2buffer_str(ldns_buffer *output, const ldns_key *k)
- const BIGNUM *n=NULL, *e=NULL, *d=NULL,
- *p=NULL, *q=NULL, *dmp1=NULL,
- *dmq1=NULL, *iqmp=NULL;
--#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(HAVE_LIBRESSL)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000 || (defined(HAVE_LIBRESSL) && LIBRESSL_VERSION_NUMBER < 0x20700000)
- n = rsa->n;
- e = rsa->e;
- d = rsa->d;
-@@ -2504,7 +2504,7 @@ ldns_key2buffer_str(ldns_buffer *output, const ldns_key *k)
- if(1) {
- const BIGNUM *p=NULL, *q=NULL, *g=NULL,
- *priv_key=NULL, *pub_key=NULL;
--#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(HAVE_LIBRESSL)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000 || (defined(HAVE_LIBRESSL) && LIBRESSL_VERSION_NUMBER < 0x20700000)
- #ifndef S_SPLINT_S
- p = dsa->p;
- q = dsa->q;
-diff --git a/keys.c b/keys.c
-index 91a3dffd..78bea972 100644
---- keys.c.orig
-+++ keys.c
-@@ -861,7 +861,7 @@ ldns_key_new_frm_fp_rsa_l(FILE *f, int *line_nr)
- }
- #endif /* splint */
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(HAVE_LIBRESSL)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000 || (defined(HAVE_LIBRESSL) && LIBRESSL_VERSION_NUMBER < 0x20700000)
- # ifndef S_SPLINT_S
- rsa->n = n;
- rsa->e = e;
-@@ -982,7 +982,7 @@ ldns_key_new_frm_fp_dsa_l(FILE *f, ATTR_UNUSED(int *line_nr))
- }
- #endif /* splint */
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(HAVE_LIBRESSL)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000 || (defined(HAVE_LIBRESSL) && LIBRESSL_VERSION_NUMBER < 0x20700000)
- # ifndef S_SPLINT_S
- dsa->p = p;
- dsa->q = q;
-@@ -1660,7 +1660,7 @@ ldns_key_rsa2bin(unsigned char *data, RSA *k, uint16_t *size)
- if (!k) {
- return false;
- }
--#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(HAVE_LIBRESSL)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000 || (defined(HAVE_LIBRESSL) && LIBRESSL_VERSION_NUMBER < 0x20700000)
- n = k->n;
- e = k->e;
- #else
diff --git a/dns/ldns/pkg-plist b/dns/ldns/pkg-plist
index a9b0a4bf0c47..be6782da8295 100644
--- a/dns/ldns/pkg-plist
+++ b/dns/ldns/pkg-plist
@@ -34,6 +34,7 @@ include/ldns/dnssec_sign.h
include/ldns/dnssec_verify.h
include/ldns/dnssec_zone.h
include/ldns/duration.h
+include/ldns/edns.h
include/ldns/error.h
include/ldns/higher.h
include/ldns/host2str.h
@@ -60,7 +61,7 @@ include/ldns/zone.h
lib/libldns.a
lib/libldns.so
lib/libldns.so.3
-lib/libldns.so.3.2.0
+lib/libldns.so.3.5.0
libdata/pkgconfig/libldns.pc
%%DRILL%%man/man1/drill.1.gz
%%EXAMPLES%%man/man1/ldns-chaos.1.gz
diff --git a/dns/py-ldns/pkg-plist b/dns/py-ldns/pkg-plist
index 3e25e7b926c6..4ec73ece3aa9 100644
--- a/dns/py-ldns/pkg-plist
+++ b/dns/py-ldns/pkg-plist
@@ -1,4 +1,4 @@
-%%PYTHON_SITELIBDIR%%/_ldns.so.3.2.0
+%%PYTHON_SITELIBDIR%%/_ldns.so.3.5.0
%%PYTHON_SITELIBDIR%%/_ldns.so.3
%%PYTHON_SITELIBDIR%%/ldns.py
%%PYTHON_SITELIBDIR%%/_ldns.so