aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-16 19:44:17 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-16 19:44:17 +0000
commit616e8c13a4ce5b66bbecf6020f38754802f19d47 (patch)
treeb0928ace4015619ec78b26eb08150253a558f08f
parentf6eadbaa18644c296bb4ba171931acbe3d7d9f01 (diff)
downloadports-616e8c13a4ce5b66bbecf6020f38754802f19d47.tar.gz
ports-616e8c13a4ce5b66bbecf6020f38754802f19d47.zip
devel/utf8cpp: Update to 3.2.4
- Update pkg-descr - Take maintainership Changes: https://github.com/nemtrif/utfcpp/releases
-rw-r--r--devel/utf8cpp/Makefile22
-rw-r--r--devel/utf8cpp/distinfo6
-rw-r--r--devel/utf8cpp/pkg-descr26
-rw-r--r--devel/utf8cpp/pkg-plist9
4 files changed, 35 insertions, 28 deletions
diff --git a/devel/utf8cpp/Makefile b/devel/utf8cpp/Makefile
index 234cacab7700..3b847137a6c2 100644
--- a/devel/utf8cpp/Makefile
+++ b/devel/utf8cpp/Makefile
@@ -1,9 +1,9 @@
PORTNAME= utf8cpp
+PORTVERSION= 3.2.4
DISTVERSIONPREFIX= v
-DISTVERSION= 3.2.3
CATEGORIES= devel
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Simple, portable, lightweight library for handling UTF-8 strings
WWW= https://github.com/nemtrif/utfcpp
@@ -11,20 +11,14 @@ LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake
-USE_GITHUB= yes
-GH_ACCOUNT= nemtrif
-GH_PROJECT= utfcpp
+
+CMAKE_ON= UTF8_INSTALL
+CMAKE_OFF= UTF8_SAMPLES UTF8_TESTS
NO_ARCH= yes
-PLIST_FILES= include/utf8cpp/utf8.h \
- include/utf8cpp/utf8/checked.h \
- include/utf8cpp/utf8/core.h \
- include/utf8cpp/utf8/cpp11.h \
- include/utf8cpp/utf8/cpp17.h \
- include/utf8cpp/utf8/unchecked.h \
- lib/cmake/utf8cpp/utf8cppConfig.cmake \
- lib/cmake/utf8cpp/utf8cppConfigVersion.cmake \
- lib/cmake/utf8cpp/utf8cppTargets.cmake
+USE_GITHUB= yes
+GH_ACCOUNT= nemtrif
+GH_PROJECT= utfcpp
.include <bsd.port.mk>
diff --git a/devel/utf8cpp/distinfo b/devel/utf8cpp/distinfo
index ff71ea0fe3f6..b71eaa405b62 100644
--- a/devel/utf8cpp/distinfo
+++ b/devel/utf8cpp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1672585721
-SHA256 (nemtrif-utfcpp-v3.2.3_GH0.tar.gz) = 3ba9b0dbbff08767bdffe8f03b10e596ca351228862722e4c9d4d126d2865250
-SIZE (nemtrif-utfcpp-v3.2.3_GH0.tar.gz) = 28770
+TIMESTAMP = 1692211611
+SHA256 (nemtrif-utfcpp-v3.2.4_GH0.tar.gz) = fde21a4c519eed25f095a1cd8490167409cc70d7b5e9c38756142e588ccb7c7e
+SIZE (nemtrif-utfcpp-v3.2.4_GH0.tar.gz) = 28822
diff --git a/devel/utf8cpp/pkg-descr b/devel/utf8cpp/pkg-descr
index 7f58e4c9dc94..d24a3ee84462 100644
--- a/devel/utf8cpp/pkg-descr
+++ b/devel/utf8cpp/pkg-descr
@@ -1,12 +1,16 @@
-Many C++ developers miss an easy and portable way of handling Unicode
-encoded strings. The original C++ Standard (known as C++98 or C++03) is
-Unicode agnostic. C++11 provides some support for Unicode on core
-language and library level: u8, u, and U character and string literals,
-char16_t and char32_t character types, u16string and u32string library
-classes, and codecvt support for conversions between Unicode encoding
-forms. In the meantime, developers use third party libraries like ICU,
-OS specific capabilities, or simply roll out their own solutions.
+C++ developers miss an easy and portable way of handling Unicode encoded
+strings. The original C++ Standard (known as C++98 or C++03) is Unicode
+agnostic. C++11 provides some support for Unicode on core language and library
+level: u8, u, and U character and string literals, char16_t and char32_t
+character types, u16string and u32string library classes, and codecvt support
+for conversions between Unicode encoding forms. In the meantime, developers use
+third party libraries like ICU, OS specific capabilities, or simply roll out
+their own solutions.
-In order to easily handle UTF-8 encoded Unicode strings, I came up with
-a small generic library. For anybody used to work with STL algorithms
-and iterators, it should be easy and natural to use.
+In order to easily handle UTF-8 encoded Unicode strings, I came up with a small,
+C++98 compatible generic library. For anybody used to work with STL algorithms
+and iterators, it should be easy and natural to use. The code is freely
+available for any purpose - check out the license. The library has been used a
+lot in the past ten years both in commercial and open-source projects and is
+considered feature-complete now. If you run into bugs or performance issues,
+please let me know and I'll do my best to address them.
diff --git a/devel/utf8cpp/pkg-plist b/devel/utf8cpp/pkg-plist
new file mode 100644
index 000000000000..d3e1e958a5d5
--- /dev/null
+++ b/devel/utf8cpp/pkg-plist
@@ -0,0 +1,9 @@
+include/utf8cpp/utf8.h
+include/utf8cpp/utf8/checked.h
+include/utf8cpp/utf8/core.h
+include/utf8cpp/utf8/cpp11.h
+include/utf8cpp/utf8/cpp17.h
+include/utf8cpp/utf8/unchecked.h
+lib/cmake/utf8cpp/utf8cppConfig.cmake
+lib/cmake/utf8cpp/utf8cppConfigVersion.cmake
+lib/cmake/utf8cpp/utf8cppTargets.cmake