aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2023-02-20 20:41:18 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2023-02-20 20:41:18 +0000
commit617004df297538c3c79a196da3d358a61cfce72a (patch)
tree1373a7c96b6620ef0cb2cefb0e58c3a6e5b27314
parent98931df3a9719c05cf9b29fdc1c3ebbead63be82 (diff)
downloadports-617004d.tar.gz
ports-617004d.zip
devel/yaml-cpp03: Remove
devel/yaml-cpp03 was created to provide old library versions to support the blender-lts28 port which has been deleted after EOL. PR: 268477 Reported by: Shane <FreeBSD@ShaneWare.Biz> Approved by: tim@niemueller.de (maintainer)
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/yaml-cpp03/Makefile27
-rw-r--r--devel/yaml-cpp03/distinfo3
-rw-r--r--devel/yaml-cpp03/files/patch-CMakeLists.txt34
-rw-r--r--devel/yaml-cpp03/pkg-descr1
-rw-r--r--devel/yaml-cpp03/pkg-plist31
7 files changed, 1 insertions, 97 deletions
diff --git a/MOVED b/MOVED
index 68479d0c55f9..f95d17b65ddc 100644
--- a/MOVED
+++ b/MOVED
@@ -17765,3 +17765,4 @@ finance/py-TA-Lib|finance/py-ta-lib|2023-02-12|Remove duplicate port
x11-toolkits/gnocl||2023-02-13|Fails to build, newer snapshot depends on a removed port
games/opendungeons||2023-02-14|Has expired: Broken for more than 6 months
databases/mysql-connector-odbc|databases/mysql-connector-odbc-80|2023-02-18|Has expired: Requires EOLd mysql version
+devel/yaml-cpp03|devel/yaml-cpp|2023-02-21|Used by blender-lts28 which is EOL'd
diff --git a/devel/Makefile b/devel/Makefile
index 1478b7f9038f..0f43ffaaca65 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7604,7 +7604,6 @@
SUBDIR += yajl
SUBDIR += yajl-tcl
SUBDIR += yaml-cpp
- SUBDIR += yaml-cpp03
SUBDIR += yaml2argdata
SUBDIR += yasm
SUBDIR += yder
diff --git a/devel/yaml-cpp03/Makefile b/devel/yaml-cpp03/Makefile
deleted file mode 100644
index 8709c74027d1..000000000000
--- a/devel/yaml-cpp03/Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
-PORTNAME= yaml-cpp
-PORTVERSION= 0.3.0
-PORTREVISION= 2
-DISTVERSIONPREFIX= release-
-CATEGORIES= devel
-PKGNAMESUFFIX= 03
-
-MAINTAINER= tim@niemueller.de
-COMMENT= YAML parser and emitter in C++ matching the YAML 1.2 spec
-WWW= https://code.google.com/p/yaml-cpp/
-
-LICENSE= MIT
-
-USES= compiler:c++11-lang cmake
-USE_LDCONFIG= yes
-CMAKE_ARGS+= -DBUILD_SHARED_LIBS:BOOL=ON -DYAML_CPP_BUILD_TOOLS=0
-
-USE_GITHUB= yes
-GH_ACCOUNT= jbeder
-
-post-patch: .SILENT
- ${FIND} ${WRKSRC} -name '*.[hc]*' -o -name CMakeLists.txt | \
- ${XARGS} ${REINPLACE_CMD} -e 's|yaml-cpp|yaml-cpp${PKGNAMESUFFIX}|g'
- ${MV} ${WRKSRC}/include/yaml-cpp ${WRKSRC}/include/yaml-cpp${PKGNAMESUFFIX}
- ${MV} ${WRKSRC}/yaml-cpp.pc.cmake ${WRKSRC}/yaml-cpp${PKGNAMESUFFIX}.pc.cmake
-
-.include <bsd.port.mk>
diff --git a/devel/yaml-cpp03/distinfo b/devel/yaml-cpp03/distinfo
deleted file mode 100644
index ead85cf89645..000000000000
--- a/devel/yaml-cpp03/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1474037192
-SHA256 (jbeder-yaml-cpp-release-0.3.0_GH0.tar.gz) = ab8d0e07aa14f10224ed6682065569761f363ec44bc36fcdb2946f6d38fe5a89
-SIZE (jbeder-yaml-cpp-release-0.3.0_GH0.tar.gz) = 83201
diff --git a/devel/yaml-cpp03/files/patch-CMakeLists.txt b/devel/yaml-cpp03/files/patch-CMakeLists.txt
deleted file mode 100644
index da69502f0eeb..000000000000
--- a/devel/yaml-cpp03/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
---- CMakeLists.txt.orig 2013-04-14 03:37:53.000000000 +0400
-+++ CMakeLists.txt 2014-09-11 17:37:09.000000000 +0400
-@@ -139,11 +139,11 @@ if(CMAKE_COMPILER_IS_GNUCXX)
- #
- set(CMAKE_CXX_FLAGS "-Wall ${GCC_EXTRA_OPTIONS} -pedantic -Wno-long-long ${CMAKE_CXX_FLAGS}")
- #
-- add_custom_target(debuggable $(MAKE) clean
-+ add_custom_target(debuggable make clean
- COMMAND ${CMAKE_COMMAND} -DCMAKE_BUILD_TYPE=Debug ${CMAKE_SOURCE_DIR}
- COMMENT "Adjusting settings for debug compilation"
- VERBATIM)
-- add_custom_target(releasable $(MAKE) clean
-+ add_custom_target(releasable make clean
- COMMAND ${CMAKE_COMMAND} -DCMAKE_BUILD_TYPE=Release ${CMAKE_SOURCE_DIR}
- COMMENT "Adjusting settings for release compilation"
- VERBATIM)
-@@ -240,7 +240,7 @@
-
- set_target_properties(yaml-cpp PROPERTIES
- VERSION "${YAML_CPP_VERSION}"
-- SOVERSION "${YAML_CPP_VERSION_MAJOR}.${YAML_CPP_VERSION_MINOR}"
-+ SOVERSION "${YAML_CPP_VERSION_MAJOR}"
- PROJECT_LABEL "yaml-cpp ${LABEL_SUFFIX}"
- )
-
-@@ -272,7 +272,7 @@
- if(UNIX)
- set(PC_FILE ${CMAKE_BINARY_DIR}/yaml-cpp.pc)
- configure_file("yaml-cpp.pc.cmake" ${PC_FILE} @ONLY)
-- install(FILES ${PC_FILE} DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
-+ install(FILES ${PC_FILE} DESTINATION libdata/pkgconfig)
- endif()
-
-
diff --git a/devel/yaml-cpp03/pkg-descr b/devel/yaml-cpp03/pkg-descr
deleted file mode 100644
index 5267ec772baa..000000000000
--- a/devel/yaml-cpp03/pkg-descr
+++ /dev/null
@@ -1 +0,0 @@
-yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec.
diff --git a/devel/yaml-cpp03/pkg-plist b/devel/yaml-cpp03/pkg-plist
deleted file mode 100644
index 847acc980bed..000000000000
--- a/devel/yaml-cpp03/pkg-plist
+++ /dev/null
@@ -1,31 +0,0 @@
-include/yaml-cpp03/aliasmanager.h
-include/yaml-cpp03/anchor.h
-include/yaml-cpp03/binary.h
-include/yaml-cpp03/contrib/anchordict.h
-include/yaml-cpp03/contrib/graphbuilder.h
-include/yaml-cpp03/conversion.h
-include/yaml-cpp03/dll.h
-include/yaml-cpp03/emitfromevents.h
-include/yaml-cpp03/emitter.h
-include/yaml-cpp03/emittermanip.h
-include/yaml-cpp03/eventhandler.h
-include/yaml-cpp03/exceptions.h
-include/yaml-cpp03/iterator.h
-include/yaml-cpp03/ltnode.h
-include/yaml-cpp03/mark.h
-include/yaml-cpp03/node.h
-include/yaml-cpp03/nodeimpl.h
-include/yaml-cpp03/nodereadimpl.h
-include/yaml-cpp03/nodeutil.h
-include/yaml-cpp03/noncopyable.h
-include/yaml-cpp03/null.h
-include/yaml-cpp03/ostream.h
-include/yaml-cpp03/parser.h
-include/yaml-cpp03/stlemitter.h
-include/yaml-cpp03/stlnode.h
-include/yaml-cpp03/traits.h
-include/yaml-cpp03/yaml.h
-lib/libyaml-cpp03.so
-lib/libyaml-cpp03.so.0
-lib/libyaml-cpp03.so.0.3.0
-libdata/pkgconfig/yaml-cpp03.pc