aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2022-05-22 18:28:57 +0000
committerDima Panov <fluffy@FreeBSD.org>2022-05-22 20:17:03 +0000
commit617a8b4cd8dca0ef1563a1727540a99d91eaba45 (patch)
treed23e5440a3e0da17da0899d319a8fb3c71728663
parentb3409f4fb0c5c537d7cc0631388c970072e32a88 (diff)
downloadports-617a8b4cd8dca0ef1563a1727540a99d91eaba45.tar.gz
ports-617a8b4cd8dca0ef1563a1727540a99d91eaba45.zip
databases/mongodb40: switch to bundled old boost
PR: 246106
-rw-r--r--databases/mongodb40/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/databases/mongodb40/Makefile b/databases/mongodb40/Makefile
index 6cef7bc3001d..4617de24ca20 100644
--- a/databases/mongodb40/Makefile
+++ b/databases/mongodb40/Makefile
@@ -1,6 +1,7 @@
PORTNAME= mongodb
DISTVERSIONPREFIX= r
DISTVERSION= 4.0.28
+PORTREVISION= 1
CATEGORIES= databases net
MASTER_SITES= https://fastdl.mongodb.org/src/ \
http://fastdl.mongodb.org/src/
@@ -22,12 +23,11 @@ ONLY_FOR_ARCHS_REASON= only supported on amd64, aarch64, and powerpc64le; i386 d
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cheetah3>0:devel/py-cheetah3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml@${PY_FLAVOR} \
${LOCALBASE}/bin/ar:devel/binutils
-LIB_DEPENDS= libboost_system.so:devel/boost-libs \
- libpcre.so:devel/pcre \
+LIB_DEPENDS= libpcre.so:devel/pcre \
libcurl.so:ftp/curl \
libsnappy.so:archivers/snappy
-USES= compiler:c++14-lang cpe python:3.5+,build scons shebangfix
+USES= compiler:c++14-lang cpe python:3.7+,build scons shebangfix
USE_RC_SUBR= mongod
CONFLICTS_INSTALL= mongodb36 mongodb4[24] mongodb50
@@ -37,7 +37,7 @@ python_OLD_CMD= @python_interpreter@
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} \
--use-system-pcre --use-system-snappy \
- --use-system-boost --use-system-zlib \
+ --use-system-zlib \
--cxx-std=14 --libc++ \
--runtime-hardening=on \
--disable-warnings-as-errors \