aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2022-05-13 13:16:17 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-05-15 09:22:45 +0000
commit617e0982019746729e9ac8a9903016ff5f246d40 (patch)
tree5c2be8e00f10fe614b7a28df5d9d1e44b5b409d7
parent82bb72e9b808a52daf7fe5e5d1bee986cd5ed719 (diff)
downloadports-617e0982019746729e9ac8a9903016ff5f246d40.tar.gz
ports-617e0982019746729e9ac8a9903016ff5f246d40.zip
Mk/Uses: make a copy of package.xml
When installing pear ports with php80-pear-1.10.12, I noticed a failure: the file package.xml disappeared from $WRKSRC and the symlink became invalid. PR: 263942
-rw-r--r--Mk/Uses/pear.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/Uses/pear.mk b/Mk/Uses/pear.mk
index a04a163fbdb8..e3412fa1fa46 100644
--- a/Mk/Uses/pear.mk
+++ b/Mk/Uses/pear.mk
@@ -114,6 +114,10 @@ pear-pre-install:
@${ECHO_MSG} ""
@${FALSE}
. endif
+ (if [ -f ${WRKSRC}/package.xml ] \
+ && [ ! -f ${WRKDIR}/package.xml ] ; then \
+ ${CP} -p ${WRKSRC}/package.xml ${WRKDIR} ; \
+ fi)
DIRFILTER= ${SED} -En '\:^.*/[^/]*$$:s:^(.+)/[^/]*$$:\1:p' \
| ( while read r; do \