aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2023-05-29 14:07:02 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2023-05-29 14:39:49 +0000
commit61cf9409b2d72c85d76424e86bcf1fe79d627913 (patch)
tree5a072682ac0086c71a61b0d5345f57c6c68fa61f
parentd2acce4664ce682d83cec435e394987ce76461f8 (diff)
downloadports-61cf9409b2d72c85d76424e86bcf1fe79d627913.tar.gz
ports-61cf9409b2d72c85d76424e86bcf1fe79d627913.zip
databases/postgresql-libpqxx: update to 7.7.5
-rw-r--r--databases/postgresql-libpqxx/Makefile5
-rw-r--r--databases/postgresql-libpqxx/distinfo6
-rw-r--r--databases/postgresql-libpqxx/pkg-plist24
3 files changed, 24 insertions, 11 deletions
diff --git a/databases/postgresql-libpqxx/Makefile b/databases/postgresql-libpqxx/Makefile
index affda0f41518..4039e5ad2458 100644
--- a/databases/postgresql-libpqxx/Makefile
+++ b/databases/postgresql-libpqxx/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libpqxx
-PORTVERSION= 7.2.0
+PORTVERSION= 7.7.5
CATEGORIES= databases
PKGNAMEPREFIX= postgresql-
DIST_SUBDIR= postgresql
@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
CONFLICTS= postgresql-libpqxx-[1-5].* postgresql-libpqxx3-3.* \
postgresql-libpqxx4-4.*
-USES= compiler:c++11-lang gmake libtool pathfix pgsql python:build shebangfix
+USES= compiler:c++17-lang gmake libtool pathfix pgsql python:build shebangfix
USE_GITHUB= yes
GH_ACCOUNT= jtv
GNU_CONFIGURE= yes
@@ -25,5 +25,6 @@ PLIST_SUB= PORTVERSION=${PORTVERSION:R}
CONFIGURE_ARGS= --enable-shared \
--disable-documentation \
--disable-dependency-tracking
+CXXFLAGS+= -std=c++17
.include <bsd.port.mk>
diff --git a/databases/postgresql-libpqxx/distinfo b/databases/postgresql-libpqxx/distinfo
index 54e68472f2b5..0d2260e1025b 100644
--- a/databases/postgresql-libpqxx/distinfo
+++ b/databases/postgresql-libpqxx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1600331537
-SHA256 (postgresql/jtv-libpqxx-7.2.0_GH0.tar.gz) = c482a31c5d08402bc9e8df8291bed3555640ea80b3cb354fca958b1b469870dd
-SIZE (postgresql/jtv-libpqxx-7.2.0_GH0.tar.gz) = 707225
+TIMESTAMP = 1685350121
+SHA256 (postgresql/jtv-libpqxx-7.7.5_GH0.tar.gz) = c7dc3e8fa2eee656f2b6a8179d72f15db10e97a80dc4f173f806e615ea990973
+SIZE (postgresql/jtv-libpqxx-7.7.5_GH0.tar.gz) = 745921
diff --git a/databases/postgresql-libpqxx/pkg-plist b/databases/postgresql-libpqxx/pkg-plist
index 76c7c6d75e7b..14bdc47f0db9 100644
--- a/databases/postgresql-libpqxx/pkg-plist
+++ b/databases/postgresql-libpqxx/pkg-plist
@@ -2,7 +2,8 @@ include/pqxx/array
include/pqxx/array.hxx
include/pqxx/binarystring
include/pqxx/binarystring.hxx
-include/pqxx/compiler-public.hxx
+include/pqxx/blob
+include/pqxx/blob.hxx
include/pqxx/composite
include/pqxx/composite.hxx
include/pqxx/config-public-compiler.h
@@ -20,8 +21,7 @@ include/pqxx/field
include/pqxx/field.hxx
include/pqxx/internal/array-composite.hxx
include/pqxx/internal/callgate.hxx
-include/pqxx/internal/compiler-internal-post.hxx
-include/pqxx/internal/compiler-internal-pre.hxx
+include/pqxx/internal/concat.hxx
include/pqxx/internal/conversions.hxx
include/pqxx/internal/encoding_group.hxx
include/pqxx/internal/encodings.hxx
@@ -30,6 +30,8 @@ include/pqxx/internal/gates/connection-largeobject.hxx
include/pqxx/internal/gates/connection-notification_receiver.hxx
include/pqxx/internal/gates/connection-pipeline.hxx
include/pqxx/internal/gates/connection-sql_cursor.hxx
+include/pqxx/internal/gates/connection-stream_from.hxx
+include/pqxx/internal/gates/connection-stream_to.hxx
include/pqxx/internal/gates/connection-transaction.hxx
include/pqxx/internal/gates/errorhandler-connection.hxx
include/pqxx/internal/gates/icursor_iterator-icursorstream.hxx
@@ -39,15 +41,18 @@ include/pqxx/internal/gates/result-creation.hxx
include/pqxx/internal/gates/result-pipeline.hxx
include/pqxx/internal/gates/result-sql_cursor.hxx
include/pqxx/internal/gates/transaction-sql_cursor.hxx
-include/pqxx/internal/gates/transaction-transactionfocus.hxx
+include/pqxx/internal/gates/transaction-transaction_focus.hxx
+include/pqxx/internal/header-post.hxx
+include/pqxx/internal/header-pre.hxx
include/pqxx/internal/ignore-deprecated-post.hxx
include/pqxx/internal/ignore-deprecated-pre.hxx
include/pqxx/internal/libpq-forward.hxx
include/pqxx/internal/result_iter.hxx
+include/pqxx/internal/result_iterator.hxx
include/pqxx/internal/sql_cursor.hxx
include/pqxx/internal/statement_parameters.hxx
include/pqxx/internal/stream_iterator.hxx
-include/pqxx/internal/transaction_focus.hxx
+include/pqxx/internal/wait.hxx
include/pqxx/isolation
include/pqxx/isolation.hxx
include/pqxx/largeobject
@@ -56,14 +61,17 @@ include/pqxx/nontransaction
include/pqxx/nontransaction.hxx
include/pqxx/notification
include/pqxx/notification.hxx
+include/pqxx/params
+include/pqxx/params.hxx
include/pqxx/pipeline
include/pqxx/pipeline.hxx
include/pqxx/pqxx
include/pqxx/prepared_statement
include/pqxx/prepared_statement.hxx
+include/pqxx/range
+include/pqxx/range.hxx
include/pqxx/result
include/pqxx/result.hxx
-include/pqxx/result_iterator.hxx
include/pqxx/robusttransaction
include/pqxx/robusttransaction.hxx
include/pqxx/row
@@ -78,10 +86,14 @@ include/pqxx/stream_to
include/pqxx/stream_to.hxx
include/pqxx/subtransaction
include/pqxx/subtransaction.hxx
+include/pqxx/time
+include/pqxx/time.hxx
include/pqxx/transaction
include/pqxx/transaction.hxx
include/pqxx/transaction_base
include/pqxx/transaction_base.hxx
+include/pqxx/transaction_focus
+include/pqxx/transaction_focus.hxx
include/pqxx/transactor
include/pqxx/transactor.hxx
include/pqxx/types