aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-04-20 10:22:00 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-04-20 10:25:17 +0000
commit620d7678c819d85f9236d2e307009a5aca088970 (patch)
treeac34cdbba02c62d1622fa54108bfc8948f459952
parent324a4fd7b26a2db5e797ecb0a5f1e74dedd0b17a (diff)
downloadports-620d7678c819d85f9236d2e307009a5aca088970.tar.gz
ports-620d7678c819d85f9236d2e307009a5aca088970.zip
kde.mk: Support KDE ports with no DOCS
The kde.mk framework automatically does DOCS for KDE ports -- but not all of them have documentation, so then you get a weird situation of OPTIONS_DEFINE=DOCS in a port that has no documentation (e.g. sysutils/baloo-widgets) where the option has no effect at all. Massage the machinery a little so that the bogus option can be dropped; KDE ports with no docs should not define a DOCS option any more. PR: 252363
-rw-r--r--Mk/Uses/kde.mk7
-rw-r--r--sysutils/baloo-widgets/Makefile2
2 files changed, 6 insertions, 3 deletions
diff --git a/Mk/Uses/kde.mk b/Mk/Uses/kde.mk
index 8556bb1d5cca..5ddeeccd61f7 100644
--- a/Mk/Uses/kde.mk
+++ b/Mk/Uses/kde.mk
@@ -155,9 +155,14 @@ MASTER_SITES?= KDE/${KDE_APPLICATIONS_BRANCH}/applications/${KDE_APPLICATIONS_V
MASTER_SITES?= KDE/${KDE_APPLICATIONS_BRANCH}/release-service/${KDE_APPLICATIONS_VERSION}/src
# Let bsd.port.mk create the plist-entries for the documentation.
# KDE Applications ports install their documentation to
-# ${PREFIX}/share/doc.
+# ${PREFIX}/share/doc. This is only done if the port
+# defines OPTION DOCS -- the _KDE_OPTIONS here is to
+# avoid make errors when there are no options defined at all.
+_KDE_OPTIONS= bogus ${OPTIONS_DEFINE}
+. if ${_KDE_OPTIONS:MDOCS}
DOCSDIR= ${PREFIX}/share/doc
PORTDOCS?= HTML/*
+. endif
# Further pass along a SHLIB_VER PLIST_SUB
PLIST_SUB+= KDE_APPLICATIONS_SHLIB_VER=${KDE_APPLICATIONS_SHLIB_VER} \
KDE_APPLICATIONS_VERSION_SHORT="${KDE_APPLICATIONS_VERSION:R:R}"
diff --git a/sysutils/baloo-widgets/Makefile b/sysutils/baloo-widgets/Makefile
index 56a2bb97a391..916b6ddc7c77 100644
--- a/sysutils/baloo-widgets/Makefile
+++ b/sysutils/baloo-widgets/Makefile
@@ -13,8 +13,6 @@ USE_QT= concurrent core dbus gui network testlib widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS
-
# Override shared library version
KDE_APPLICATIONS_SHLIB_VER=${KDE_APPLICATIONS_VERSION}