aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-06-15 15:23:48 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-06-15 15:23:48 +0000
commit6224d84fbb20fed172a69817c36b4d1f2e197e64 (patch)
tree965b31b7ccbfab4e677e4e94a0387a92f1e74410
parent478a722e81ae0038fc34d1ea4ae93c13e897ab3c (diff)
downloadports-6224d84fbb20fed172a69817c36b4d1f2e197e64.tar.gz
ports-6224d84fbb20fed172a69817c36b4d1f2e197e64.zip
- Set 'wait_timeout' to a safer value.
- Bump PORTREVISION. Discussed with: ale via email
Notes
Notes: svn path=/head/; revision=299352
-rw-r--r--databases/akonadi/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
index 17dc9176eca4..449c6ca27535 100644
--- a/databases/akonadi/Makefile
+++ b/databases/akonadi/Makefile
@@ -6,7 +6,7 @@
PORTNAME= akonadi
PORTVERSION= 1.7.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/src/
@@ -77,9 +77,10 @@ post-patch:
${PATCH_WRKSRC}/server/CMakeLists.txt
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${PATCH_WRKSRC}/server/src/storage/dbconfigmysql.cpp
- # MySQL seems to have this limit on FreeBSD (same of Windows
- # but undocumented and unstable).
- ${REINPLACE_CMD} -e '/wait_timeout/ s|31536000|2147483|' \
+ # To avoid overflow, MySQL settings need to be lower than
+ # INT_MAX / kern.hz. This setting assumes kern.hz=2000, and
+ # it's nothing but a temporary hack.
+ ${REINPLACE_CMD} -e '/wait_timeout/ s|31536000|1073741|' \
${PATCH_WRKSRC}/server/src/storage/*.conf
# Prevent updating MIME during build.
${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d; /SharedMimeInfo/ d' \