aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2023-04-24 16:07:15 +0000
committerMikael Urankar <mikael@FreeBSD.org>2023-04-24 17:50:43 +0000
commit624bde48cd1c06c4cfb73982e55b9a6199ce4851 (patch)
tree71abc94c909a21e7d7f72c3410310dfb5de7f244
parent5541fd26f03f05face11918c8a796206346788d3 (diff)
downloadports-624bde48cd1c06c4cfb73982e55b9a6199ce4851.tar.gz
ports-624bde48cd1c06c4cfb73982e55b9a6199ce4851.zip
lang/rust: always build rustdoc
Due to a regression in rust [1], rustdoc is not built anymore but is required by some ports. Force the build of rustdoc. [1] https://github.com/rust-lang/rust/commit/11e002a001348e7ea035c0cb2665be806e2a832e PR: 271036
-rw-r--r--lang/rust/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 7cc3e33cc660..501d8c8b7a02 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -1,6 +1,6 @@
PORTNAME= rust
PORTVERSION?= 1.69.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= lang
MASTER_SITES= https://static.rust-lang.org/dist/:src \
https://dev-static.rust-lang.org/dist/:src \
@@ -80,7 +80,7 @@ _RUST_ARCH_i386= i686
_RUST_ARCH_riscv64= riscv64gc
_RUST_TARGET= ${_RUST_ARCH_${ARCH}:U${ARCH}}-unknown-${OPSYS:tl}
_RUST_TARGETS= ${_RUST_TARGET}
-_RUST_TOOLS= analysis cargo clippy rustfmt
+_RUST_TOOLS= analysis cargo clippy rustdoc rustfmt
_RUSTC_BOOTSTRAP= ${BOOTSTRAPS_DATE_${ARCH}:U${BOOTSTRAPS_DATE}}/rustc-${RUST_BOOTSTRAP_VERSION_${ARCH}:U${RUST_BOOTSTRAP_VERSION}}-${_RUST_TARGET}
_RUST_STD_BOOTSTRAP= ${BOOTSTRAPS_DATE_${ARCH}:U${BOOTSTRAPS_DATE}}/rust-std-${RUST_BOOTSTRAP_VERSION_${ARCH}:U${RUST_BOOTSTRAP_VERSION}}-${_RUST_TARGET}