aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-01-01 02:48:26 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-01-01 08:09:01 +0000
commit628705efc5f3fee6d1538ab103361f4fd19cf549 (patch)
tree939658a6384bb90235bef1dc24939d852098891c
parent45d8e3793cfcb95e6c359e18b4cd4477eab60519 (diff)
downloadports-628705efc5f3fee6d1538ab103361f4fd19cf549.tar.gz
ports-628705efc5f3fee6d1538ab103361f4fd19cf549.zip
math/py-squarify: New port: Squarify treemap layout algorithm
-rw-r--r--math/Makefile1
-rw-r--r--math/py-squarify/Makefile18
-rw-r--r--math/py-squarify/distinfo3
-rw-r--r--math/py-squarify/pkg-descr8
4 files changed, 30 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index d41e49720103..53ff700a427e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -1069,6 +1069,7 @@
SUBDIR += py-spot
SUBDIR += py-spreg
SUBDIR += py-spvcm
+ SUBDIR += py-squarify
SUBDIR += py-ssm
SUBDIR += py-statsmodels
SUBDIR += py-svgmath
diff --git a/math/py-squarify/Makefile b/math/py-squarify/Makefile
new file mode 100644
index 000000000000..ffc11dc69435
--- /dev/null
+++ b/math/py-squarify/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= squarify
+PORTVERSION= 0.4.3
+CATEGORIES= math python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Squarify treemap layout algorithm
+WWW= https://github.com/laserson/squarify
+
+LICENSE= APACHE20
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-squarify/distinfo b/math/py-squarify/distinfo
new file mode 100644
index 000000000000..d687e97923fc
--- /dev/null
+++ b/math/py-squarify/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1704074541
+SHA256 (squarify-0.4.3.tar.gz) = 54091f6ad175f7f201f8934574e647ce1b50dedc478c5fd968688eb7d7469f95
+SIZE (squarify-0.4.3.tar.gz) = 4292
diff --git a/math/py-squarify/pkg-descr b/math/py-squarify/pkg-descr
new file mode 100644
index 000000000000..6158129451a4
--- /dev/null
+++ b/math/py-squarify/pkg-descr
@@ -0,0 +1,8 @@
+squarify is a pure Python implementation of the squarify treemap layout
+algorithm.
+
+squarify is an extension to the treemap method for the visualization of
+hierarchical information, such as directory structures and Organization
+structures, is presented. The Standard treemap method often gives thin,
+elongated rectangles. As a result, rectangles are difficult to compare and
+to select.