aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-30 00:37:32 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-30 00:37:32 +0000
commit62b38d8b9980bd0c49ee1c357672b7b3f8261a19 (patch)
treee8d4b0aaf8bb00d383ac76e8c1fdc071779e5627
parentd0abc2860d822a6b69cafb457ff1bfd435f57047 (diff)
downloadports-62b38d8b9980bd0c49ee1c357672b7b3f8261a19.tar.gz
ports-62b38d8b9980bd0c49ee1c357672b7b3f8261a19.zip
graphics/py-sqlalchemy-imageattach: New port: SQLAlchemy extension for attaching images to entities
SQLAlchemy-ImageAttach is a SQLAlchemy extension for attaching images to entity objects. It provides the following features: - Storage backend interface - Maintaining multiple image sizes - Every image has its URL - SQLAlchemy transaction aware
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-sqlalchemy-imageattach/Makefile21
-rw-r--r--graphics/py-sqlalchemy-imageattach/distinfo3
-rw-r--r--graphics/py-sqlalchemy-imageattach/pkg-descr7
4 files changed, 32 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 553cd3f80113..42bc2033ed5d 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -950,6 +950,7 @@
SUBDIR += py-seqdiag
SUBDIR += py-sorl-thumbnail
SUBDIR += py-spectra
+ SUBDIR += py-sqlalchemy-imageattach
SUBDIR += py-svg.path
SUBDIR += py-svgwrite
SUBDIR += py-termtosvg
diff --git a/graphics/py-sqlalchemy-imageattach/Makefile b/graphics/py-sqlalchemy-imageattach/Makefile
new file mode 100644
index 000000000000..821701b5f085
--- /dev/null
+++ b/graphics/py-sqlalchemy-imageattach/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= SQLAlchemy-ImageAttach
+PORTVERSION= 1.1.0
+CATEGORIES= graphics python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= SQLAlchemy extension for attaching images to entities
+WWW= https://github.com/dahlia/sqlalchemy-imageattach
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>0:databases/py-sqlalchemy10@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Wand>0:graphics/py-wand@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-sqlalchemy-imageattach/distinfo b/graphics/py-sqlalchemy-imageattach/distinfo
new file mode 100644
index 000000000000..5ae1aee60a42
--- /dev/null
+++ b/graphics/py-sqlalchemy-imageattach/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1680321015
+SHA256 (SQLAlchemy-ImageAttach-1.1.0.tar.gz) = a9e3d56da889119e2105b3fee660ec259bb3b51be28173efb1ba129a52710ec4
+SIZE (SQLAlchemy-ImageAttach-1.1.0.tar.gz) = 29038
diff --git a/graphics/py-sqlalchemy-imageattach/pkg-descr b/graphics/py-sqlalchemy-imageattach/pkg-descr
new file mode 100644
index 000000000000..769daeecd28f
--- /dev/null
+++ b/graphics/py-sqlalchemy-imageattach/pkg-descr
@@ -0,0 +1,7 @@
+SQLAlchemy-ImageAttach is a SQLAlchemy extension for attaching images to entity
+objects. It provides the following features:
+
+- Storage backend interface
+- Maintaining multiple image sizes
+- Every image has its URL
+- SQLAlchemy transaction aware