aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-08-25 17:41:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-08-26 06:30:22 +0000
commit630a8a1ea538f72e0a0e00e645758982cdba095a (patch)
tree0e26ab49e5a4688668fe8e495be28d7370232db9
parent827afb1759885006e4b8cf0fff60f37d8a366ff8 (diff)
downloadports-630a8a1ea538f72e0a0e00e645758982cdba095a.tar.gz
ports-630a8a1ea538f72e0a0e00e645758982cdba095a.zip
devel/qca: add flavors for Qt 5 and Qt 6
-rw-r--r--Mk/Uses/qca.mk9
-rw-r--r--audio/amarok/Makefile2
-rw-r--r--databases/kbibtex/Makefile2
-rw-r--r--deskutils/kdeconnect-kde/Makefile1
-rw-r--r--deskutils/kdepim-runtime/Makefile1
-rw-r--r--devel/okteta/Makefile1
-rw-r--r--devel/qca/Makefile23
-rw-r--r--devel/qca/pkg-plist66
-rw-r--r--editors/calligra/Makefile2
-rw-r--r--finance/skrooge/Makefile1
-rw-r--r--games/ksirk/Makefile1
-rw-r--r--graphics/okular/Makefile1
-rw-r--r--graphics/qgis-ltr/Makefile1
-rw-r--r--graphics/qgis/Makefile1
-rw-r--r--irc/konversation/Makefile1
-rw-r--r--irc/quassel/Makefile2
-rw-r--r--net-im/kopete/Makefile1
-rw-r--r--net-im/ktp-auth-handler/Makefile1
-rw-r--r--net-im/psi/Makefile1
-rw-r--r--net-p2p/libktorrent/Makefile1
-rw-r--r--net/kget/Makefile1
-rw-r--r--net/messagelib/Makefile1
-rw-r--r--net/qoauth-qt5/Makefile2
-rw-r--r--polish/kadu/Makefile2
-rw-r--r--sysutils/kf5-kwallet/Makefile1
-rw-r--r--www/choqok/Makefile2
-rw-r--r--x11/plasma5-kactivitymanagerd/Makefile2
27 files changed, 81 insertions, 49 deletions
diff --git a/Mk/Uses/qca.mk b/Mk/Uses/qca.mk
index 72f46105946c..29ef2215f72f 100644
--- a/Mk/Uses/qca.mk
+++ b/Mk/Uses/qca.mk
@@ -13,11 +13,16 @@ _INCLUDE_QCA_MK= yes
IGNORE+= USES=qca takes no arguments
. endif
-_QCA_LIB= libqca-qt5.so
+. if empty(USES:Mqt*)
+IGNORE+= Qt version not specified
+. endif
+
+_QCA_LIB= libqca-qt${_QT_VER}.so
_QCA_DEFAULT_PORT= devel/qca
_QCA_CHOSEN_PORT= DEFAULT
+_QCA_FLAVOR= qt${_QT_VER}
-LIB_DEPENDS+= ${_QCA_LIB}:${_QCA_${_QCA_CHOSEN_PORT}_PORT}
+LIB_DEPENDS+= ${_QCA_LIB}:${_QCA_${_QCA_CHOSEN_PORT}_PORT}@${_QCA_FLAVOR}
.endif
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index 3d0be4d8077c..e948b94c8f24 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -1,7 +1,7 @@
PORTNAME= amarok
DISTVERSIONPREFIX= v
DISTVERSION= 2.9.71
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio kde
MAINTAINER= kde@FreeBSD.org
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index 73d64dc3fc78..fbe070cfc243 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kbibtex
DISTVERSION= 0.9.2
-PORTREVISION= 33
+PORTREVISION= 34
CATEGORIES= databases kde
MASTER_SITES= KDE/stable/KBibTeX/${DISTVERSION}
diff --git a/deskutils/kdeconnect-kde/Makefile b/deskutils/kdeconnect-kde/Makefile
index a99849d85f5f..daa6ef2dfd8e 100644
--- a/deskutils/kdeconnect-kde/Makefile
+++ b/deskutils/kdeconnect-kde/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kdeconnect-kde
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/deskutils/kdepim-runtime/Makefile b/deskutils/kdepim-runtime/Makefile
index 5ea10158a813..b6d010f43f32 100644
--- a/deskutils/kdepim-runtime/Makefile
+++ b/deskutils/kdepim-runtime/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kdepim-runtime
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/devel/okteta/Makefile b/devel/okteta/Makefile
index 8b88c3dc2727..cccda8794d7d 100644
--- a/devel/okteta/Makefile
+++ b/devel/okteta/Makefile
@@ -1,5 +1,6 @@
PORTNAME= okteta
DISTVERSION= 0.26.9
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel kde
MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}/src
diff --git a/devel/qca/Makefile b/devel/qca/Makefile
index 1e46890de5b0..aa2060eedd85 100644
--- a/devel/qca/Makefile
+++ b/devel/qca/Makefile
@@ -1,8 +1,9 @@
PORTNAME= qca
DISTVERSION= 2.3.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= KDE/stable/qca/${PORTVERSION}
-PKGNAMESUFFIX= -qt5
+PKGNAMESUFFIX= -${FLAVOR}
MAINTAINER= kde@FreeBSD.org
COMMENT= Cross-platform crypto API for Qt ${FLAVOR:C/qt//}
@@ -10,10 +11,13 @@ COMMENT= Cross-platform crypto API for Qt ${FLAVOR:C/qt//}
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+FLAVORS= qt5 qt6
+FLAVOR?= qt5
+
BUILD_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-USES= cmake compiler:c++11-lang qt:5 tar:xz
+USES= cmake compiler:c++11-lang qt:${FLAVOR:S/qt//} tar:xz
CMAKE_ARGS= -DBUILD_PLUGINS=none -DBUILD_TESTS=no \
-DPKGCONFIG_INSTALL_PREFIX=${PREFIX}/libdata/pkgconfig \
-DQCA_FEATURE_INSTALL_DIR=${QT_MKSPECDIR}/features \
@@ -21,10 +25,17 @@ CMAKE_ARGS= -DBUILD_PLUGINS=none -DBUILD_TESTS=no \
CONFIGURE_ENV= QC_CERTSTORE_PATH=${LOCALBASE}/share/certs/ca-root-nss.crt
USE_LDCONFIG= yes
-CMAKE_ARGS+= -DQCA_SUFFIX=qt5
-USE_QT= core buildtools_build qmake_build
-
-PLIST_SUB= SHLIB_VER=${PORTVERSION}
+CMAKE_ARGS+= -DQCA_SUFFIX=${FLAVOR} \
+ -D${FLAVOR:tu}:BOOL=TRUE
+_USE_QT5= core buildtools_build qmake_build
+_USE_QT6= 5compat base
+USE_QT= ${_USE_QT${FLAVOR:S/qt//}}
+
+_PLIST_SUB_QT5= QT5_ONLY=""
+_PLIST_SUB_QT6= QT5_ONLY="@comment "
+PLIST_SUB= SHLIB_VER=${PORTVERSION} \
+ QCA_QT_VERSION=${FLAVOR} \
+ ${_PLIST_SUB_QT${FLAVOR:S/qt//}}
OPTIONS_DEFINE= BOTAN GNUPG OPENSSL SASL TEST
OPTIONS_DEFAULT=GNUPG OPENSSL
diff --git a/devel/qca/pkg-plist b/devel/qca/pkg-plist
index d9a46b9672ff..19f6429ca074 100644
--- a/devel/qca/pkg-plist
+++ b/devel/qca/pkg-plist
@@ -1,33 +1,33 @@
-bin/mozcerts-qt5
-bin/qcatool-qt5
-include/Qca-qt5/QtCrypto/QtCrypto
-include/Qca-qt5/QtCrypto/qca.h
-include/Qca-qt5/QtCrypto/qca_basic.h
-include/Qca-qt5/QtCrypto/qca_cert.h
-include/Qca-qt5/QtCrypto/qca_core.h
-include/Qca-qt5/QtCrypto/qca_export.h
-include/Qca-qt5/QtCrypto/qca_keystore.h
-include/Qca-qt5/QtCrypto/qca_publickey.h
-include/Qca-qt5/QtCrypto/qca_safetimer.h
-include/Qca-qt5/QtCrypto/qca_securelayer.h
-include/Qca-qt5/QtCrypto/qca_securemessage.h
-include/Qca-qt5/QtCrypto/qca_support.h
-include/Qca-qt5/QtCrypto/qca_textfilter.h
-include/Qca-qt5/QtCrypto/qca_tools.h
-include/Qca-qt5/QtCrypto/qca_version.h
-include/Qca-qt5/QtCrypto/qcaprovider.h
-include/Qca-qt5/QtCrypto/qpipe.h
-lib/cmake/Qca-qt5/Qca-qt5Config.cmake
-lib/cmake/Qca-qt5/Qca-qt5ConfigVersion.cmake
-lib/cmake/Qca-qt5/Qca-qt5Targets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/Qca-qt5/Qca-qt5Targets.cmake
-lib/libqca-qt5.so
-lib/libqca-qt5.so.2
-lib/libqca-qt5.so.%%SHLIB_VER%%
-%%BOTAN%%lib/qca-qt5/crypto/libqca-botan.so
-%%SASL%%lib/qca-qt5/crypto/libqca-cyrus-sasl.so
-%%GNUPG%%lib/qca-qt5/crypto/libqca-gnupg.so
-%%OPENSSL%%lib/qca-qt5/crypto/libqca-ossl.so
-%%QT_MKSPECDIR%%/features/crypto.prf
-libdata/pkgconfig/qca2-qt5.pc
-man/man1/qcatool-qt5.1.gz
+bin/mozcerts-%%QCA_QT_VERSION%%
+bin/qcatool-%%QCA_QT_VERSION%%
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/QtCrypto
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_basic.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_cert.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_core.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_export.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_keystore.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_publickey.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_safetimer.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_securelayer.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_securemessage.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_support.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_textfilter.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_tools.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qca_version.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qcaprovider.h
+include/Qca-%%QCA_QT_VERSION%%/QtCrypto/qpipe.h
+lib/cmake/Qca-%%QCA_QT_VERSION%%/Qca-%%QCA_QT_VERSION%%Config.cmake
+lib/cmake/Qca-%%QCA_QT_VERSION%%/Qca-%%QCA_QT_VERSION%%ConfigVersion.cmake
+lib/cmake/Qca-%%QCA_QT_VERSION%%/Qca-%%QCA_QT_VERSION%%Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qca-%%QCA_QT_VERSION%%/Qca-%%QCA_QT_VERSION%%Targets.cmake
+lib/libqca-%%QCA_QT_VERSION%%.so
+lib/libqca-%%QCA_QT_VERSION%%.so.2
+lib/libqca-%%QCA_QT_VERSION%%.so.%%SHLIB_VER%%
+%%BOTAN%%lib/qca-%%QCA_QT_VERSION%%/crypto/libqca-botan.so
+%%SASL%%lib/qca-%%QCA_QT_VERSION%%/crypto/libqca-cyrus-sasl.so
+%%GNUPG%%lib/qca-%%QCA_QT_VERSION%%/crypto/libqca-gnupg.so
+%%OPENSSL%%lib/qca-%%QCA_QT_VERSION%%/crypto/libqca-ossl.so
+%%QT5_ONLY%%%%QT_MKSPECDIR%%/features/crypto.prf
+%%QT5_ONLY%%libdata/pkgconfig/qca2-%%QCA_QT_VERSION%%.pc
+man/man1/qcatool-%%QCA_QT_VERSION%%.1.gz
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 6ae0285b5087..0caa6a6ddeed 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -1,6 +1,6 @@
PORTNAME= calligra
DISTVERSION= 3.2.1
-PORTREVISION= 41
+PORTREVISION= 42
CATEGORIES= editors kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
DIST_SUBDIR= KDE/${PORTNAME}
diff --git a/finance/skrooge/Makefile b/finance/skrooge/Makefile
index 4b4a63782ef5..edcfc642477b 100644
--- a/finance/skrooge/Makefile
+++ b/finance/skrooge/Makefile
@@ -1,5 +1,6 @@
PORTNAME= skrooge
DISTVERSION= 2.28.0
+PORTREVISION= 1
CATEGORIES= finance kde
MASTER_SITES= KDE/stable/${PORTNAME}
DIST_SUBDIR= KDE/${PORTNAME}
diff --git a/games/ksirk/Makefile b/games/ksirk/Makefile
index 1c4b5db27816..e99444e81ad2 100644
--- a/games/ksirk/Makefile
+++ b/games/ksirk/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ksirk
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/graphics/okular/Makefile b/graphics/okular/Makefile
index 88ed2ab6990e..a16387a5d749 100644
--- a/graphics/okular/Makefile
+++ b/graphics/okular/Makefile
@@ -1,5 +1,6 @@
PORTNAME= okular
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/graphics/qgis-ltr/Makefile b/graphics/qgis-ltr/Makefile
index c97a273c4823..3f8650a94160 100644
--- a/graphics/qgis-ltr/Makefile
+++ b/graphics/qgis-ltr/Makefile
@@ -1,5 +1,6 @@
PORTNAME= qgis
DISTVERSION= 3.22.10
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= https://qgis.org/downloads/
PKGNAMESUFFIX= -ltr
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index c42713c36908..de2cb256d8d3 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -1,5 +1,6 @@
PORTNAME= qgis
DISTVERSION= 3.26.2
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= https://qgis.org/downloads/
diff --git a/irc/konversation/Makefile b/irc/konversation/Makefile
index 37372ef27bab..a1d662b56bb6 100644
--- a/irc/konversation/Makefile
+++ b/irc/konversation/Makefile
@@ -1,5 +1,6 @@
PORTNAME= konversation
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= irc kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index dac624ac4104..62a07fb2d254 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= quassel
DISTVERSION= 0.14.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= irc
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${DISTVERSION}/
diff --git a/net-im/kopete/Makefile b/net-im/kopete/Makefile
index 841eed8faab9..5f1b4f97d7e1 100644
--- a/net-im/kopete/Makefile
+++ b/net-im/kopete/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kopete
PORTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/ktp-auth-handler/Makefile b/net-im/ktp-auth-handler/Makefile
index d0c040e6b240..845916a62f1a 100644
--- a/net-im/ktp-auth-handler/Makefile
+++ b/net-im/ktp-auth-handler/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ktp-auth-handler
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net-im/psi/Makefile b/net-im/psi/Makefile
index fa40b3cc5368..1fa5a4b89676 100644
--- a/net-im/psi/Makefile
+++ b/net-im/psi/Makefile
@@ -1,5 +1,6 @@
PORTNAME= psi
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= SF/${PORTNAME}/Psi/${PORTVERSION}
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index 9e146bc077cb..c7f3e5559599 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libktorrent
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-p2p kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net/kget/Makefile b/net/kget/Makefile
index 6a59cbcf7044..75e43184d285 100644
--- a/net/kget/Makefile
+++ b/net/kget/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kget
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net/messagelib/Makefile b/net/messagelib/Makefile
index 83c447c2a161..7267819de6d4 100644
--- a/net/messagelib/Makefile
+++ b/net/messagelib/Makefile
@@ -1,5 +1,6 @@
PORTNAME= messagelib
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/net/qoauth-qt5/Makefile b/net/qoauth-qt5/Makefile
index feeecd75511c..547262fa494b 100644
--- a/net/qoauth-qt5/Makefile
+++ b/net/qoauth-qt5/Makefile
@@ -1,7 +1,7 @@
PORTNAME= qoauth
PORTVERSION= 2.0.0
DISTVERSIONPREFIX= v
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net devel security
PKGNAMESUFFIX= -qt5
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 3e1f8b43ae14..77f67a0944b2 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kadu
PORTVERSION= 4.3
-PORTREVISION= 23
+PORTREVISION= 24
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/:kadu \
diff --git a/sysutils/kf5-kwallet/Makefile b/sysutils/kf5-kwallet/Makefile
index a082fdca6241..5e16dffe3136 100644
--- a/sysutils/kf5-kwallet/Makefile
+++ b/sysutils/kf5-kwallet/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kwallet
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-frameworks
PATCH_SITES= https://invent.kde.org/frameworks/kwallet/-/commit/
diff --git a/www/choqok/Makefile b/www/choqok/Makefile
index 232c2406cd7d..bbc41a0da2ce 100644
--- a/www/choqok/Makefile
+++ b/www/choqok/Makefile
@@ -1,6 +1,6 @@
PORTNAME= choqok
DISTVERSION= 1.7.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION:R}/src
DIST_SUBDIR= KDE/${PORTNAME}
diff --git a/x11/plasma5-kactivitymanagerd/Makefile b/x11/plasma5-kactivitymanagerd/Makefile
index 7d3fbc981502..f5d84e39d2cc 100644
--- a/x11/plasma5-kactivitymanagerd/Makefile
+++ b/x11/plasma5-kactivitymanagerd/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kactivitymanagerd
DISTVERSION= ${KDE_PLASMA_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org