aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 18:07:49 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 18:07:49 +0000
commit639fe47eba0e0118060dda73c5b0ac1009d660b0 (patch)
tree7a189449f05194a37b06d48fc648c68636e6db1b
parent25216e671eaf4d9ee2b6a6db46eba7a1baf332f0 (diff)
downloadports-639fe47eba0e0118060dda73c5b0ac1009d660b0.tar.gz
ports-639fe47eba0e0118060dda73c5b0ac1009d660b0.zip
- New port: math/fpc-gmp
Free Pascal interface to gmp library PR: 146001 Submitted by: Christopher Key <cjk32 at cam.ac.uk>
Notes
Notes: svn path=/head/; revision=259369
-rw-r--r--math/Makefile1
-rw-r--r--math/fpc-gmp/Makefile23
-rw-r--r--math/fpc-gmp/pkg-plist9
3 files changed, 33 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 09760b34a1cd..dc22ba1cde3c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -79,6 +79,7 @@
SUBDIR += fftw3-long
SUBDIR += fityk
SUBDIR += fpc-fftw
+ SUBDIR += fpc-gmp
SUBDIR += fpc-numlib
SUBDIR += freefem
SUBDIR += freemat
diff --git a/math/fpc-gmp/Makefile b/math/fpc-gmp/Makefile
new file mode 100644
index 000000000000..93000b52547b
--- /dev/null
+++ b/math/fpc-gmp/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-gmp
+# Date created: 2010-04-22
+# Whom: Christopher Key <cjk32@cam.ac.uk>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= math lang
+PKGNAMESUFFIX= -gmp
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal interface to gmp library
+
+USE_FPC= yes
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= GMP "Install gmp library" on
+
+.include "${MASTERDIR}/Makefile"
diff --git a/math/fpc-gmp/pkg-plist b/math/fpc-gmp/pkg-plist
new file mode 100644
index 000000000000..9290f1f525be
--- /dev/null
+++ b/math/fpc-gmp/pkg-plist
@@ -0,0 +1,9 @@
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/gmp/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/gmp/gmp.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/gmp/gmp.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/gmp/libpgmp.a
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/gmp
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc