aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-11 03:08:21 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-11 03:11:28 +0000
commit63ad96b2566ef807c357d5e158caa7da974554f1 (patch)
treef4c3fa29451899e749e3ed20c4fe348738632f59
parent05c3b0ef8b96862e31e69bbafd53d5ef5950a08b (diff)
downloadports-63ad96b2566ef807c357d5e158caa7da974554f1.tar.gz
ports-63ad96b2566ef807c357d5e158caa7da974554f1.zip
devel/py-pyflakes: Use the simpler script which does not raise StopIteration
- Bump PORTREVISION for package change PR: 267219 Reported by: yuri
-rw-r--r--devel/py-pyflakes/files/patch-setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/devel/py-pyflakes/files/patch-setup.py b/devel/py-pyflakes/files/patch-setup.py
new file mode 100644
index 000000000000..7af0b37e513d
--- /dev/null
+++ b/devel/py-pyflakes/files/patch-setup.py
@@ -0,0 +1,14 @@
+--- setup.py.orig 2023-01-31 18:28:24 UTC
++++ setup.py
+@@ -10,10 +10,8 @@ except ImportError:
+ extra = {'scripts': ["bin/pyflakes"]}
+ else:
+ extra = {
++ 'scripts': ["bin/pyflakes"],
+ 'test_suite': 'pyflakes.test',
+- 'entry_points': {
+- 'console_scripts': ['pyflakes = pyflakes.api:main'],
+- },
+ }
+
+