aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-06 13:34:24 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-06 14:09:31 +0000
commit63c8147ee1aafa7d42d24407f3905aed7408f182 (patch)
tree7d36d10db1e9d63d8e2654392a3e6f88fe5d1bf4
parent759649a5b05de312726573133b1a37959b1b615e (diff)
downloadports-63c8147ee1aafa7d42d24407f3905aed7408f182.tar.gz
ports-63c8147ee1aafa7d42d24407f3905aed7408f182.zip
games/openmortal: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. PR: 251512
-rw-r--r--games/openmortal/Makefile4
-rw-r--r--games/openmortal/files/patch-configure21
2 files changed, 24 insertions, 1 deletions
diff --git a/games/openmortal/Makefile b/games/openmortal/Makefile
index 8081762f52b6..a5db4d35feb6 100644
--- a/games/openmortal/Makefile
+++ b/games/openmortal/Makefile
@@ -11,7 +11,7 @@ COMMENT= Parody of the once popular coin-up fighting game, Mortal Kombat
LIB_DEPENDS= libfreetype.so:print/freetype2
-USES= dos2unix perl5 sdl tar:bzip2
+USES= dos2unix perl5 pkgconfig sdl tar:bzip2
GNU_CONFIGURE= yes
USE_SDL= mixer image sdl net
DOS2UNIX_FILES= src/gfx.cpp
@@ -19,4 +19,6 @@ DOS2UNIX_FILES= src/gfx.cpp
PLIST_FILES= bin/${PORTNAME}
PORTDATA= *
+BINARY_ALIAS= freetype-config=true
+
.include <bsd.port.mk>
diff --git a/games/openmortal/files/patch-configure b/games/openmortal/files/patch-configure
new file mode 100644
index 000000000000..a7680ba7d5b0
--- /dev/null
+++ b/games/openmortal/files/patch-configure
@@ -0,0 +1,21 @@
+--- configure.orig 2021-08-06 13:30:20 UTC
++++ configure
+@@ -1685,13 +1685,13 @@ no_ft=""
+ if test "$FT2_CONFIG" = "no" ; then
+ no_ft=yes
+ else
+- FT2_CFLAGS=`$FT2_CONFIG $ft_config_args --cflags`
+- FT2_LIBS=`$FT2_CONFIG $ft_config_args --libs`
+- ft_config_major_version=`$FT2_CONFIG $ft_config_args --version | \
++ FT2_CFLAGS=`pkg-config freetype2 --cflags`
++ FT2_LIBS=`pkg-config freetype2 --libs`
++ ft_config_major_version=`pkg-config freetype2 --modversion | \
+ sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
+- ft_config_minor_version=`$FT2_CONFIG $ft_config_args --version | \
++ ft_config_minor_version=`pkg-config freetype2 --modversion | \
+ sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
+- ft_config_micro_version=`$FT2_CONFIG $ft_config_args --version | \
++ ft_config_micro_version=`pkg-config freetype2 --modversion | \
+ sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
+ ft_min_major_version=`echo $min_ft_version | \
+ sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`