aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg V <greg@unrelenting.technology>2023-10-18 17:23:40 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-18 21:15:32 +0000
commit63e4896661f60bc4f3ece75a3240cee10e617545 (patch)
tree22e90eca4ab12aae403b46ab3e80ef89da90146b
parent8b9c341018c4ebd212a8eaf2e6a7cf25ff344f50 (diff)
downloadports-63e4896661f60bc4f3ece75a3240cee10e617545.tar.gz
ports-63e4896661f60bc4f3ece75a3240cee10e617545.zip
math/gmp: Optionize INFO
- Remove unnecessary CONFIGURE_ARGS are which are also default for HAS_CONFIGURE - Pet portclippy - No BUMP as there is no change in pkg PR: 259573 Approved by: ale (maintainer-timeout)
-rw-r--r--math/gmp/Makefile28
1 files changed, 15 insertions, 13 deletions
diff --git a/math/gmp/Makefile b/math/gmp/Makefile
index 0130a0973503..2f759a714b0e 100644
--- a/math/gmp/Makefile
+++ b/math/gmp/Makefile
@@ -9,27 +9,26 @@ WWW= https://gmplib.org/
LICENSE= LGPL3
-USES= cpe libtool makeinfo tar:xz pathfix
-
+USES= cpe libtool tar:xz pathfix
CPE_VENDOR= gmplib
-
-OPTIONS_DEFINE= CPU_OPTS
-CPU_OPTS_DESC= Enable assembly optimizations for your CPU
+USE_LDCONFIG= yes
HAS_CONFIGURE= yes
-CONFIGURE_ENV= MAKEINFO="${MAKEINFO} --no-split"
CONFIGURE_ARGS= --prefix=${PREFIX} \
- --infodir=${PREFIX}/${INFO_PATH} \
- --mandir=${PREFIX}/man \
--enable-cxx
-USE_LDCONFIG= yes
-
-INFO= gmp
-
INSTALL_TARGET= install-strip
TEST_TARGET= check
+OPTIONS_DEFINE= CPU_OPTS INFO
+OPTIONS_DEFAULT= INFO
+
+CPU_OPTS_DESC= Enable assembly optimizations for your CPU
+
+INFO_USES= makeinfo
+INFO_CONFIGURE_ENV= MAKEINFO="${MAKEINFO} --no-split"
+INFO_INFO= gmp
+
.include <bsd.port.pre.mk>
.if ${ARCH:Mmips*}
@@ -50,7 +49,10 @@ CONFIGURE_ENV+= ABI="64"
CONFIGURE_ENV+= ABI="32"
.endif
-post-extract:
+post-extract-INFO-on:
@${RM} ${WRKSRC}/doc/gmp.info*
+post-patch-INFO-off:
+ ${REINPLACE_CMD} -e '/^SUBDIRS/ s|doc||' ${WRKSRC}/Makefile.in
+
.include <bsd.port.post.mk>