aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-05-04 14:06:08 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-05-04 14:06:08 +0000
commit63f76304d6f21c191cb8e08ab49787bcf031fb6d (patch)
tree20dbde6d95ce50dde89bcaeaaee0c6c3ee84e6b1
parent72e61e01d5850e4a1b7f817ff8c3f51d32dc101c (diff)
downloadports-63f76304d6f21c191cb8e08ab49787bcf031fb6d.tar.gz
ports-63f76304d6f21c191cb8e08ab49787bcf031fb6d.zip
- When DISABLE_MAKE_JOBS or MAKE_JOBS_UNSAFE is set, also set
MAKE_JOBS_NUMBER to 1. This makes it safe to do -j${MAKE_JOBS_NUMBER} without any extra logic. - Cleanup ports working around the empty MAKE_JOBS_NUMBER - This also fixes several ports that were expecting MAKE_JOBS_NUMBER to always have a number Reviewed by: bapt Spotted by: John Marino <draco@marino.st> With hat: portmgr
Notes
Notes: svn path=/head/; revision=317320
-rw-r--r--Mk/bsd.port.mk1
-rw-r--r--audio/gmidimonitor/Makefile2
-rw-r--r--audio/lv2core/Makefile2
-rw-r--r--audio/patchage/Makefile2
-rw-r--r--audio/raul/Makefile2
-rw-r--r--audio/slv2/Makefile2
-rw-r--r--databases/dbf/Makefile2
-rw-r--r--editors/libreoffice/Makefile6
-rw-r--r--games/tuxmath/Makefile2
-rw-r--r--games/tuxtype/Makefile2
-rw-r--r--graphics/mapnik/Makefile2
-rw-r--r--java/openjdk6/Makefile4
-rw-r--r--java/openjdk7/Makefile9
-rw-r--r--math/polymake/Makefile7
-rw-r--r--math/sage/Makefile2
-rw-r--r--multimedia/aegisub/Makefile2
-rw-r--r--www/midori/Makefile5
-rw-r--r--www/node04/Makefile2
-rw-r--r--www/node06/Makefile2
-rw-r--r--x11-toolkits/flowcanvas/Makefile2
-rw-r--r--x11-wm/ede/Makefile2
-rw-r--r--x11/roxterm/Makefile2
22 files changed, 4 insertions, 60 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 32d47f67444c..14b985ed9f63 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2189,6 +2189,7 @@ CFLAGS:= ${CFLAGS:N-std=*} -std=${USE_CSTD}
# Multiple make jobs support
.if defined(DISABLE_MAKE_JOBS) || defined(MAKE_JOBS_UNSAFE)
+MAKE_JOBS_NUMBER= 1
_MAKE_JOBS= #
.else
.if defined(MAKE_JOBS_SAFE) || defined(FORCE_MAKE_JOBS)
diff --git a/audio/gmidimonitor/Makefile b/audio/gmidimonitor/Makefile
index 151d4950e305..28ffd557cfb9 100644
--- a/audio/gmidimonitor/Makefile
+++ b/audio/gmidimonitor/Makefile
@@ -27,9 +27,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
PLIST_FILES= bin/gmidimonitor %%DATADIR%%/gmidimonitor.ui
PLIST_DIRS= %%DATADIR%%
-.if defined(MAKE_JOBS_NUMBER)
MAKE_JOBS_ARGS= -j${MAKE_JOBS_NUMBER}
-.endif
do-configure:
@(cd ${WRKSRC} && ./waf configure --prefix=${PREFIX} --alsa=no)
diff --git a/audio/lv2core/Makefile b/audio/lv2core/Makefile
index dbe15e45441f..eddaa6f22f2f 100644
--- a/audio/lv2core/Makefile
+++ b/audio/lv2core/Makefile
@@ -23,9 +23,7 @@ MAKE_JOBS_SAFE= yes
WAF_VERBOSE= --verbose
.endif
-.if defined(MAKE_JOBS_NUMBER)
WAF_JOBS= --jobs=${MAKE_JOBS_NUMBER}
-.endif
post-patch:
@${REINPLACE_CMD} -e '/autowaf.build_pc/s|^|#|' ${WRKSRC}/wscript
diff --git a/audio/patchage/Makefile b/audio/patchage/Makefile
index 6b6ad7c9a95f..9cdcfed8747f 100644
--- a/audio/patchage/Makefile
+++ b/audio/patchage/Makefile
@@ -37,9 +37,7 @@ CFLAGS+= -I${LOCALBASE}/include
WAF_VERBOSE= --verbose
.endif
-.if defined(MAKE_JOBS_NUMBER)
WAF_JOBS= --jobs=${MAKE_JOBS_NUMBER}
-.endif
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/audio/raul/Makefile b/audio/raul/Makefile
index e918297934c1..bd708d910107 100644
--- a/audio/raul/Makefile
+++ b/audio/raul/Makefile
@@ -29,9 +29,7 @@ CFLAGS+= -I${LOCALBASE}/include
WAF_VERBOSE= --verbose
.endif
-.if defined(MAKE_JOBS_NUMBER)
WAF_JOBS= --jobs=${MAKE_JOBS_NUMBER}
-.endif
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/audio/slv2/Makefile b/audio/slv2/Makefile
index 55c1bb554b54..6427c56fe9d1 100644
--- a/audio/slv2/Makefile
+++ b/audio/slv2/Makefile
@@ -28,9 +28,7 @@ MAKE_JOBS_SAFE= yes
WAF_VERBOSE= --verbose
.endif
-.if defined(MAKE_JOBS_NUMBER)
WAF_JOBS= --jobs=${MAKE_JOBS_NUMBER}
-.endif
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/databases/dbf/Makefile b/databases/dbf/Makefile
index d4a1b8c64cc4..b2115759b5b6 100644
--- a/databases/dbf/Makefile
+++ b/databases/dbf/Makefile
@@ -36,9 +36,7 @@ CONFIGURE_ENV+= ac_cv_header_libintl_h=no
PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(DISABLE_MAKE_JOBS)
_make_jobs= -j${MAKE_JOBS_NUMBER}
-.endif
post-extract:
@${FIND} ${WRKDIR} -name "configure" -or -name "install-sh" | \
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 34fcc540edde..e9d18baeb812 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -84,12 +84,6 @@ DIST_SUBDIR= libreoffice
LODESTDIR= ${WRKDIR}/loinstall
WRKSRC= ${WRKDIR}/${PORTNAME}-${LOVERSION}
-.if defined(DISABLE_MAKE_JOBS)
-MAKE_JOBS_NUMBER= 1
-.else
-MAKE_JOBS_NUMBER?= `${SYSCTL} -n kern.smp.cpus`
-.endif
-
CONFIGURE_ENV= DMAKE=${LOCALBASE}/bin/dmake \
GPERF=${LOCALBASE}/bin/gperf \
PYTHON_CFLAGS="`${PYTHON_VERSION}-config --cflags`" \
diff --git a/games/tuxmath/Makefile b/games/tuxmath/Makefile
index c19d326450f4..b83a16deb48f 100644
--- a/games/tuxmath/Makefile
+++ b/games/tuxmath/Makefile
@@ -62,9 +62,7 @@ CONFIGURE_ARGS+=--without-rsvg
.endif
# use multiple make jobs for T4K_WRKSRC
-.if !defined(DISABLE_MAKE_JOBS)
_make_jobs= -j${MAKE_JOBS_NUMBER}
-.endif
post-extract:
@${LN} -sf ${T4K_WRKSRC} ${WRKDIR}/${T4K_NAME}
diff --git a/games/tuxtype/Makefile b/games/tuxtype/Makefile
index 2bc1ee74cdcc..c4178274bb7a 100644
--- a/games/tuxtype/Makefile
+++ b/games/tuxtype/Makefile
@@ -63,9 +63,7 @@ CONFIGURE_ARGS+=--without-rsvg
.endif
# use multiple make jobs for T4K_WRKSRC
-.if !defined(DISABLE_MAKE_JOBS)
_make_jobs= -j${MAKE_JOBS_NUMBER}
-.endif
post-extract:
@${LN} -sf ${T4K_WRKSRC} ${WRKDIR}/${T4K_NAME}
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
index 925441431550..24ca0e3a94dd 100644
--- a/graphics/mapnik/Makefile
+++ b/graphics/mapnik/Makefile
@@ -127,9 +127,7 @@ IGNORE= does not install: runs out of virtual memory
SCONS_ARGS+= WARNING_CXXFLAGS=${WARNING_CXXFLAGS}
SCONS_ARGS+= INPUT_PLUGINS="`${ECHO} ${INPUT_PLUGINS} | ${TR} ' ' ,`"
-.if defined (MAKE_JOBS_NUMBER)
SCONS_ARGS+= JOBS=${MAKE_JOBS_NUMBER}
-.endif
pre-configure:
.if ${PORT_OPTIONS:MSQLITE3}
diff --git a/java/openjdk6/Makefile b/java/openjdk6/Makefile
index 8f7201e00d30..44e0f518fd1b 100644
--- a/java/openjdk6/Makefile
+++ b/java/openjdk6/Makefile
@@ -212,11 +212,7 @@ MAKE_ENV+= CCC="${CXX}" GCC="${CC}"
MAKE_ENV+= WARNINGS_ARE_ERRORS="${WARNINGS_ARE_ERRORS}"
# XXX Turn off parallel build by default.
-.if defined(DISABLE_MAKE_JOBS) || !defined(FORCE_MAKE_JOBS)
-BUILD_JOBS_NUMBER= 1
-.elif defined(FORCE_MAKE_JOBS)
BUILD_JOBS_NUMBER= ${MAKE_JOBS_NUMBER}
-.endif
_MAKE_JOBS= #
MAKE_ENV+= ALT_PARALLEL_COMPILE_JOBS=${BUILD_JOBS_NUMBER} \
HOTSPOT_BUILD_JOBS=${BUILD_JOBS_NUMBER}
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index 1cfabbaed0c6..8f6feb51b8a8 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -99,14 +99,7 @@ MAKE_ENV+= LANG="C" \
JDK_MICRO_VERSION="0_${PORT_MINOR_VERSION}" \
BUILD_NUMBER="b${PORT_BUILD_NUMBER}"
-.if !defined(DISABLE_MAKE_JOBS)
-.if defined(MAKE_JOBS_NUMBER)
-BUILD_JOBS_NUMBER= ${MAKE_JOBS_NUMBER}
-.else
-BUILD_JOBS_NUMBER= `${SYSCTL} -n kern.smp.cpus`
-.endif
-MAKE_ENV+= HOTSPOT_BUILD_JOBS=${BUILD_JOBS_NUMBER}
-.endif
+MAKE_ENV+= HOTSPOT_BUILD_JOBS=${MAKE_JOBS_NUMBER}
BOOTSTRAP_JDKS= ${LOCALBASE}/openjdk7 \
${LOCALBASE}/openjdk6 \
diff --git a/math/polymake/Makefile b/math/polymake/Makefile
index ccfec34013e9..cfdce3314cb8 100644
--- a/math/polymake/Makefile
+++ b/math/polymake/Makefile
@@ -53,18 +53,15 @@ USE_LDCONFIG= yes
IGNORE= does not build with Perl 5.14+
.endif
-.if !defined(DISABLE_MAKE_JOBS)
pre-fetch:
- @MAKE_JOBS_NUMBER=${MAKE_JOBS_NUMBER}; \
- if [ $${MAKE_JOBS_NUMBER} -gt 1 ]; then \
+ @if [ ${MAKE_JOBS_NUMBER} -gt 1 ]; then \
${ECHO_CMD} "Building this port uses a lot of CPU power, and a lot of memory to the point"; \
${ECHO_CMD} "that swap space might be used extensively. Consider using less threads, as"; \
${ECHO_CMD} "this might cause the build to be considerably faster. Currently the build is"; \
- ${ECHO_CMD} "set to use $${MAKE_JOBS_NUMBER} threads. To change to <n> threads, use"; \
+ ${ECHO_CMD} "set to use ${MAKE_JOBS_NUMBER} threads. To change to <n> threads, use"; \
${ECHO_CMD}; \
${ECHO_CMD} "make MAKE_JOBS_NUMBER=<n>"; \
fi
-.endif
post-install:
${INSTALL_DATA} ${PREFIX}/libexec/polymake/conf.make ${PREFIX}/libexec/polymake/conf.make.in
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 0c5dd229422e..2d2b62adf8d0 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -168,8 +168,6 @@ FPM_FLAG= -mfpmath=387
FPM_FLAG=
.endif
-.if !defined(DISABLE_MAKE_JOBS)
MAKE_ENV+= MAKE="${MAKE} -j${MAKE_JOBS_NUMBER}"
-.endif
.include <bsd.port.post.mk>
diff --git a/multimedia/aegisub/Makefile b/multimedia/aegisub/Makefile
index 6ed8e76176e3..b962698668f6 100644
--- a/multimedia/aegisub/Makefile
+++ b/multimedia/aegisub/Makefile
@@ -136,9 +136,7 @@ CONFIGURE_ARGS+= --without-lua
.endif
# use multiple make jobs for FFMS_WRKSRC
-.if !defined(DISABLE_MAKE_JOBS)
_make_jobs= -j${MAKE_JOBS_NUMBER}
-.endif
post-extract:
.for i in ${FFMS_DISTFILE}
diff --git a/www/midori/Makefile b/www/midori/Makefile
index adc40bc7bf79..57255100bfba 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -28,12 +28,7 @@ CONFIGURE_ARGS+=--enable-libnotify \
--enable-docs \
--disable-gtk3
-# if user has set DISABLE_MAKE_JOBS, then MAKE_JOBS_NUMBER is undefined
-.if defined(DISABLE_MAKE_JOBS)
-CONFIGURE_ARGS+=--jobs=1
-.else
CONFIGURE_ARGS+=--jobs=${MAKE_JOBS_NUMBER}
-.endif
MAKE_JOBS_SAFE= yes
HAS_CONFIGURE= yes
diff --git a/www/node04/Makefile b/www/node04/Makefile
index 81662cd93fb4..735d8634123f 100644
--- a/www/node04/Makefile
+++ b/www/node04/Makefile
@@ -43,9 +43,7 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-src__node_buffer.cc
PLIST_SUB+= SHAREDV8=""
.endif
-.if !defined(DISABLE_MAKE_JOBS)
WAF_ARGS= --jobs=${MAKE_JOBS_NUMBER}
-.endif
do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} tools/waf-light ${WAF_ARGS} build)
diff --git a/www/node06/Makefile b/www/node06/Makefile
index 79067298a83f..df6cce1655cf 100644
--- a/www/node06/Makefile
+++ b/www/node06/Makefile
@@ -37,9 +37,7 @@ USE_OPENSSL= yes
MAN1= node.1
-.if !defined(DISABLE_MAKE_JOBS)
WAF_ARGS= --jobs=${MAKE_JOBS_NUMBER}
-.endif
.include <bsd.port.options.mk>
diff --git a/x11-toolkits/flowcanvas/Makefile b/x11-toolkits/flowcanvas/Makefile
index d6973cc8d35c..9c13ae7f3c10 100644
--- a/x11-toolkits/flowcanvas/Makefile
+++ b/x11-toolkits/flowcanvas/Makefile
@@ -31,9 +31,7 @@ CFLAGS+= -I${LOCALBASE}/include
WAF_VERBOSE= --verbose
.endif
-.if defined(MAKE_JOBS_NUMBER)
WAF_JOBS= --jobs=${MAKE_JOBS_NUMBER}
-.endif
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/x11-wm/ede/Makefile b/x11-wm/ede/Makefile
index abb2e91ebf3c..fdffabcdf51c 100644
--- a/x11-wm/ede/Makefile
+++ b/x11-wm/ede/Makefile
@@ -58,9 +58,7 @@ CONFIGURE_ARGS+=--disable-hal
.endif
# use multiple make jobs
-.if !defined(DISABLE_MAKE_JOBS)
_make_jobs= -j${MAKE_JOBS_NUMBER}
-.endif
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/x11/roxterm/Makefile b/x11/roxterm/Makefile
index 2af83129f84f..5bc1463e9dd4 100644
--- a/x11/roxterm/Makefile
+++ b/x11/roxterm/Makefile
@@ -33,9 +33,7 @@ MAITCHFLAGS= CC=${CC};CPP=${CC};CFLAGS=${CFLAGS};PARALLEL=${_make_jobs}
.include <bsd.port.options.mk>
-.if !defined(DISABLE_MAKE_JOBS)
_make_jobs= ${MAKE_JOBS_NUMBER}
-.endif
post-patch:
@${REINPLACE_CMD} -e \