aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2022-12-30 16:00:34 +0000
committerThomas Zander <riggs@FreeBSD.org>2022-12-30 16:15:48 +0000
commit641bf33cd9b6d821a4a114079ea2ce9340fb3cc7 (patch)
tree826703a97357a205727e5d5d28b53d8377ae5a8a
parent6c35869fd916cbfd8ff193449e947f9f2ce681f4 (diff)
downloadports-641bf33cd9b6d821a4a114079ea2ce9340fb3cc7.tar.gz
ports-641bf33cd9b6d821a4a114079ea2ce9340fb3cc7.zip
audio/fluidsynth: Update to upstream version 2.3.1
Details: - Update to new upstream version 2.3.1 - Add non-default PIPEWIRE OPTION
-rw-r--r--audio/fluidsynth/Makefile11
-rw-r--r--audio/fluidsynth/distinfo6
-rw-r--r--audio/fluidsynth/files/patch-CMakeLists.txt28
-rw-r--r--audio/fluidsynth/files/patch-src_CMakeLists.txt33
-rw-r--r--audio/fluidsynth/pkg-plist8
5 files changed, 49 insertions, 37 deletions
diff --git a/audio/fluidsynth/Makefile b/audio/fluidsynth/Makefile
index 46da480b9457..06bd4adbc0a8 100644
--- a/audio/fluidsynth/Makefile
+++ b/audio/fluidsynth/Makefile
@@ -1,6 +1,6 @@
PORTNAME= fluidsynth
DISTVERSIONPREFIX= v
-DISTVERSION= 2.2.8
+DISTVERSION= 2.3.1
CATEGORIES= audio
MAINTAINER= multimedia@FreeBSD.org
@@ -20,10 +20,12 @@ USE_LDCONFIG= yes
CMAKE_OFF= enable-libinstpatch enable-midishare
LDFLAGS+= -lpthread
-OPTIONS_DEFINE= ALSA DBUS JACK LADSPA LASH PORTAUDIO PULSEAUDIO \
- READLINE SDL SNDFILE SNDIO
+OPTIONS_DEFINE= ALSA DBUS JACK LADSPA LASH PIPEWIRE PORTAUDIO \
+ PULSEAUDIO READLINE SDL SNDFILE SNDIO
OPTIONS_DEFAULT= JACK READLINE
+PIPEWIRE_DESC= PipeWire support
+
JACK_LIB_DEPENDS= libjack.so:audio/jack
JACK_CMAKE_BOOL= enable-jack
@@ -41,6 +43,9 @@ LADSPA_CMAKE_BOOL= enable-ladspa
LASH_LIB_DEPENDS= liblash.so:audio/lash
LASH_CMAKE_BOOL= enable-lash
+PIPEWIRE_LIB_DEPENDS= libpipewire-0.3.so:multimedia/pipewire
+PIPEWIRE_CMAKE_BOOL= enable-pipewire
+
PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
PORTAUDIO_CMAKE_BOOL= enable-portaudio
diff --git a/audio/fluidsynth/distinfo b/audio/fluidsynth/distinfo
index 737098f6852c..87d0738a0804 100644
--- a/audio/fluidsynth/distinfo
+++ b/audio/fluidsynth/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1658525753
-SHA256 (FluidSynth-fluidsynth-v2.2.8_GH0.tar.gz) = 7c29a5cb7a2755c8012d941d1335da7bda957bbb0a86b7c59215d26773bb51fe
-SIZE (FluidSynth-fluidsynth-v2.2.8_GH0.tar.gz) = 1751615
+TIMESTAMP = 1672385297
+SHA256 (FluidSynth-fluidsynth-v2.3.1_GH0.tar.gz) = d734e4cf488be763cf123e5976f3154f0094815093eecdf71e0e9ae148431883
+SIZE (FluidSynth-fluidsynth-v2.3.1_GH0.tar.gz) = 1758632
diff --git a/audio/fluidsynth/files/patch-CMakeLists.txt b/audio/fluidsynth/files/patch-CMakeLists.txt
index f9197d1ca637..f9c26aca644e 100644
--- a/audio/fluidsynth/files/patch-CMakeLists.txt
+++ b/audio/fluidsynth/files/patch-CMakeLists.txt
@@ -1,22 +1,22 @@
---- CMakeLists.txt.orig 2019-02-03 07:13:31 UTC
+--- CMakeLists.txt.orig 2022-12-28 11:43:59 UTC
+++ CMakeLists.txt
-@@ -71,6 +71,7 @@ option ( enable-dsound "compile DirectSound support (i
- option ( enable-winmidi "compile Windows MIDI support (if it is available)" on )
- option ( enable-pkgconfig "use pkg-config to locate fluidsynth's (mostly optional) dependencies" on )
+@@ -90,6 +90,7 @@ option ( enable-winmidi "compile Windows MIDI support
+ option ( enable-sdl2 "compile SDL2 audio support (if it is available)" on )
option ( enable-pulseaudio "compile PulseAudio support (if it is available)" on )
+ option ( enable-pipewire "compile PipeWire support (if it is available)" on )
+option ( enable-sndio "compile Sndio support (if it is available)" on )
option ( enable-readline "compile readline lib line editing (if it is available)" on )
option ( enable-threads "enable multi-threading support (such as parallel voice synthesis)" on )
-
-@@ -481,6 +482,11 @@ else(NOT enable-pkgconfig)
- else ( enable-pulseaudio )
+ option ( enable-openmp "enable OpenMP support (parallelization of soundfont decoding, vectorization of voice mixing, etc.)" on )
+@@ -530,6 +531,11 @@ if ( enable-pulseaudio )
+ else ( enable-pulseaudio )
unset_pkg_config ( PULSE )
- endif ( enable-pulseaudio )
+ endif ( enable-pulseaudio )
+
-+ unset ( SNDIO_SUPPORT CACHE )
-+ if ( enable-sndio )
-+ set ( SNDIO_SUPPORT 1 )
-+ endif ( enable-sndio )
++unset ( SNDIO_SUPPORT CACHE )
++if ( enable-sndio )
++ set ( SNDIO_SUPPORT 1 )
++endif ( enable-sndio )
- unset ( ALSA_SUPPORT CACHE )
- if ( enable-alsa )
+ unset ( ALSA_SUPPORT CACHE )
+ if ( enable-alsa )
diff --git a/audio/fluidsynth/files/patch-src_CMakeLists.txt b/audio/fluidsynth/files/patch-src_CMakeLists.txt
index c668618bc7e9..c1de696660a8 100644
--- a/audio/fluidsynth/files/patch-src_CMakeLists.txt
+++ b/audio/fluidsynth/files/patch-src_CMakeLists.txt
@@ -1,7 +1,7 @@
---- src/CMakeLists.txt.orig 2018-12-30 11:42:00 UTC
+--- src/CMakeLists.txt.orig 2022-12-28 11:43:59 UTC
+++ src/CMakeLists.txt
-@@ -50,6 +50,11 @@ if ( PULSE_SUPPORT )
- include_directories ( ${PULSE_INCLUDE_DIRS} )
+@@ -25,6 +25,11 @@ if ( PULSE_SUPPORT )
+ set ( fluid_pulse_SOURCES drivers/fluid_pulse.c )
endif ( PULSE_SUPPORT )
+if ( SNDIO_SUPPORT )
@@ -11,20 +11,23 @@
+
if ( ALSA_SUPPORT )
set ( fluid_alsa_SOURCES drivers/fluid_alsa.c )
- include_directories ( ${ALSA_INCLUDE_DIRS} )
-@@ -247,6 +252,7 @@ add_library ( libfluidsynth-OBJ OBJECT
+ endif ( ALSA_SUPPORT )
+@@ -245,6 +250,7 @@ add_library ( libfluidsynth-OBJ OBJECT
${fluid_oss_SOURCES}
${fluid_portaudio_SOURCES}
${fluid_pulse_SOURCES}
+ ${fluid_sndio_SOURCES}
${fluid_dsound_SOURCES}
- ${fluid_winmidi_SOURCES}
- ${libfluidsynth_SOURCES}
-@@ -314,6 +320,7 @@ target_link_libraries ( libfluidsynth
- ${JACK_LIBRARIES}
- ${ALSA_LIBRARIES}
- ${PULSE_LIBRARIES}
-+ ${SNDIO_LIBRARIES}
- ${PORTAUDIO_LIBRARIES}
- ${LIBSNDFILE_LIBRARIES}
- ${DBUS_LIBRARIES}
+ ${fluid_wasapi_SOURCES}
+ ${fluid_waveout_SOURCES}
+@@ -360,6 +366,10 @@ endif()
+
+ if ( TARGET PkgConfig::PULSE AND PULSE_SUPPORT )
+ target_link_libraries ( libfluidsynth-OBJ PUBLIC PkgConfig::PULSE )
++endif()
++
++if ( SNDIO_SUPPORT)
++ target_link_libraries ( libfluidsynth-OBJ PUBLIC ${SNDIO_LIBRARIES} )
+ endif()
+
+ if ( ALSA_SUPPORT )
diff --git a/audio/fluidsynth/pkg-plist b/audio/fluidsynth/pkg-plist
index 34e0ce7a667b..55c988f54edd 100644
--- a/audio/fluidsynth/pkg-plist
+++ b/audio/fluidsynth/pkg-plist
@@ -17,8 +17,12 @@ include/fluidsynth/synth.h
include/fluidsynth/types.h
include/fluidsynth/version.h
include/fluidsynth/voice.h
+lib/cmake/fluidsynth/FluidSynthConfig.cmake
+lib/cmake/fluidsynth/FluidSynthConfigVersion.cmake
+lib/cmake/fluidsynth/FluidSynthTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/fluidsynth/FluidSynthTargets.cmake
lib/libfluidsynth.so
lib/libfluidsynth.so.3
-lib/libfluidsynth.so.3.1.1
+lib/libfluidsynth.so.3.1.4
libdata/pkgconfig/fluidsynth.pc
-man/man1/fluidsynth.1.gz
+share/man/man1/fluidsynth.1.gz