aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-15 22:02:27 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-15 22:02:27 +0000
commit64a800d83df28391a75317302ea47f1210bb5596 (patch)
tree444752585c3fa352168ded777771e1b9bc9a3e48
parent5f7dfdf36eccc9bb6dae9ed89659565276639b8d (diff)
downloadports-64a800d83df28391a75317302ea47f1210bb5596.tar.gz
ports-64a800d83df28391a75317302ea47f1210bb5596.zip
emulators/qemu: fix build on powerpc
Define _CALL_SYSV to fix error: In file included from /wrkdirs/usr/ports/emulators/qemu/work/qemu-5.0.1/tcg/tcg.c:344: /wrkdirs/usr/ports/emulators/qemu/work/qemu-5.0.1/tcg/ppc/tcg-target.inc.c:2290:3: error: "Unhandled abi" Use gcc because clang hangs.
-rw-r--r--emulators/qemu/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 17edfbdc8b39..4c341e7a33f0 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -123,7 +123,8 @@ PORTDOCS?= docs index.html interop/.buildinfo interop/* qemu-ga-ref.html qemu-ga
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
-CFLAGS_amd64+= -fPIC
+CFLAGS_amd64= -fPIC
+CFLAGS_powerpc= -D_CALL_SYSV
CONFIGURE_ARGS?=--localstatedir=/var \
--extra-ldflags=-L${LOCALBASE}/lib --disable-libssh \
--prefix=${PREFIX} --cc=${CC} --enable-netmap --disable-kvm \
@@ -143,6 +144,7 @@ MAKE_ARGS+= ARCH=x86_64
.if ${ARCH} == "powerpc"
MAKE_ARGS+= ARCH=ppc
+USE_GCC= yes
.endif
.if ${ARCH} == "powerpc64"