aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-29 17:01:42 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-29 17:01:42 +0000
commit64e435f631ec5286e28d883e4ddbe334baa987ec (patch)
tree4725d36a2e47ec282304858fc25379e36b4560e1
parent4666e63bba5414f613616bf642591f6c6538daae (diff)
downloadports-64e435f631ec5286e28d883e4ddbe334baa987ec.tar.gz
ports-64e435f631ec5286e28d883e4ddbe334baa987ec.zip
Be consistent.
Noticed by: amdmi3 Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=404763
-rw-r--r--Mk/bsd.options.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 0a11a7e68078..b6ae3e018ed6 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -499,10 +499,10 @@ ${_u:tu}= ${${opt}_VARS:M${var}=*:C/[^=]*=//:C/^"(.*)"$$/\1/}
. endfor
. endif
. if defined(${opt}_CONFIGURE_ENABLE)
-CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ENABLE:C/^/--enable-/}
+CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ENABLE:S/^/--enable-/}
. endif
. if defined(${opt}_CONFIGURE_WITH)
-CONFIGURE_ARGS+= ${${opt}_CONFIGURE_WITH:C/^/--with-/}
+CONFIGURE_ARGS+= ${${opt}_CONFIGURE_WITH:S/^/--with-/}
. endif
. for configure in CONFIGURE CMAKE QMAKE
. if defined(${opt}_${configure}_ON)
@@ -546,7 +546,7 @@ ${_u:tu}= ${${opt}_VARS_OFF:M${var}=*:C/[^=]*=//:C/^"(.*)"$$/\1/}
CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ENABLE:S/^/--disable-/:C/=.*//}
. endif
. if defined(${opt}_CONFIGURE_WITH)
-CONFIGURE_ARGS+= ${${opt}_CONFIGURE_WITH:C/^/--without-/:C/=.*//}
+CONFIGURE_ARGS+= ${${opt}_CONFIGURE_WITH:S/^/--without-/:C/=.*//}
. endif
. for configure in CONFIGURE CMAKE QMAKE
. if defined(${opt}_${configure}_OFF)