aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-10-26 19:17:19 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-10-26 19:17:19 +0000
commit6502ab1b26740b68bf710eb4aa8f927841e44a0a (patch)
tree18febf7051d5ece5825e25d1012a581aaec0fa58
parent9815645834977fe2ada5052d3c81881b7624bed7 (diff)
downloadports-6502ab1b26740b68bf710eb4aa8f927841e44a0a.tar.gz
ports-6502ab1b26740b68bf710eb4aa8f927841e44a0a.zip
www/firefox: update to 94.0 (rc2)
-rw-r--r--www/firefox/Makefile11
-rw-r--r--www/firefox/distinfo6
-rw-r--r--www/firefox/files/patch-bug1602730_comment524
-rw-r--r--www/firefox/files/patch-rust-1.56.021
4 files changed, 8 insertions, 54 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 4a768f3a0a89..268b6b40f1e0 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,22 +1,21 @@
# Created by: Alan Eldridge <alane@FreeBSD.org>
PORTNAME= firefox
-DISTVERSION= 93.0
-PORTREVISION= 3
+DISTVERSION= 94.0
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
- MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
+ MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build2/source
DISTFILES= ${DISTNAME}.source${EXTRACT_SUFX}
MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nspr>=4.32:devel/nspr \
- nss>=3.70:security/nss \
- icu>=67.1,1:devel/icu \
+ nss>=3.71:security/nss \
+ icu>=69.1,1:devel/icu \
libevent>=2.1.8:devel/libevent \
- harfbuzz>=2.8.1:print/harfbuzz \
+ harfbuzz>=2.9.1:print/harfbuzz \
graphite2>=1.3.14:graphics/graphite2 \
png>=1.6.37:graphics/png \
libvpx>=1.8.2:multimedia/libvpx \
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 4d6458d79e11..bb261fd8eda0 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1632868474
-SHA256 (firefox-93.0.source.tar.xz) = a78f080f5849bc284b84299f3540934a12e961a7ea368b592ae6576ea1f97102
-SIZE (firefox-93.0.source.tar.xz) = 382181136
+TIMESTAMP = 1635270996
+SHA256 (firefox-94.0.source.tar.xz) = b5e1a5f6068f16992bb516d01875f3f04acd90f53ad5b7a11a6a5a66ff999f09
+SIZE (firefox-94.0.source.tar.xz) = 380022264
diff --git a/www/firefox/files/patch-bug1602730_comment5 b/www/firefox/files/patch-bug1602730_comment5
deleted file mode 100644
index 212221b6d5cf..000000000000
--- a/www/firefox/files/patch-bug1602730_comment5
+++ /dev/null
@@ -1,24 +0,0 @@
---- gfx/layers/composite/CompositableHost.cpp.orig 2020-09-12 21:47:42 UTC
-+++ gfx/layers/composite/CompositableHost.cpp
-@@ -10,6 +10,7 @@
- #include "Effects.h" // for EffectMask, Effect, etc
- #include "gfxUtils.h"
- #include "Layers.h"
-+#include "mozilla/EndianUtils.h"
- #include "mozilla/gfx/gfxVars.h"
- #include "mozilla/layers/LayersSurfaces.h" // for SurfaceDescriptor
- #include "mozilla/layers/TextureHost.h" // for TextureHost, etc
-@@ -89,9 +90,13 @@
- }
- MOZ_ASSERT(source);
-
-+ // Setting an alpha-mask here breaks the URL-bar on big endian (s390x)
-+ // if the typed URL is too long for the textbox (automatic scrolling needed)
-+#if MOZ_LITTLE_ENDIAN()
- RefPtr<EffectMask> effect =
- new EffectMask(source, source->GetSize(), aTransform);
- aEffects.mSecondaryEffects[EffectTypes::MASK] = effect;
-+#endif
- return true;
- }
-
diff --git a/www/firefox/files/patch-rust-1.56.0 b/www/firefox/files/patch-rust-1.56.0
deleted file mode 100644
index 180eb3bdf244..000000000000
--- a/www/firefox/files/patch-rust-1.56.0
+++ /dev/null
@@ -1,21 +0,0 @@
-error[E0557]: feature has been removed
- --> /wrkdirs/usr/ports/www/firefox/work/firefox-93.0/third_party/rust/packed_simd/src/lib.rs:203:5
- |
-203 | const_generics,
- | ^^^^^^^^^^^^^^ feature has been removed
- |
- = note: removed in favor of `#![feature(adt_const_params]` and `#![feature(generic_const_exprs)]`
-
-https://github.com/rust-lang/packed_simd/commit/45d5347a0d2187c046a546a477d2a53111cd7713
-
---- third_party/rust/packed_simd/src/lib.rs.orig 2021-10-20 11:41:07 UTC
-+++ third_party/rust/packed_simd/src/lib.rs
-@@ -200,7 +200,7 @@
- //! preserving, etc.
-
- #![feature(
-- const_generics,
-+ adt_const_params,
- repr_simd,
- rustc_attrs,
- platform_intrinsics,