aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-08-13 13:19:17 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-08-13 18:23:35 +0000
commit6553c93b0a7ae9491f9af84f63d3115cfa265bc5 (patch)
treef93150a482010ff0bd07cf7576455ea3caf1dcc2
parent3f0d6e066339cfde3eb3f662566e23325c8d5dcc (diff)
downloadports-6553c93b0a7ae9491f9af84f63d3115cfa265bc5.tar.gz
ports-6553c93b0a7ae9491f9af84f63d3115cfa265bc5.zip
x11/sddm: Restore a patch for the Xsession script.
Make it start D-Bus and ConsoleKit again. PR: 272637 Sponsored by: Serenity Cybersecurity, LLC
-rw-r--r--x11/sddm/Makefile6
-rw-r--r--x11/sddm/files/patch-data_scripts_Xsession12
2 files changed, 16 insertions, 2 deletions
diff --git a/x11/sddm/Makefile b/x11/sddm/Makefile
index 25556e3135bb..f2563817f87c 100644
--- a/x11/sddm/Makefile
+++ b/x11/sddm/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sddm
PORTVERSION= 0.20.0
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= v
CATEGORIES= x11
@@ -18,7 +18,8 @@ LICENSE_FILE_GPLv2+ = ${WRKSRC}/LICENSE
LICENSE_FILE_CC-BY-3.0= ${WRKSRC}/LICENSE.CC-BY-3.0
BUILD_DEPENDS= rst2man.py-${PYTHON_VER}:textproc/py-docutils@${PY_FLAVOR}
-RUN_DEPENDS= dbus-run-session:devel/dbus \
+RUN_DEPENDS= consolekit2>1.2.5:sysutils/consolekit2 \
+ dbus-launch:devel/dbus \
xauth:x11/xauth \
xmessage:x11/xmessage
@@ -51,6 +52,7 @@ post-patch:
@${REINPLACE_CMD} -e 's#/etc/X11#${LOCALBASE}/etc/X11#' \
-e 's#/usr/bin/#${LOCALBASE}/bin/#g' \
-e 's#/usr/share/#${LOCALBASE}/share/#' \
+ -e 's#%%LOCALBASE%%#${LOCALBASE}#g' \
${WRKSRC}/data/scripts/Xsession \
${WRKSRC}/src/common/Configuration.h
diff --git a/x11/sddm/files/patch-data_scripts_Xsession b/x11/sddm/files/patch-data_scripts_Xsession
new file mode 100644
index 000000000000..6c4b40a5cc37
--- /dev/null
+++ b/x11/sddm/files/patch-data_scripts_Xsession
@@ -0,0 +1,12 @@
+Start a session D-Bus before anything else.
+Then register ourselves with ConsoleKit via $STARTUP
+
+--- data/scripts/Xsession.orig 2023-06-23 12:28:38 UTC
++++ data/scripts/Xsession
+@@ -90,5 +90,5 @@ else
+ if [ -z "$*" ]; then
+ exec xmessage -center -buttons OK:0 -default OK "Sorry, $DESKTOP_SESSION is no valid session."
+ else
+- exec $@
++ exec %%LOCALBASE%%/bin/dbus-launch --exit-with-x11 -- $STARTUP "$@"
+ fi