aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2021-05-12 09:40:47 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2021-05-12 09:40:47 +0000
commit655a237422f8dfdda287a57c5e0fe61718b5c956 (patch)
tree9d28d2a8d5ced4f686015f4d14503997d8d07f67
parent1f76307ce2cfc92711f643f84f98ce798b2c3107 (diff)
downloadports-655a237422f8dfdda287a57c5e0fe61718b5c956.tar.gz
ports-655a237422f8dfdda287a57c5e0fe61718b5c956.zip
devel/ipython: add missing runtime dependency
Add missing dependency upon matplotlib-inline, that was introduced in IPython 7.23 [1], but was overlooked in recent port update. [1] https://ipython.readthedocs.io/en/latest/whatsnew/version7.html?ipython-7-23#ipython-7-23 PR: 255743 Reported by: p5B2E9A8F@t-online.de With hat: python
-rw-r--r--devel/ipython/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/ipython/Makefile b/devel/ipython/Makefile
index 379815f2f0d3..2313de0aaa5b 100644
--- a/devel/ipython/Makefile
+++ b/devel/ipython/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ipython
PORTVERSION= 7.23.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,7 +21,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}backcall>=0:devel/py-backcall@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}prompt-toolkit>=2.0.0<3.1.0:devel/py-prompt-toolkit@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>=2:databases/py-sqlite3@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}traitlets>=4.2:devel/py-traitlets@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}traitlets>=4.2:devel/py-traitlets@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib-inline>=4.2:math/py-matplotlib-inline@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist distutils