aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2022-10-21 20:40:13 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2022-10-21 20:40:13 +0000
commit65a0d7986d46628f305823c335f0111d1ce73077 (patch)
tree477d4659d1f7ec3dd9863e57ce43a072eeb8831f
parentb2d650d75d65f08dbd25515fab0bf13720236ead (diff)
downloadports-65a0d7986d46628f305823c335f0111d1ce73077.tar.gz
ports-65a0d7986d46628f305823c335f0111d1ce73077.zip
math/octave-forge-fda: new port to support data analysis.
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-fda/Makefile29
-rw-r--r--math/octave-forge-fda/distinfo3
-rw-r--r--math/octave-forge-fda/pkg-descr10
4 files changed, 43 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 0eb3b835859e..d23b8a42bc1a 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -540,6 +540,7 @@
SUBDIR += octave-forge-divand
SUBDIR += octave-forge-doctest
SUBDIR += octave-forge-econometrics
+ SUBDIR += octave-forge-fda
SUBDIR += octave-forge-fenv
SUBDIR += octave-forge-financial
SUBDIR += octave-forge-fits
diff --git a/math/octave-forge-fda/Makefile b/math/octave-forge-fda/Makefile
new file mode 100644
index 000000000000..9e890f5be883
--- /dev/null
+++ b/math/octave-forge-fda/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= octave-forge-fda
+PORTVERSION= 1.0.0
+CATEGORIES= math
+MASTER_SITES= https://gitlab.com/kakila/fda/-/archive/master/
+DISTNAME= fda-master
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+WWW= http://octave.sourceforge.net/
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= fda-master
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+do-build:
+ @${DO_NADA}
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${OCTAVE_DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-fda/distinfo b/math/octave-forge-fda/distinfo
new file mode 100644
index 000000000000..6473d441a244
--- /dev/null
+++ b/math/octave-forge-fda/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1666374422
+SHA256 (octave-forge/fda-master.tar.gz) = 4e6e23e93267c0b973e8143c8f368f65744d9939ff8f70bc9c397aec5f24f281
+SIZE (octave-forge/fda-master.tar.gz) = 3851295
diff --git a/math/octave-forge-fda/pkg-descr b/math/octave-forge-fda/pkg-descr
new file mode 100644
index 000000000000..d6f809c5d7c5
--- /dev/null
+++ b/math/octave-forge-fda/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is fda.
+
+ These functions were developed to support functional data analysis as
+described in Ramsay, J. O. and Silverman, B. W. (2005) Functional Data
+ Analysis. New York: Springer.