aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-15 14:34:53 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-15 14:34:53 +0000
commit65a552955f4584a3f01a6256eaa73c0e8254f143 (patch)
tree4de01a45affa3b8b769962a858d46ed616e66252
parentb5b6832be1a644910f90ba54077f9f9d7fda15bf (diff)
downloadports-65a552955f4584a3f01a6256eaa73c0e8254f143.tar.gz
ports-65a552955f4584a3f01a6256eaa73c0e8254f143.zip
Add ruby-locale, a simple Ruby module that provides setlocale(3).
Notes
Notes: svn path=/head/; revision=31665
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-locale/Makefile44
-rw-r--r--devel/ruby-locale/distinfo1
-rw-r--r--devel/ruby-locale/files/patch-aa8
-rw-r--r--devel/ruby-locale/pkg-comment1
-rw-r--r--devel/ruby-locale/pkg-descr4
-rw-r--r--devel/ruby-locale/pkg-plist5
7 files changed, 64 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 010efc0beda7..84a2943ae3ef 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -266,6 +266,7 @@
SUBDIR += ruby-amstd
SUBDIR += ruby-date2
SUBDIR += ruby-intl
+ SUBDIR += ruby-locale
SUBDIR += ruby-optparse
SUBDIR += ruby-property
SUBDIR += ruby-racc
diff --git a/devel/ruby-locale/Makefile b/devel/ruby-locale/Makefile
new file mode 100644
index 000000000000..0f941269f54c
--- /dev/null
+++ b/devel/ruby-locale/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Ruby-locale
+# Date created: 15 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= locale
+PORTVERSION= 0.2
+CATEGORIES= devel # ruby
+MASTER_SITES= http://kafka.salem.mass.edu/~yashi/ruby/
+PKGNAMEPREFIX= ruby-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+#USE_BZIP2= yes # only saves 500 bytes..
+
+INSTALL_TARGET= site-install
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/examples/ruby/locale
+ ${INSTALL_DATA} ${WRKSRC}/test.rb ${PREFIX}/share/examples/ruby/locale/
+ ${MKDIR} ${PREFIX}/share/doc/ruby/locale
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ruby/locale/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-locale/distinfo b/devel/ruby-locale/distinfo
new file mode 100644
index 000000000000..fb878c8b2a12
--- /dev/null
+++ b/devel/ruby-locale/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-locale-0.2.tar.gz) = 674bf4d9ba231c331938d8e394b05507
diff --git a/devel/ruby-locale/files/patch-aa b/devel/ruby-locale/files/patch-aa
new file mode 100644
index 000000000000..5789b00980e5
--- /dev/null
+++ b/devel/ruby-locale/files/patch-aa
@@ -0,0 +1,8 @@
+--- extconf.rb.orig Fri Apr 14 13:20:58 2000
++++ extconf.rb Tue Aug 15 21:16:38 2000
+@@ -1,4 +1,5 @@
+ require 'mkmf'
+
+ have_header 'locale.h'
++have_library 'xpg4', 'setlocale'
+ create_makefile 'locale'
diff --git a/devel/ruby-locale/pkg-comment b/devel/ruby-locale/pkg-comment
new file mode 100644
index 000000000000..ec8037905ad8
--- /dev/null
+++ b/devel/ruby-locale/pkg-comment
@@ -0,0 +1 @@
+A simple Ruby module that provides setlocale(3)
diff --git a/devel/ruby-locale/pkg-descr b/devel/ruby-locale/pkg-descr
new file mode 100644
index 000000000000..29a1051e15fa
--- /dev/null
+++ b/devel/ruby-locale/pkg-descr
@@ -0,0 +1,4 @@
+Ruby-locale -- A simple Ruby module that provides setlocale(3)
+
+Author: Yasushi Shoji <yashi@kafka.salem.mass.edu>
+WWW: http://kafka.salem.mass.edu/~yashi/ruby/#locale
diff --git a/devel/ruby-locale/pkg-plist b/devel/ruby-locale/pkg-plist
new file mode 100644
index 000000000000..c401c7b0d5f6
--- /dev/null
+++ b/devel/ruby-locale/pkg-plist
@@ -0,0 +1,5 @@
+lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/locale.so
+share/examples/ruby/locale/test.rb
+@dirrm share/examples/ruby/locale
+share/doc/ruby/locale/README
+@dirrm share/doc/ruby/locale