aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2022-07-31 16:20:20 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2022-07-31 16:20:20 +0000
commit65eb08792cd4cb627667908f888d4858693535b7 (patch)
treefdd0ab30cf471c5af574a34bc3a4f45c07e1aad6
parent949672a6bef2134dfe3f2518400b58999d69ac10 (diff)
downloadports-65eb08792cd4cb627667908f888d4858693535b7.tar.gz
ports-65eb08792cd4cb627667908f888d4858693535b7.zip
www/py-lektor: follow tips from vishwin@, and hack setup.py
while here, set inifile version to be 0.4 instead of 0.4.1 PR: 265486 Reported by: p5B2EA84B3 % t-online.de
-rw-r--r--www/py-lektor/Makefile1
-rw-r--r--www/py-lektor/files/patch-setup.cfg11
-rw-r--r--www/py-lektor/files/patch-setup.py9
3 files changed, 21 insertions, 0 deletions
diff --git a/www/py-lektor/Makefile b/www/py-lektor/Makefile
index 2289bcb9108a..d744e5cff75a 100644
--- a/www/py-lektor/Makefile
+++ b/www/py-lektor/Makefile
@@ -1,5 +1,6 @@
PORTNAME= Lektor
PORTVERSION= 3.3.6
+PORTREVISION= 1
CATEGORIES= www devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-lektor/files/patch-setup.cfg b/www/py-lektor/files/patch-setup.cfg
new file mode 100644
index 000000000000..38f184be4272
--- /dev/null
+++ b/www/py-lektor/files/patch-setup.cfg
@@ -0,0 +1,11 @@
+--- setup.cfg.orig 2022-07-31 16:11:11 UTC
++++ setup.cfg
+@@ -35,7 +35,7 @@ install_requires =
+ EXIFRead
+ filetype>=1.0.7
+ Flask
+- inifile>=0.4.1
++ inifile>=0.4
+ Jinja2>=3.0
+ mistune>=0.7.0,<2
+ pip
diff --git a/www/py-lektor/files/patch-setup.py b/www/py-lektor/files/patch-setup.py
new file mode 100644
index 000000000000..22af075176c5
--- /dev/null
+++ b/www/py-lektor/files/patch-setup.py
@@ -0,0 +1,9 @@
+--- setup.py.orig 2022-07-31 16:11:11 UTC
++++ setup.py
+@@ -0,0 +1,6 @@
++from setuptools import setup
++
++setup(
++ name="Lektor",
++ version="3.3.6",
++)