aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-12 19:44:58 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-12 19:44:58 +0000
commit65f0fadb206c6210df221a9151708531fd603a7d (patch)
treea68852a82d24afe4de593a25324ff4ed1cce23e7
parentff0a9fbdea38780be08bf189cc5473ccd7bcf26b (diff)
downloadports-65f0fadb206c6210df221a9151708531fd603a7d.tar.gz
ports-65f0fadb206c6210df221a9151708531fd603a7d.zip
Update to 1.0.r2
PR: ports/99805 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=167605
-rw-r--r--multimedia/tunapie/Makefile6
-rw-r--r--multimedia/tunapie/distinfo6
-rw-r--r--multimedia/tunapie/files/patch-install.sh6
-rw-r--r--multimedia/tunapie/files/patch-src-TunerFrame1.py12
-rw-r--r--multimedia/tunapie/files/patch-src-TunerPrefs.py14
-rw-r--r--multimedia/tunapie/files/patch-src-compile17
-rw-r--r--multimedia/tunapie/pkg-plist3
7 files changed, 42 insertions, 22 deletions
diff --git a/multimedia/tunapie/Makefile b/multimedia/tunapie/Makefile
index c2ac81ffc202..51e1a93cb33e 100644
--- a/multimedia/tunapie/Makefile
+++ b/multimedia/tunapie/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= tunapie
-PORTVERSION= 0.9.9
+PORTVERSION= 1.0.r2
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+DISTNAME= ${PORTNAME}_${PORTVERSION:S|.r2|_rc2|}
MAINTAINER= nivit@email.it
COMMENT= Tuner for streaming internet radio and TV
@@ -18,7 +18,7 @@ COMMENT= Tuner for streaming internet radio and TV
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/__init__.py:${PORTSDIR}/lang/py-mx-base \
${PYTHON_SITELIBDIR}/${WX_PYTHON_DIR}/wxPython/_wx.py:${PORTSDIR}/x11-toolkits/py-wxPython26 \
streamripper:${PORTSDIR}/audio/streamripper \
- mplayer:${PORTSDIR}/multimedia/mplayer \
+ xine:${PORTSDIR}/multimedia/xine \
xmms:${PORTSDIR}/multimedia/xmms
NO_BUILD= yes
diff --git a/multimedia/tunapie/distinfo b/multimedia/tunapie/distinfo
index add4a5f3705c..a16a33aa4079 100644
--- a/multimedia/tunapie/distinfo
+++ b/multimedia/tunapie/distinfo
@@ -1,3 +1,3 @@
-MD5 (tunapie_0.9.9.tar.gz) = e67de4978036beea03eb349f8b0d14a9
-SHA256 (tunapie_0.9.9.tar.gz) = f01d2ece51063dbe9695fb57c3431e3074fcdd38b562f9bf3cc7baead5ed5dcc
-SIZE (tunapie_0.9.9.tar.gz) = 37727
+MD5 (tunapie_1.0_rc2.tar.gz) = 2b479e78e2c3474e43a17d7b668af52d
+SHA256 (tunapie_1.0_rc2.tar.gz) = e1f3942d9be93b6c4736770f1c33075f760e309a55f729259fd5fb04abfb6f6a
+SIZE (tunapie_1.0_rc2.tar.gz) = 39034
diff --git a/multimedia/tunapie/files/patch-install.sh b/multimedia/tunapie/files/patch-install.sh
index 46ef95257ab1..ea3db36299ed 100644
--- a/multimedia/tunapie/files/patch-install.sh
+++ b/multimedia/tunapie/files/patch-install.sh
@@ -1,6 +1,6 @@
$FreeBSD$
---- install.sh Sat Apr 1 23:21:08 2006
-+++ install.sh.port Mon Apr 3 14:06:04 2006
+--- install.sh Sun Jul 2 10:49:31 2006
++++ install.sh.port Tue Jul 4 14:10:42 2006
@@ -3,7 +3,7 @@
else cp src/tunersafe.py src/tuner.py
fi
@@ -10,6 +10,6 @@ $FreeBSD$
-mkdir /usr/local/share/tunapie
-cp src/*.py src/*.pyc src/*.jpg /usr/local/share/tunapie
+cp tunapie %%PREFIX%%/bin
-+#rm -rf %%DATADIR%%
++#rm -rf /usr/local/share/tunapie
+mkdir %%DATADIR%%
+cp src/*.py src/*.pyc src/*.jpg %%DATADIR%%
diff --git a/multimedia/tunapie/files/patch-src-TunerFrame1.py b/multimedia/tunapie/files/patch-src-TunerFrame1.py
index bdf647bc01c6..3360ba585ff0 100644
--- a/multimedia/tunapie/files/patch-src-TunerFrame1.py
+++ b/multimedia/tunapie/files/patch-src-TunerFrame1.py
@@ -1,18 +1,18 @@
$FreeBSD$
---- src/TunerFrame1.py Tue May 9 23:17:31 2006
-+++ src/TunerFrame1.py.port Wed May 10 11:38:29 2006
-@@ -352,10 +352,10 @@
+--- src/TunerFrame1.py Sun Jul 2 20:16:55 2006
++++ src/TunerFrame1.py.port Tue Jul 4 15:07:01 2006
+@@ -422,10 +422,10 @@
for name in self.favname:
self.favorites.Append(name)
self.name=[]
- self.mediaplayer='/usr/bin/xmms'
-- self.videoplayer='/usr/bin/mplayer -nojoystick'
+- self.videoplayer='/usr/bin/totem'
- self.term='/usr/bin/x-terminal-emulator'
- self.ripper='/usr/bin/streamripper -t -u winamp2 -o never'
+ self.mediaplayer='%%X11BASE%%/bin/xmms'
-+ self.videoplayer='%%LOCALBASE%%/bin/mplayer -nojoystick'
++ self.videoplayer='%%X11BASE%%/bin/xine'
+ self.term='%%X11BASE%%/bin/xterm'
+ self.ripper='%%LOCALBASE%%/bin/streamripper -t -u winamp2 -o never'
self.rdir=self.home+'/.tunapie/streamripper'
self.shoutice=1 #0 is icecast server 1 is shoutcast
- self.mediaplayer,self.videoplayer,self.term,self.ripper,self.rdir,self.shoutice=\
+ self.maxd=100
diff --git a/multimedia/tunapie/files/patch-src-TunerPrefs.py b/multimedia/tunapie/files/patch-src-TunerPrefs.py
index c12421e9ef6d..823581970991 100644
--- a/multimedia/tunapie/files/patch-src-TunerPrefs.py
+++ b/multimedia/tunapie/files/patch-src-TunerPrefs.py
@@ -1,7 +1,7 @@
$FreeBSD$
---- src/TunerPrefs.py Wed May 24 23:10:23 2006
-+++ src/TunerPrefs.py.port Sat May 27 10:59:16 2006
-@@ -74,7 +74,7 @@
+--- src/TunerPrefs.py Sun Jul 2 10:49:31 2006
++++ src/TunerPrefs.py.port Tue Jul 4 15:11:29 2006
+@@ -77,7 +77,7 @@
self.audiopath = wx.TextCtrl(id=wxID_PREFERENCESAUDIOPATH,
name='audiopath', parent=self, pos=wx.Point(160, 16),
@@ -10,16 +10,16 @@ $FreeBSD$
self.audiopath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
u'Sans'))
self.audiopath.SetBackgroundColour(wx.Colour(255, 253, 239))
-@@ -82,7 +82,7 @@
+@@ -85,7 +85,7 @@
self.videopath = wx.TextCtrl(id=wxID_PREFERENCESVIDEOPATH,
name='videopath', parent=self, pos=wx.Point(160, 48),
- size=wx.Size(208, 22), style=0, value='/usr/bin/mplayer')
-+ size=wx.Size(208, 22), style=0, value='%%LOCALBASE%%/bin/mplayer')
++ size=wx.Size(208, 22), style=0, value='%%X11BASE%%/bin/xine')
self.videopath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
u'Sans'))
self.videopath.SetBackgroundColour(wx.Colour(255, 253, 239))
-@@ -110,7 +110,7 @@
+@@ -113,7 +113,7 @@
self.termpath = wx.TextCtrl(id=wxID_PREFERENCESTERMPATH,
name='termpath', parent=self, pos=wx.Point(160, 80),
size=wx.Size(208, 22), style=0,
@@ -28,7 +28,7 @@ $FreeBSD$
self.termpath.SetFont(wx.Font(7, wx.SWISS, wx.NORMAL, wx.NORMAL, False,
u'Sans'))
self.termpath.SetBackgroundColour(wx.Colour(255, 253, 239))
-@@ -118,7 +118,7 @@
+@@ -121,7 +121,7 @@
self.rippath = wx.TextCtrl(id=wxID_PREFERENCESRIPPATH, name='rippath',
parent=self, pos=wx.Point(160, 112), size=wx.Size(208, 22),
diff --git a/multimedia/tunapie/files/patch-src-compile b/multimedia/tunapie/files/patch-src-compile
new file mode 100644
index 000000000000..3e627617891b
--- /dev/null
+++ b/multimedia/tunapie/files/patch-src-compile
@@ -0,0 +1,17 @@
+$FreeBSD$
+--- src/compile Sun Jul 2 10:49:31 2006
++++ src/compile.port Tue Jul 11 21:30:59 2006
+@@ -1 +1,12 @@
+-import Tunapie
++import os, os.path, re
++from compiler import compileFile
++
++def compile_tunapie(arg, dir, files):
++ for file in files:
++ path = os.path.join(dir, file)
++ path = os.path.normcase(path)
++ if re.search(r".*\.py$", path):
++ print " ==> Generating bytecode for " + path
++ compileFile(path)
++
++os.path.walk('.', compile_tunapie, 0)
diff --git a/multimedia/tunapie/pkg-plist b/multimedia/tunapie/pkg-plist
index f7ca3af2c1b3..26604d10fd98 100644
--- a/multimedia/tunapie/pkg-plist
+++ b/multimedia/tunapie/pkg-plist
@@ -7,6 +7,7 @@ bin/tunapie
%%DATADIR%%/RecordTime.py
%%DATADIR%%/RecordTime.pyc
%%DATADIR%%/Splash.py
+%%DATADIR%%/Splash.pyc
%%DATADIR%%/Tunapie.py
%%DATADIR%%/Tunapie.pyc
%%DATADIR%%/TunerFrame1.py
@@ -19,5 +20,7 @@ bin/tunapie
%%DATADIR%%/tuner.py
%%DATADIR%%/tuner.pyc
%%DATADIR%%/tuneradult.py
+%%DATADIR%%/tuneradult.pyc
%%DATADIR%%/tunersafe.py
+%%DATADIR%%/tunersafe.pyc
@dirrm %%DATADIR%%