aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2021-07-12 21:09:26 +0000
committerDan Langille <dvl@FreeBSD.org>2021-07-12 21:09:26 +0000
commit662905021e6b34c84240a6da98dab822ca864f3c (patch)
treef6c888cc66cb29efdc11200200290f7b2468a642
parentbe98df0b75eaa77c0c7153f4b389adf6c34691ba (diff)
downloadports-662905021e6b34c84240a6da98dab822ca864f3c.tar.gz
ports-662905021e6b34c84240a6da98dab822ca864f3c.zip
devel/py-celery-progress: New port: Distributed Task Queue
Drop in, dependency-free progress bars for your Django/Celery applications. Super simple setup. Lots of customization available. PR: 257133 Reported by: gettoknowmi@yahoo.com
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-celery-progress/Makefile25
-rw-r--r--devel/py-celery-progress/distinfo3
-rw-r--r--devel/py-celery-progress/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0cf936b4c20a..1841f6e72ab6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4257,6 +4257,7 @@
SUBDIR += py-cclib
SUBDIR += py-cdg
SUBDIR += py-celery
+ SUBDIR += py-celery-progress
SUBDIR += py-cerberus
SUBDIR += py-certsrv
SUBDIR += py-cffi
diff --git a/devel/py-celery-progress/Makefile b/devel/py-celery-progress/Makefile
new file mode 100644
index 000000000000..ba1c526668af
--- /dev/null
+++ b/devel/py-celery-progress/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= celery-progress
+PORTVERSION= 0.1.1
+CATEGORIES= devel
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gettoknowmi@yahoo.com
+COMMENT= Distributed Task Queue
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS+= redis>0:databases/redis \
+ rabbitmq>0:net/rabbitmq \
+ ${PYTHON_PKGNAMEPREFIX}celery>0:devel/py-celery@${PY_FLAVOR} \
+ websocat>0:www/websocat
+
+USES= python:3.6+,run
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-celery-progress/distinfo b/devel/py-celery-progress/distinfo
new file mode 100644
index 000000000000..6042e4aa549e
--- /dev/null
+++ b/devel/py-celery-progress/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1626100938
+SHA256 (celery-progress-0.1.1.tar.gz) = b2622d1b410a763412810f0293153c984f4a0220b76769bd701b5b45e583ddad
+SIZE (celery-progress-0.1.1.tar.gz) = 12814
diff --git a/devel/py-celery-progress/pkg-descr b/devel/py-celery-progress/pkg-descr
new file mode 100644
index 000000000000..4bc142d341e8
--- /dev/null
+++ b/devel/py-celery-progress/pkg-descr
@@ -0,0 +1,7 @@
+Task queues are used as a mechanism to distribute work across threads or
+machines.
+
+Celery communicates via messages, usually using a broker to mediate between
+clients and workers.
+
+WWW: https://github.com/celery/celery/