aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2023-04-29 15:59:08 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2023-04-29 15:59:08 +0000
commit663d0a6ab3d3d079edc5fea4982c862daa529295 (patch)
treefaa1192d60bad840efa35f37609e6346cb0c52ff
parent75bed9fdf24c2cc7e14012aaa537af03c7931fb3 (diff)
downloadports-663d0a6ab3d3d079edc5fea4982c862daa529295.tar.gz
ports-663d0a6ab3d3d079edc5fea4982c862daa529295.zip
audio/xfce4-mixer: Resuscitate port, update to 4.18.0
This new mixer incarnation has support for various audio architectures. The port has two flavors: lite (default one) - supports only system audio (oss) full - has all options turned on, also supporta alsa, pulseaudio and sndio
-rw-r--r--MOVED1
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xfce4-mixer/Makefile61
-rw-r--r--audio/xfce4-mixer/distinfo3
-rw-r--r--audio/xfce4-mixer/pkg-descr3
-rw-r--r--audio/xfce4-mixer/pkg-plist66
6 files changed, 134 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index c61b4195d202..fe76f3442d10 100644
--- a/MOVED
+++ b/MOVED
@@ -15541,7 +15541,6 @@ devel/py-twext||2020-11-03|Has expired: Uses deprecated version of python
databases/py-sqlparse020|databases/py-sqlparse|2020-11-03|Dependency of removed www/calendarserver
net-im/zephyr||2020-11-07|Has expired: Broken for more than 6 months
net/samba410|net/samba412|2020-11-08|Has expired: yes
-audio/xfce4-mixer|audio/xfce4-pulseaudio-plugin|2020-11-08|Unsupported upstream since 2015. Try using audio/xfce4-pulseaudio-plugin
multimedia/swfdec-gnome||2020-11-09|Depends on the expired gstreamer 0.10
graphics/swfdec||2020-11-09|Depends on the expired gstreamer 0.10
multimedia/py-openlp||2020-11-09|Depends on the expired gstreamer 0.10
diff --git a/audio/Makefile b/audio/Makefile
index fa53e63336b8..c83e04a5afb5 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -867,6 +867,7 @@
SUBDIR += xanalyser
SUBDIR += xcd
SUBDIR += xcdplayer
+ SUBDIR += xfce4-mixer
SUBDIR += xfce4-mpc-plugin
SUBDIR += xfce4-pulseaudio-plugin
SUBDIR += xfmpc
diff --git a/audio/xfce4-mixer/Makefile b/audio/xfce4-mixer/Makefile
new file mode 100644
index 000000000000..158cd86e2b96
--- /dev/null
+++ b/audio/xfce4-mixer/Makefile
@@ -0,0 +1,61 @@
+PORTNAME= xfce4-mixer
+PORTVERSION= 4.18.0
+CATEGORIES= audio xfce
+MASTER_SITES= XFCE/apps
+DIST_SUBDIR= xfce4
+
+MAINTAINER= xfce@FreeBSD.org
+COMMENT= Volume control for the Xfce desktop
+WWW= https://docs.xfce.org/apps/xfce4-mixer/start
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
+
+FLAVORS= lite full
+FLAVOR?= ${FLAVORS:[1]}
+
+lite_CONFLICTS_INSTALL= xfce4-mixer-full
+
+full_PKGNAMESUFFIX= -full
+full_CONFLICTS_INSTALL= xfce4-mixer
+
+USES= compiler:c11 gettext-tools gmake gnome gstreamer libtool \
+ pkgconfig tar:bzip2 xfce xorg
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 intltool
+USE_GSTREAMER= good
+USE_XFCE= panel
+USE_XORG= x11
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= KEYBINDER NLS
+OPTIONS_DEFAULT= OSS
+OPTIONS_GROUP= AUDIO
+OPTIONS_GROUP_AUDIO= ALSA OSS PULSEAUDIO SNDIO
+OPTIONS_SUB= yes
+
+.if ${FLAVOR} == full
+OPTIONS_DEFAULT+= ALSA KEYBINDER PULSEAUDIO SNDIO
+.endif
+
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
+ALSA_CONFIGURE_ENABLE= alsa
+
+KEYBINDER_DESC= Multimedia keyboard shortcuts
+KEYBINDER_LIB_DEPENDS= libkeybinder-3.0.so:x11/keybinder-gtk3
+KEYBINDER_CONFIGURE_ENABLE= keybinder
+
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
+
+OSS_CONFIGURE_ENABLE= oss
+
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+PULSEAUDIO_CONFIGURE_ENABLE= pulse
+
+SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
+SNDIO_CONFIGURE_ENABLE= sndio
+
+.include <bsd.port.mk>
diff --git a/audio/xfce4-mixer/distinfo b/audio/xfce4-mixer/distinfo
new file mode 100644
index 000000000000..e01fe2dd0ba3
--- /dev/null
+++ b/audio/xfce4-mixer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1682756990
+SHA256 (xfce4/xfce4-mixer-4.18.0.tar.bz2) = 53747a23732e79ed808a73242bbc8e0140434249ca1a0f57f4028e88531f95de
+SIZE (xfce4/xfce4-mixer-4.18.0.tar.bz2) = 527890
diff --git a/audio/xfce4-mixer/pkg-descr b/audio/xfce4-mixer/pkg-descr
new file mode 100644
index 000000000000..058a10474053
--- /dev/null
+++ b/audio/xfce4-mixer/pkg-descr
@@ -0,0 +1,3 @@
+The Mixer is a volume control application for the Xfce Desktop
+Environment. It provides both a volume control plugin for the Xfce panel
+and a standalone mixer application.
diff --git a/audio/xfce4-mixer/pkg-plist b/audio/xfce4-mixer/pkg-plist
new file mode 100644
index 000000000000..1bb4d0e67e2f
--- /dev/null
+++ b/audio/xfce4-mixer/pkg-plist
@@ -0,0 +1,66 @@
+bin/xfce4-mixer
+lib/xfce4/panel/plugins/libmixer.so
+man/man1/xfce4-mixer.1.gz
+share/applications/xfce4-mixer.desktop
+%%NLS%%share/locale/ar/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/be/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/el/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/en_AU/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/en_CA/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/fa_IR/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/he/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/hy_AM/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/hye/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/id/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/ie/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/is/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/oc/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/si/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/th/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/xfce4-mixer.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-mixer.mo
+share/pixmaps/xfce4-mixer/chain-broken.png
+share/pixmaps/xfce4-mixer/chain.png
+share/xfce4/mixer/icons/hicolor/16x16/status/audio-input-microphone-muted.png
+share/xfce4/mixer/icons/hicolor/scalable/status/audio-input-microphone-muted.svg
+share/xfce4/panel/plugins/mixer.desktop