aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-21 16:51:53 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-21 17:01:57 +0000
commit664ad19ced52ff61f57992d6e661a807e60b6a69 (patch)
tree976fa33c50938a506ddae5ff4d0bd948903b06c0
parent72093f0398ad47fef5f545d364c70ab1c6bf9852 (diff)
downloadports-664ad19ced52ff61f57992d6e661a807e60b6a69.tar.gz
ports-664ad19ced52ff61f57992d6e661a807e60b6a69.zip
devel/py-contextlib-chdir: Add py-contextlib-chdir 1.0.2
contextlib-chdir provides the backport of contextlib.chdir stdlib class added in Python 3.11.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-contextlib-chdir/Makefile20
-rw-r--r--devel/py-contextlib-chdir/distinfo3
-rw-r--r--devel/py-contextlib-chdir/files/patch-pyproject.toml10
-rw-r--r--devel/py-contextlib-chdir/pkg-descr2
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4cad503a7af9..998961787754 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4503,6 +4503,7 @@
SUBDIR += py-constantly
SUBDIR += py-construct
SUBDIR += py-construct-classes
+ SUBDIR += py-contextlib-chdir
SUBDIR += py-contextlib2
SUBDIR += py-convertdate
SUBDIR += py-cookiecutter
diff --git a/devel/py-contextlib-chdir/Makefile b/devel/py-contextlib-chdir/Makefile
new file mode 100644
index 000000000000..2de37d0d1c66
--- /dev/null
+++ b/devel/py-contextlib-chdir/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= contextlib-chdir
+PORTVERSION= 1.0.2
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Backport of contextlib.chdir stdlib class added in Python 3.11
+WWW= https://github.com/mondeja/contextlib-chdir
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-contextlib-chdir/distinfo b/devel/py-contextlib-chdir/distinfo
new file mode 100644
index 000000000000..a8d93346186b
--- /dev/null
+++ b/devel/py-contextlib-chdir/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1692211613
+SHA256 (contextlib-chdir-1.0.2.tar.gz) = 58406a71db00647fcccfc7e52e9e04e44d29eacf30400e7c0ba3b15f09d5f3fa
+SIZE (contextlib-chdir-1.0.2.tar.gz) = 1863
diff --git a/devel/py-contextlib-chdir/files/patch-pyproject.toml b/devel/py-contextlib-chdir/files/patch-pyproject.toml
new file mode 100644
index 000000000000..859972f0a53e
--- /dev/null
+++ b/devel/py-contextlib-chdir/files/patch-pyproject.toml
@@ -0,0 +1,10 @@
+--- pyproject.toml.orig 2022-06-08 17:54:37 UTC
++++ pyproject.toml
+@@ -9,3 +9,7 @@ packages = [{ include = "contextlib_chdir.*" }, { incl
+
+ [tool.poetry.dependencies]
+ python = "^3.6"
++
++[build-system]
++requires = ["poetry-core>=1.0.0"]
++build-backend = "poetry.core.masonry.api"
diff --git a/devel/py-contextlib-chdir/pkg-descr b/devel/py-contextlib-chdir/pkg-descr
new file mode 100644
index 000000000000..b18784e79fcb
--- /dev/null
+++ b/devel/py-contextlib-chdir/pkg-descr
@@ -0,0 +1,2 @@
+contextlib-chdir provides the backport of contextlib.chdir stdlib class added in
+Python 3.11.