aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-11-14 19:12:10 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-11-14 19:12:10 +0000
commit66512b7e3ce8f71ca19871831c30eb8833f42177 (patch)
treeeeb6cf15093749727e4d967e414fe1a40f684489
parent7ba7ca77add02ed6d344c1bf131f3d714a3b125b (diff)
downloadports-66512b7e3ce8f71ca19871831c30eb8833f42177.tar.gz
ports-66512b7e3ce8f71ca19871831c30eb8833f42177.zip
lang/ldc: Remove dependency on libgphobos.so which was needed for the GDC bootstrap.
Sponsored by: Serenity Cybersecurity, LLC
-rw-r--r--lang/ldc/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/lang/ldc/Makefile b/lang/ldc/Makefile
index d849a451eefe..5add870b1557 100644
--- a/lang/ldc/Makefile
+++ b/lang/ldc/Makefile
@@ -15,8 +15,7 @@ LICENSE= BSD3CLAUSE
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= The bootstrap compiler is provided only for x86_64
-LIB_DEPENDS= libconfig.so:devel/libconfig \
- libgphobos.so:lang/gcc${_GCC_VER}
+LIB_DEPENDS= libconfig.so:devel/libconfig
USES= llvm:lib,run ninja cmake:insource pkgconfig
@@ -26,8 +25,6 @@ USES= llvm:lib,run ninja cmake:insource pkgconfig
USE_LDCONFIG= yes
-_GCC_VER= 11
-
CFLAGS+= -fPIC
CMAKE_ARGS+= -DLDC_INSTALL_PREFIX="${PREFIX}" \