aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-04-10 11:24:24 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-04-10 11:24:24 +0000
commit666abc5661c6de6ba55825210b52fa782e567ec9 (patch)
tree9d6e67cc3d5d2296e7495455620c5c08e2f57c13
parent7bd4cba2745c5fdf69895a6900205c23d3a0ea13 (diff)
downloadports-666abc5661c6de6ba55825210b52fa782e567ec9.tar.gz
ports-666abc5661c6de6ba55825210b52fa782e567ec9.zip
- Add LICENSE
- Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=412916
-rw-r--r--cad/electric/Makefile5
-rw-r--r--cad/electric/files/patch-Makefile.in16
-rw-r--r--cad/electric/files/patch-src_graph_graphqtdlg.h6
-rw-r--r--cad/electric/files/patch-src_graph_graphunixx11.c10
-rw-r--r--cad/electric/files/patch-src_include_global.h4
5 files changed, 22 insertions, 19 deletions
diff --git a/cad/electric/Makefile b/cad/electric/Makefile
index 6753001dfb88..4f70b155fc46 100644
--- a/cad/electric/Makefile
+++ b/cad/electric/Makefile
@@ -11,6 +11,9 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/^(...)\./\1/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Sophisticated electrical CAD system
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= yes
USES= motif
@@ -21,7 +24,7 @@ OPTIONS_DEFINE= T1LIB NLS OPTIMIZED_CFLAGS
OPTIONS_DEFAULT=T1LIB
T1LIB_DESC= Use T1lib Type1 font library
-T1LIB_LIB_DEPENDS+= libt1.so:devel/t1lib
+T1LIB_LIB_DEPENDS= libt1.so:devel/t1lib
T1LIB_VARS= FEATURES+=T1LIB
NLS_USES= gettext
NLS_VARS= FEATURES+=INT
diff --git a/cad/electric/files/patch-Makefile.in b/cad/electric/files/patch-Makefile.in
index 53fb875bbe81..014192e425de 100644
--- a/cad/electric/files/patch-Makefile.in
+++ b/cad/electric/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2004-07-16 03:59:50.000000000 +0200
-+++ Makefile.in 2013-02-07 14:08:44.000000000 +0100
+--- Makefile.in.orig 2004-07-16 01:59:50 UTC
++++ Makefile.in
@@ -1,14 +1,14 @@
########################################################## USING QT
##### If using Qt, uncomment these five lines
@@ -21,7 +21,7 @@
##### Qt on Macintosh: uncomment the next two lines (for Qt Evaluation, change "-lqt" to "-lqt-mt"):
# ELECTRIC_TARGET = electric-target-mac
-@@ -20,11 +20,11 @@
+@@ -20,11 +20,11 @@ QUI_CFLAGS = -DUSEQUI
########################################################### USING MOTIF
##### If using Motif (or OpenMotif/Lesstif), uncomment these five lines
@@ -38,7 +38,7 @@
##### For the general-purpose X facility, uncomment this line
XPOWER = -DANYDEPTH
-@@ -32,8 +32,8 @@
+@@ -32,8 +32,8 @@ XPOWER = -DANYDEPTH
# XPOWER =
##### For the T1lib TrueType, uncomment these two lines and set them to the proper location
@@ -49,7 +49,7 @@
###########################################################
-@@ -61,8 +61,8 @@
+@@ -61,8 +61,8 @@ XPOWER = -DANYDEPTH
########################################################### TCL INTERPRETER
##### If building with a TCL interpreter, uncomment these two lines
@@ -60,7 +60,7 @@
###########################################################
-@@ -164,7 +164,8 @@
+@@ -164,7 +164,8 @@ JAVA_OBJS = $(JAVA_SRCS:%.java=%.class)
########################################################### MISCELLANEOUS EXTRAS
##### If building with Internationalization, uncomment this line
@@ -70,7 +70,7 @@
##### If building with Unicode text, uncomment this line
# UNICODECFLAGS = -D_UNICODE
-@@ -179,7 +180,7 @@
+@@ -179,7 +180,7 @@ JAVA_OBJS = $(JAVA_SRCS:%.java=%.class)
# FORTECFLAGS = -compat
##### If optimizing, uncomment this line (modify optimizations to taste)
@@ -79,7 +79,7 @@
##### If debugging, uncomment this line (modify debug options to taste)
# DEBUG = -g3
-@@ -796,12 +797,12 @@
+@@ -796,12 +797,12 @@ CORE_SRC = \
BUILDOPTS = $(DEBUG) $(ARCHFLAGS)
BUILDDIR = obj
HDS = src/include
diff --git a/cad/electric/files/patch-src_graph_graphqtdlg.h b/cad/electric/files/patch-src_graph_graphqtdlg.h
index 09fb306abf51..e5471d85d05f 100644
--- a/cad/electric/files/patch-src_graph_graphqtdlg.h
+++ b/cad/electric/files/patch-src_graph_graphqtdlg.h
@@ -1,6 +1,6 @@
---- src/graph/graphqtdlg.h.orig Fri Jul 14 00:33:51 2006
-+++ src/graph/graphqtdlg.h Fri Jul 14 00:34:01 2006
-@@ -59,6 +59,7 @@
+--- src/graph/graphqtdlg.h.orig 2004-07-16 01:59:53 UTC
++++ src/graph/graphqtdlg.h
+@@ -59,6 +59,7 @@ struct Idialogitem;
class QSignalMapper;
class EScrollField;
class EDialogPrivate;
diff --git a/cad/electric/files/patch-src_graph_graphunixx11.c b/cad/electric/files/patch-src_graph_graphunixx11.c
index ae22971ccb6f..d4bc257623e6 100644
--- a/cad/electric/files/patch-src_graph_graphunixx11.c
+++ b/cad/electric/files/patch-src_graph_graphunixx11.c
@@ -1,5 +1,5 @@
---- src/graph/graphunixx11.c.orig Fri Jul 16 05:59:53 2004
-+++ src/graph/graphunixx11.c Fri Jul 14 01:11:20 2006
+--- src/graph/graphunixx11.c.orig 2004-07-16 01:59:53 UTC
++++ src/graph/graphunixx11.c
@@ -167,6 +167,8 @@
#define TRUESTRLEN strlen
@@ -9,7 +9,7 @@
/****** windows ******/
#define WMLEFTBORDER 8 /* size of left border for windows */
-@@ -1518,13 +1520,13 @@
+@@ -1518,13 +1520,13 @@ BOOLEAN initgraphics(BOOLEAN messages)
gra_truetypeon = 1;
/* Preload T1 fonts here, because T1_LoadFont spoils memory */
@@ -25,7 +25,7 @@
for(gra_truetypedeffont=0; gra_truetypedeffont<j; gra_truetypedeffont++)
{
T1_LoadFont(gra_truetypedeffont);
-@@ -3088,8 +3090,13 @@
+@@ -3088,8 +3090,13 @@ void ewait(INTBIG process)
INTBIG enumprocessors(void)
{
INTBIG numproc;
@@ -40,7 +40,7 @@
return(numproc);
}
-@@ -4758,7 +4765,7 @@
+@@ -4758,7 +4765,7 @@ INTBIG screengetfacelist(CHAR ***list, B
if (gra_numfaces == 0)
{
diff --git a/cad/electric/files/patch-src_include_global.h b/cad/electric/files/patch-src_include_global.h
index 7827ed756d3e..e2c6a6420758 100644
--- a/cad/electric/files/patch-src_include_global.h
+++ b/cad/electric/files/patch-src_include_global.h
@@ -1,5 +1,5 @@
---- src/include/global.h.orig Fri Jul 14 12:43:20 2006
-+++ src/include/global.h Fri Jul 14 12:45:34 2006
+--- src/include/global.h.orig 2004-07-16 01:59:53 UTC
++++ src/include/global.h
@@ -204,7 +204,7 @@
#define INTSML short /* at least 16 bits */
#define UINTSML unsigned short