aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2020-03-18 15:28:35 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2020-03-18 15:28:35 +0000
commit66776a0a89ed4f1f0e0f47f962528e5b7f714010 (patch)
treedf474b239824383d179cfd1c591182290aeb497a
parent787eacc36488c79b5d83c3c6170b393e354e2a76 (diff)
downloadports-66776a0a89ed4f1f0e0f47f962528e5b7f714010.tar.gz
ports-66776a0a89ed4f1f0e0f47f962528e5b7f714010.zip
sysutils/twmn: Update to g20190917, unbreak with clang 10
In file included from /usr/local/include/qt5/QtCore/qstring.h:49: /usr/local/include/qt5/QtCore/qbytearray.h:545:22: error: definition of implicit copy constructor for 'QByteRef' is deprecated because it has a user-declared copy assignment operator [-Werror,-Wdeprecated-copy] inline QByteRef &operator=(const QByteRef &c) ^ /usr/local/include/qt5/QtCore/qbytearray.h:563:28: note: in implicit copy constructor for 'QByteRef' first required here { Q_ASSERT(i >= 0); return QByteRef(*this, i); } ^ PR: 244251
Notes
Notes: svn path=/head/; revision=528654
-rw-r--r--sysutils/twmn/Makefile5
-rw-r--r--sysutils/twmn/distinfo6
-rw-r--r--sysutils/twmn/files/patch-twmnd_twmnd.pro12
3 files changed, 17 insertions, 6 deletions
diff --git a/sysutils/twmn/Makefile b/sysutils/twmn/Makefile
index 5046f2418b59..3ccad11f10fa 100644
--- a/sysutils/twmn/Makefile
+++ b/sysutils/twmn/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= twmn
-PORTVERSION= g20171216
-PORTREVISION= 9
+PORTVERSION= g20190917
CATEGORIES= sysutils
MAINTAINER= dmgk@FreeBSD.org
@@ -16,7 +15,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs
USES= compiler:c++11-lang qmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= sboli
-GH_TAGNAME= 5b92ac5
+GH_TAGNAME= 861a323
USE_QT= core dbus gui network widgets x11extras buildtools_build
LDFLAGS+= -Wl,--as-needed # see bug#224488
diff --git a/sysutils/twmn/distinfo b/sysutils/twmn/distinfo
index 4f96af2da78b..e6d610ce9fd2 100644
--- a/sysutils/twmn/distinfo
+++ b/sysutils/twmn/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1513803467
-SHA256 (sboli-twmn-g20171216-5b92ac5_GH0.tar.gz) = bd9793942919de021e2c88f69795a2fde11441c5e9153b89a1f96ad1009774cb
-SIZE (sboli-twmn-g20171216-5b92ac5_GH0.tar.gz) = 75071
+TIMESTAMP = 1584535298
+SHA256 (sboli-twmn-g20190917-861a323_GH0.tar.gz) = d6eded8478d7eb49f23e1eb39cccd3d7981f9de7380ba0955abd86e8d2a4fc22
+SIZE (sboli-twmn-g20190917-861a323_GH0.tar.gz) = 75006
diff --git a/sysutils/twmn/files/patch-twmnd_twmnd.pro b/sysutils/twmn/files/patch-twmnd_twmnd.pro
new file mode 100644
index 000000000000..3268a1f8ef09
--- /dev/null
+++ b/sysutils/twmn/files/patch-twmnd_twmnd.pro
@@ -0,0 +1,12 @@
+--- twmnd/twmnd.pro.orig 2019-09-17 23:27:49 UTC
++++ twmnd/twmnd.pro
+@@ -10,7 +10,8 @@ TARGET = twmnd
+ TEMPLATE = app
+ CONFIG += debug
+ DESTDIR = ../bin/
+-QMAKE_CXXFLAGS += -Wall -Werror -pedantic -Wno-long-long
++QMAKE_CXXFLAGS_WARN_ON -= -W
++QMAKE_CXXFLAGS += -Wall -Werror -pedantic -Wno-long-long -Wno-error=deprecated-copy
+
+ target.path+=/usr/local/bin
+ INSTALLS += target