aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-08-30 01:15:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-08-30 01:15:20 +0000
commit66974c6f5e2effaf4876717db889bcc3add90b04 (patch)
tree4f0c4b4206e69537be195d51aa2a26f486b60e75
parentc06669b079ccb292a393be3403fd36e66332a4ae (diff)
downloadports-66974c6f5e2effaf4876717db889bcc3add90b04.tar.gz
ports-66974c6f5e2effaf4876717db889bcc3add90b04.zip
Convert astro to USES=gmake
While here: - Trim headers - Use shebangfix when needed - Convert to new perl5 world
Notes
Notes: svn path=/head/; revision=325648
-rw-r--r--astro/astrometry/Makefile8
-rw-r--r--astro/fowsr/Makefile2
-rw-r--r--astro/foxtrotgps/Makefile14
-rw-r--r--astro/glunarclock/Makefile4
-rw-r--r--astro/gpscorrelate/Makefile2
-rw-r--r--astro/gpsdrive/Makefile3
-rw-r--r--astro/libosmpbf/Makefile2
-rw-r--r--astro/libroadnav/Makefile2
-rw-r--r--astro/marble/Makefile3
-rw-r--r--astro/mymoon/Makefile8
-rw-r--r--astro/nightfall/Makefile3
-rw-r--r--astro/openuniverse/Makefile8
-rw-r--r--astro/planets/Makefile2
-rw-r--r--astro/rmap/Makefile2
-rw-r--r--astro/roadnav/Makefile2
-rw-r--r--astro/sextractor/Makefile2
-rw-r--r--astro/starplot/Makefile3
-rw-r--r--astro/swe/Makefile2
-rw-r--r--astro/wcslib/Makefile20
-rw-r--r--astro/wmjupiter/Makefile8
-rw-r--r--astro/wmmoonclock/Makefile2
-rw-r--r--astro/wmsolar/Makefile2
-rw-r--r--astro/xglobe/Makefile8
-rw-r--r--astro/xtide/Makefile2
24 files changed, 44 insertions, 70 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index 805ca6f79dc7..daa0ef4fb2ef 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: astrometry
-# Date created: 7 July 2009
-# Whom: Dereckson <dereckson@gmail.com>
-#
+# Created by: Dereckson <dereckson@gmail.com>
# $FreeBSD$
-#
PORTNAME= astrometry
PORTVERSION= 0.34
@@ -22,8 +18,8 @@ LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
+USES= gmake
USE_PYTHON= 2.5+
-USE_GMAKE= yes
ALL_TARGET= all extra
MAKE_ENV= INSTALL_DIR=${PREFIX}/astrometry
MAKE_JOBS_UNSAFE= yes
diff --git a/astro/fowsr/Makefile b/astro/fowsr/Makefile
index 987ea5ce1e2b..4942111d1fc2 100644
--- a/astro/fowsr/Makefile
+++ b/astro/fowsr/Makefile
@@ -16,7 +16,7 @@ FILEVER= 1.0
FILEDATE= 20100718
WRKSRC= ${WRKDIR}/${PORTNAME}-${FILEVER}
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/fowsr
diff --git a/astro/foxtrotgps/Makefile b/astro/foxtrotgps/Makefile
index f68624073276..fc8ab25b39c0 100644
--- a/astro/foxtrotgps/Makefile
+++ b/astro/foxtrotgps/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= astro geography
MASTER_SITES= http://www.foxtrotgps.org/releases/
MAINTAINER= crwhipp@gmail.com
-COMMENT= A lightweight opensource gps moving map application
+COMMENT= Lightweight opensource gps moving map application
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
exif:${PORTSDIR}/graphics/libexif \
@@ -16,10 +16,12 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
gps:${PORTSDIR}/astro/gpsd
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= gettext
+USES= gettext gmake pkgconfig shebangfix
+SHEBANG_FILES= contrib/convert2gpx \
+ contrib/convert2osm \
+ contrib/georss2foxtrotgps-poi
-USE_GNOME= gtk20 gconf2 libxml2 intltool pkgconfig libglade2
+USE_GNOME= gtk20 gconf2 libxml2 intltool libglade2
USE_SQLITE= 3
INSTALLS_ICONS= yes
@@ -27,8 +29,4 @@ GCONF_SCHEMAS= apps_foxtrotgps.schemas
MAN1= foxtrotgps.1 convert2gpx.1 convert2osm.1
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/contrib/convert2gpx ${WRKSRC}/contrib/convert2osm
- @${REINPLACE_CMD} -e 's|/usr/bin/python|${LOCALBASE}/bin/python|' ${WRKSRC}/contrib/georss2foxtrotgps-poi
-
.include <bsd.port.mk>
diff --git a/astro/glunarclock/Makefile b/astro/glunarclock/Makefile
index c1990f64b941..bf992cc10491 100644
--- a/astro/glunarclock/Makefile
+++ b/astro/glunarclock/Makefile
@@ -1,6 +1,7 @@
# Created by: Vincent Tantardini <vinc@freebsd-fr.org>
# $FreeBSD$
# $MCom: ports/astro/glunarclock/Makefile,v 1.12 2009/04/07 03:25:51 marcus Exp $
+
PORTNAME= glunarclock
PORTVERSION= 0.34.1
PORTREVISION= 1
@@ -12,9 +13,8 @@ COMMENT= GNOME applet that displays the current phase of the Moon
LIB_DEPENDS= xklavier.12:${PORTSDIR}/x11/libxklavier
-USES= pathfix gettext
+USES= pathfix gettext gmake
USE_GNOME= gnomepanel gnomeprefix intlhack libgnomeui
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/astro/gpscorrelate/Makefile b/astro/gpscorrelate/Makefile
index ebb0f62014e9..66b70c9f04fb 100644
--- a/astro/gpscorrelate/Makefile
+++ b/astro/gpscorrelate/Makefile
@@ -22,8 +22,8 @@ USE_GITHUB= yes
GH_ACCOUNT= freefoote
GH_COMMIT= a36646b
+USES= gmake
USE_GNOME= libxml2
-USE_GMAKE= yes
MAN1= gpscorrelate.1
MLINKS= gpscorrelate.1 gpscorrelate-gui.1
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index f260442c4f2b..71ce40eb059c 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -15,9 +15,8 @@ LICENSE= GPLv2
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
-USES= perl5
+USES= gmake perl5
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
USE_GNOME= gtk20
USE_LDCONFIG= yes
diff --git a/astro/libosmpbf/Makefile b/astro/libosmpbf/Makefile
index 846bf2059978..ed80ead759b8 100644
--- a/astro/libosmpbf/Makefile
+++ b/astro/libosmpbf/Makefile
@@ -18,7 +18,7 @@ GH_PROJECT= OSM-binary
GH_TAGNAME= v${PORTVERSION}
GH_COMMIT= d9be2d1
-USE_GMAKE= yes
+USES= gmake
BUILD_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${WRKSRC}/src
diff --git a/astro/libroadnav/Makefile b/astro/libroadnav/Makefile
index 9fce7c613d93..33fa9edb6769 100644
--- a/astro/libroadnav/Makefile
+++ b/astro/libroadnav/Makefile
@@ -12,7 +12,7 @@ COMMENT= Helper library for Roadnav (3D GPS mapping program)
USE_WX= 2.6+
WX_COMPS= wx contrib
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-prefix=${LOCALBASE} --with-wx-config=${WX_CONFIG}
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index 1b369229c5d6..b3c259eaa127 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -13,12 +13,11 @@ COMMENT= Virtual globe and world atlas for KDE
CONFLICTS= kdeedu-4.4.[0-4]
USE_KDE4= kdehier kdelibs kdeprefix automoc4 sharedmime
-USES= cmake:outsource
+USES= cmake:outsource gmake
USE_QT4= corelib dbus declarative designer_build gui network phonon \
qtestlib script sql svg webkit xml \
qmake_build moc_build rcc_build uic_build
USE_XZ= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
MAKE_ENV= XDG_CONFIG_HOME=/dev/null
CMAKE_ARGS= -DMOBILE:BOOL=FALSE
diff --git a/astro/mymoon/Makefile b/astro/mymoon/Makefile
index 01998318fab0..adc73a20289a 100644
--- a/astro/mymoon/Makefile
+++ b/astro/mymoon/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mymoon
-# Date created: 24 May 2003
-# Whom: Kirill Ponomarew <ponomarew@oberon.net>
-#
+# Created by: Kirill Ponomarew <ponomarew@oberon.net>
# $FreeBSD$
-#
PORTNAME= mymoon
DISTVERSION= 1.2a
@@ -21,7 +17,7 @@ LIB_DEPENDS= nova:${PORTSDIR}/astro/libnova
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index 78827bc6f375..38e88afabf09 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -14,9 +14,8 @@ OPTIONS_DEFINE= GNOME PGPLOT OPENGL
OPTIONS_DEFAULT= PGPLOT OPENGL
PGPLOT_DESC= Enable PGPLOT support
-USES= pathfix gettext perl5
+USES= gmake pathfix gettext perl5
USE_GNOME= gnomehier gtk20
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/astro/openuniverse/Makefile b/astro/openuniverse/Makefile
index a77c548933ad..e8c46f5b375b 100644
--- a/astro/openuniverse/Makefile
+++ b/astro/openuniverse/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: openuniverse
-# Date created: 4 August 1998
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= openuniverse
DISTVERSION= 1.0beta3
@@ -18,9 +14,9 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
USE_GL= glut
+USES= gmake
USE_XORG= sm ice xmu xi xext x11
GNU_CONFIGURE= yes
-USE_GMAKE= yes
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
diff --git a/astro/planets/Makefile b/astro/planets/Makefile
index 967e6924c03c..9eeaf6cdf72e 100644
--- a/astro/planets/Makefile
+++ b/astro/planets/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= ocaml:${PORTSDIR}/lang/ocaml
-USE_GMAKE= yes
+USES= gmake
ALL_TARGET= ${PORTNAME}
MAN1= planets.1
diff --git a/astro/rmap/Makefile b/astro/rmap/Makefile
index 6c25d8bd483b..7b29e73d78b0 100644
--- a/astro/rmap/Makefile
+++ b/astro/rmap/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
MAN1= rmap.1
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
diff --git a/astro/roadnav/Makefile b/astro/roadnav/Makefile
index f518edf9e604..c4e1db149be6 100644
--- a/astro/roadnav/Makefile
+++ b/astro/roadnav/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libroadnav.a:${PORTSDIR}/astro/libroadnav
USE_WX= 2.6+
WX_COMPS= wx contrib
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-prefix=${LOCALBASE} --with-wx-config=${WX_CONFIG}
diff --git a/astro/sextractor/Makefile b/astro/sextractor/Makefile
index 68b34cb17ac2..3d97b2168e67 100644
--- a/astro/sextractor/Makefile
+++ b/astro/sextractor/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= mathias@monnerville.com
COMMENT= Catalogue of objects builder from astronomical images
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
MAN1= sex.1
MANX= sex.x
diff --git a/astro/starplot/Makefile b/astro/starplot/Makefile
index 6fe90a321d82..504d8f55f59e 100644
--- a/astro/starplot/Makefile
+++ b/astro/starplot/Makefile
@@ -10,9 +10,8 @@ MASTER_SITES= http://starplot.org/downloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= 3-dimensional viewer for star charts
-USES= pathfix gettext
+USES= gmake pathfix gettext
USE_GNOME= gtk20
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/astro/swe/Makefile b/astro/swe/Makefile
index 222f3cda9b2c..296b0ac29bf7 100644
--- a/astro/swe/Makefile
+++ b/astro/swe/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= 5u623l20@gmail.com
COMMENT= High Precision Ephemeris Developed By Astrodienst
WRKSRC= ${WRKDIR}/src
-USE_GMAKE= yes
+USES= gmake
ALL_TARGET= #
USE_LDCONFIG= yes
diff --git a/astro/wcslib/Makefile b/astro/wcslib/Makefile
index 22afdd2d9098..4f0659627000 100644
--- a/astro/wcslib/Makefile
+++ b/astro/wcslib/Makefile
@@ -1,27 +1,27 @@
# Created by: Tony Maher <tonymaher@optusnet.com.au>
# $FreeBSD$
-PORTNAME= wcslib
+PORTNAME= wcslib
PORTVERSION= 4.13.4
-CATEGORIES= astro
+CATEGORIES= astro
MASTER_SITES= ftp://ftp.atnf.csiro.au/pub/software/wcslib/
-MAINTAINER= tonymaher@optusnet.com.au
-COMMENT= Library for parsing/generating FITS headers
+MAINTAINER= tonymaher@optusnet.com.au
+COMMENT= Library for parsing/generating FITS headers
-USE_BZIP2= yes
+USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-MAKEFILE= GNUmakefile
+USES= gmake
+MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
-PLIST_SUB= VERSION="${PORTVERSION}"
-MAN1= fitshdr.1
+PLIST_SUB= VERSION="${PORTVERSION}"
+MAN1= fitshdr.1
# See makedefs.in which describes why you want to set the extra support.
# For most users it will not be required.
-OPTIONS_DEFINE= CFITSIO PGPLOT
+OPTIONS_DEFINE= CFITSIO PGPLOT
CFITSIO_DESC= Add cfitsio support (for tests only)
PGPLOT_DESC= Add pgplot support (for tests only)
diff --git a/astro/wmjupiter/Makefile b/astro/wmjupiter/Makefile
index 10572ddbe7a6..4c6af25b91a6 100644
--- a/astro/wmjupiter/Makefile
+++ b/astro/wmjupiter/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmjupiter
-# Date created: Tue Jan 15 17:28:49 EST 2002
-# Whom: pat
-#
+# Created by: pat
# $FreeBSD$
-#
PORTNAME= wmjupiter
PORTVERSION= 1.2
@@ -17,7 +13,7 @@ COMMENT= Dockapp that displays information on Jupiter
PLIST_FILES= bin/wmJupiter
WRKSRC= ${WRKDIR}/wmJupiter
USE_XORG= x11 xext xpm
-USE_GMAKE= yes
+USES= gmake
pre-patch:
@${REINPLACE_CMD} -e 's|values.h|float.h|; s|MAXDOUBLE|DBL_MAX|g' \
diff --git a/astro/wmmoonclock/Makefile b/astro/wmmoonclock/Makefile
index 1374f8a88cdc..190efcc8a421 100644
--- a/astro/wmmoonclock/Makefile
+++ b/astro/wmmoonclock/Makefile
@@ -13,7 +13,7 @@ COMMENT= Displays the phase of the moon, plus orbital data
WRKSRC= ${WRKDIR}/${DISTNAME}/Src
USE_XORG= xpm
-USE_GMAKE= yes
+USES= gmake
MAN1= wmmoonclock.1
PLIST_FILES= bin/wmmoonclock
diff --git a/astro/wmsolar/Makefile b/astro/wmsolar/Makefile
index 8a02ce614e4d..5bfed0ecb28c 100644
--- a/astro/wmsolar/Makefile
+++ b/astro/wmsolar/Makefile
@@ -13,7 +13,7 @@ COMMENT= Dockapp that displays the Solar System viewed from the top
PLIST_FILES= bin/wmSolar
WRKSRC= ${WRKDIR}/wmSolar
USE_XORG= x11 xext xpm
-USE_GMAKE= yes
+USES= gmake
pre-patch:
@${REINPLACE_CMD} -e 's|values.h|float.h|; s|MAXDOUBLE|DBL_MAX|g' \
diff --git a/astro/xglobe/Makefile b/astro/xglobe/Makefile
index 9fd4df41b322..f731cc25a142 100644
--- a/astro/xglobe/Makefile
+++ b/astro/xglobe/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xglobe
-# Date created: 20 January 1998
-# Whom: Kris Kennaway <kris@FreeBSD.org>
-#
+# Created by: Kris Kennaway <kris@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xglobe
PORTVERSION= 0.5
@@ -15,8 +11,8 @@ MASTER_SITE_SUBDIR=kris
MAINTAINER= ports@FreeBSD.org
COMMENT= Displays a view of the Earth (like xearth) with a rendered photo map
+USES= gmake
USE_QT4= corelib gui qt3support moc_build
-USE_GMAKE= yes
MAKE_ENV= QT_PREFIX=${QT_PREFIX}
do-install:
diff --git a/astro/xtide/Makefile b/astro/xtide/Makefile
index 1427a30a6ed1..ee4fbbe22bd0 100644
--- a/astro/xtide/Makefile
+++ b/astro/xtide/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv3
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
USE_GCC= yes
GNU_CONFIGURE= yes