aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-22 00:58:50 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-22 01:24:36 +0000
commit66f32c9dd235dbabda1fbe032194f159aa00d7a7 (patch)
tree41e29eb268cdbc1a69bdb248e697b620de348ec2
parente216badd22213c1654b46954576b85887a0a92b7 (diff)
downloadports-66f32c9dd235dbabda1fbe032194f159aa00d7a7.tar.gz
ports-66f32c9dd235dbabda1fbe032194f159aa00d7a7.zip
lang/php81: Update version 8.1.26=>8.1.27
- Remove unnecesary patches from devel/php82-readline [1] Changelog: https://www.php.net/ChangeLog-8.php#8.1.27 PR: 275795 [1] Reported by: x0r+freebsd@x0r.fr [1]
-rw-r--r--devel/php81-readline/files/patch-config.m433
-rw-r--r--devel/php81-readline/files/patch-readline_cli.c13
-rw-r--r--lang/php81/Makefile4
-rw-r--r--lang/php81/distinfo6
-rw-r--r--sysutils/php81-posix/files/patch-posix.c38
-rw-r--r--www/php81-opcache/files/patch-config.m420
6 files changed, 5 insertions, 109 deletions
diff --git a/devel/php81-readline/files/patch-config.m4 b/devel/php81-readline/files/patch-config.m4
deleted file mode 100644
index 93799734a3e3..000000000000
--- a/devel/php81-readline/files/patch-config.m4
+++ /dev/null
@@ -1,33 +0,0 @@
---- config.m4.orig 2019-08-06 06:54:14 UTC
-+++ config.m4
-@@ -3,16 +3,10 @@ PHP_ARG_WITH([libedit],
- [AS_HELP_STRING([--with-libedit],
- [Include libedit readline replacement (CLI/CGI only)])])
-
--if test "$PHP_LIBEDIT" = "no"; then
- PHP_ARG_WITH([readline],
- [for readline support],
- [AS_HELP_STRING([[--with-readline[=DIR]]],
- [Include readline support (CLI/CGI only)])])
--else
-- dnl "register" the --with-readline option to prevent invalid "unknown
-- dnl configure option" warning
-- php_with_readline=no
--fi
-
- if test "$PHP_READLINE" && test "$PHP_READLINE" != "no"; then
- for i in $PHP_READLINE /usr/local /usr; do
-@@ -78,6 +72,13 @@ if test "$PHP_READLINE" && test "$PHP_RE
- AC_DEFINE(HAVE_HISTORY_LIST, 1, [ ])
- AC_DEFINE(HAVE_LIBREADLINE, 1, [ ])
-
-+ PHP_CHECK_LIBRARY(readline, rl_completion_matches,
-+ [
-+ AC_DEFINE(HAVE_RL_COMPLETION_MATCHES, 1, [ ])
-+ ],[],[
-+ -L$READLINE_DIR/$PHP_LIBDIR $PHP_READLINE_LIBS
-+ ])
-+
- elif test "$PHP_LIBEDIT" != "no"; then
- if test "$PHP_LIBEDIT" != "yes"; then
- AC_MSG_WARN([libedit directory ignored, rely on pkg-config])
diff --git a/devel/php81-readline/files/patch-readline_cli.c b/devel/php81-readline/files/patch-readline_cli.c
deleted file mode 100644
index 02f55974f9b0..000000000000
--- a/devel/php81-readline/files/patch-readline_cli.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- readline_cli.c.orig 2012-03-02 16:40:26.000000000 +0100
-+++ readline_cli.c 2012-03-02 16:40:43.000000000 +0100
-@@ -19,6 +19,10 @@
-
- /* $Id: readline_cli.c 321634 2012-01-01 13:15:04Z felipe $ */
-
-+#ifdef HAVE_CONFIG_H
-+#include "config.h"
-+#endif
-+
- #include "php.h"
-
- #ifndef HAVE_RL_COMPLETION_MATCHES
diff --git a/lang/php81/Makefile b/lang/php81/Makefile
index e340f547fbd9..fab31bbe1592 100644
--- a/lang/php81/Makefile
+++ b/lang/php81/Makefile
@@ -1,6 +1,6 @@
PORTNAME= php81
-DISTVERSION= 8.1.26
-PORTREVISION= 1
+DISTVERSION= 8.1.27
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${DISTVERSION}
diff --git a/lang/php81/distinfo b/lang/php81/distinfo
index 950c878c78d3..02839706ac95 100644
--- a/lang/php81/distinfo
+++ b/lang/php81/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1700690550
-SHA256 (php-8.1.26.tar.xz) = 17f87133596449327451ad4b8d9911bfaea59ff5109f3a6f2bb679f967a8ea0f
-SIZE (php-8.1.26.tar.xz) = 11809448
+TIMESTAMP = 1703153725
+SHA256 (php-8.1.27.tar.xz) = 479e65c3f05714d4aace1370e617d78e49e996ec7a7579a5be47535be61f0658
+SIZE (php-8.1.27.tar.xz) = 11915228
diff --git a/sysutils/php81-posix/files/patch-posix.c b/sysutils/php81-posix/files/patch-posix.c
deleted file mode 100644
index d2365b249569..000000000000
--- a/sysutils/php81-posix/files/patch-posix.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- posix.c.orig Fri Feb 23 00:40:39 2007
-+++ posix.c Sun May 13 17:52:27 2007
-@@ -838,7 +838,7 @@
- #if defined(ZTS) && defined(HAVE_GETGRNAM_R) && defined(_SC_GETGR_R_SIZE_MAX)
- buflen = sysconf(_SC_GETGR_R_SIZE_MAX);
- if (buflen < 1) {
-- RETURN_FALSE;
-+ buflen = 1024;
- }
- buf = emalloc(buflen);
- g = &gbuf;
-@@ -888,7 +888,7 @@
-
- grbuflen = sysconf(_SC_GETGR_R_SIZE_MAX);
- if (grbuflen < 1) {
-- RETURN_FALSE;
-+ grbuflen = 1024;
- }
-
- grbuf = emalloc(grbuflen);
-@@ -955,7 +955,7 @@
- #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWNAM_R)
- buflen = sysconf(_SC_GETPW_R_SIZE_MAX);
- if (buflen < 1) {
-- RETURN_FALSE;
-+ buflen = 1024;
- }
- buf = emalloc(buflen);
- pw = &pwbuf;
-@@ -1004,7 +1004,7 @@
- #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWUID_R)
- pwbuflen = sysconf(_SC_GETPW_R_SIZE_MAX);
- if (pwbuflen < 1) {
-- RETURN_FALSE;
-+ pwbuflen = 1024;
- }
- pwbuf = emalloc(pwbuflen);
-
diff --git a/www/php81-opcache/files/patch-config.m4 b/www/php81-opcache/files/patch-config.m4
deleted file mode 100644
index 7bd2cb9083fd..000000000000
--- a/www/php81-opcache/files/patch-config.m4
+++ /dev/null
@@ -1,20 +0,0 @@
---- config.m4.orig 2021-12-15 02:00:45 UTC
-+++ config.m4
-@@ -29,7 +29,7 @@ if test "$PHP_OPCACHE" != "no"; then
-
- if test "$PHP_OPCACHE_JIT" = "yes"; then
- case $host_cpu in
-- i[[34567]]86*|x86*|aarch64)
-+ i[[34567]]86*|x86*|aarch64|amd64)
- ;;
- *)
- AC_MSG_WARN([JIT not supported by host architecture])
-@@ -48,7 +48,7 @@ if test "$PHP_OPCACHE" != "no"; then
- DASM_FLAGS="-D X64APPLE=1 -D X64=1"
- DASM_ARCH="x86"
- ;;
-- x86_64*)
-+ *x86_64*|amd64-*-freebsd*)
- DASM_FLAGS="-D X64=1"
- DASM_ARCH="x86"
- ;;